General Active Sport Steering gone really light.. power steering problem?

Currently reading:
General Active Sport Steering gone really light.. power steering problem?

andyleem

New member
Joined
Jul 19, 2007
Messages
9
Hi,
I would like a little help and advice on this problem i have noticed yesterday.
I appears that something is different with the power steering, it is much lighter than normal and the city mode is not on.
It is almost as light as city mode, but doesnt have the same feeling etc.
I have tried turning city mode on and off to try and fix it but it still is doing it.

Punto is a 2003 active sport 37000 miles.

Any help appreciated.
thanks
 

The Sultan

Bravo 1.8 HLX FTW
Joined
Jul 28, 2006
Messages
4,217
Location
lake windermere east edge
37k have you just had a 36k service by any chance may have blown your tyres up a bit

other reasons may have faulty torque position sensors in the column

nether heard anything like it myself

does your city button make it lighter still or stay the same
 
OP
OP
A

andyleem

New member
Joined
Jul 19, 2007
Messages
9
Yep has 36k Service.
City mode makes the steering lights, like allows the wheel to turn all the ay round easier, how ever with city mode off it seems it only goes light once driving.
 

sharonN

New member
Joined
May 12, 2011
Messages
1
Hi,
I would like a little help and advice on this problem i have noticed yesterday.
I appears that something is different with the power steering, it is much lighter than normal and the city mode is not on.
It is almost as light as city mode, but doesnt have the same feeling etc.
I have tried turning city mode on and off to try and fix it but it still is doing it.

Punto is a 2003 active sport 37000 miles.

Any help appreciated.
thanks
HI Andy,

Just joined this site as I was looking for advice - have had exactly the same prob you describe. Just bought the car (second hand with only 10,500 miles on clock) 6 months ago and steering wasn't this light when I bought it. Wondering if you sorted your problem out and what it was in the end. Have now taken it to garage but no fault code is registering on diagnostic.
 
Joined
Apr 8, 2008
Messages
16,742
HI Andy,

Just joined this site as I was looking for advice - have had exactly the same prob you describe. Just bought the car (second hand with only 10,500 miles on clock) 6 months ago and steering wasn't this light when I bought it. Wondering if you sorted your problem out and what it was in the end. Have now taken it to garage but no fault code is registering on diagnostic.

1stly Welcome

2ndly - a 5 year old thread :cry::cry:

3rdly - Have you also checked tyre pressure also check if city is on or not

Having light steering is one of the keys features - but over light (like city mode) is weird to drive with

Also have you had you tyres changed recently?

Ziggy
 

DaveMcT

Well-known member
Joined
Sep 14, 2009
Messages
18,443
Asuming the OP has a Punto Mk2 or 2a. Time is every bit as harmful as miles. In some cases (like brakes) time is more damaging.

Even with "0nly" 10,000 miles on the clock the car is going to be fairly old so will need a proper service. If you dont have recent receipts get cam belt done, ALL fluids changed and the brakes closely examined.
 
Top