General Sei EPS Problems.....help!!!!

Currently reading:
General Sei EPS Problems.....help!!!!

1stFiat

New member
Joined
Oct 1, 2007
Messages
5
Just become the proud owner of a little fiat and after a few repair jobs (CAM BELT!!) I put her in for an MOT and it failed on the power steering! :bang:

Does ne1 know of any common problems with the EPS?

It steers left easliy, almost by its self but is heavy to the right.

Thanx

Gaz
 
Last edited:
Joined
Feb 16, 2005
Messages
5,983
what exactly was the fail? You have a light on the dash board? it have a mind of its own?

Kristian
 
OP
OP
1

1stFiat

New member
Joined
Oct 1, 2007
Messages
5
It steers to the right on its own when on a ramps turn plate but is heavy to the left, but its not got a light on the dash.

Gaz:bang:
 

T14086

Forum Moderator
Joined
Sep 12, 2004
Messages
39,858
Location
Preston
mmmm sounds like needs new column at first impressions,changed a few but its not a common fault like the puntos.(all ok underneath & suspension wise?)
 
Joined
Feb 3, 2006
Messages
2,660
Location
Nottingham
I think the sensors are built into the motor assembly so new motor probably or ecu controller. would be hard to tell which without diagnostics and swopping components.
 
Joined
Feb 16, 2005
Messages
5,983
may be easier/cheaper to disable or replace for non PAS?

Disable to get it passed the MOT at least.

Kristian
 
OP
OP
1

1stFiat

New member
Joined
Oct 1, 2007
Messages
5
I've disconnected the wiring but it won't pass the MOT without it, or so i've been told. I do believe the sensors are within the motor mounted on the column. Hope gonna get the diagnostic kit on it tommorrow but just wanted to see if anyone else had ever heard of the problem.


Gaz
 
Joined
Feb 3, 2006
Messages
2,660
Location
Nottingham
may be easier/cheaper to disable or replace for non PAS?

Disable to get it passed the MOT at least.

Kristian

Yep! Pull the fuse. I think it's behind the battery.
The motors come complete with column and are big bucks new. I'd start searching scrappies for a column as these tend to be the fault. Steal ..Sorry obtain the ecu whilst your there to be shure.
 
OP
OP
1

1stFiat

New member
Joined
Oct 1, 2007
Messages
5
Thanks for the bad news!!!! :bang:

I might have a look around and see if any one reconditions them.


Gaz
 
Joined
Feb 3, 2006
Messages
2,660
Location
Nottingham
There is a chance the brushes are gone but you would have to try and strip it down to find out. Look in the clasifieds as there are some seicento's breaking ref dave and try ebay.
 
OP
OP
1

1stFiat

New member
Joined
Oct 1, 2007
Messages
5
Morning chaps! Completely forgot I have a mate who works for a fiat dealership so i'm gonna pop in there today, I'll let you know what they say.

Hoping for a cheap fix! (y)

Gaz
 

AppleSei

RIP L181 VBB
Joined
Feb 20, 2005
Messages
16,628
Location
West Yorks
Hope gonna get the diagnostic kit on it tommorrow but just wanted to see if anyone else had ever heard of the problem.

Nope does not occur often on a sei, the puntos they have had a problem with PAS components/steering components in the past though.

Extreme rarity, hope you get the quick fix you hope for, although with any steering component, be expected to perhaps shell out however as the steering is one of the most important things (y)
 
Top