Technical Check transmission red warning light

Currently reading:
Technical Check transmission red warning light

Sjimlee24

New member
Joined
Nov 6, 2022
Messages
6
Location
Gateshead Tyne&wear
Hi all new to the forum, don’t know if I’m doing this right?! If anyone does see this…. Well, last night driving back from fireworks display a red “check transmission appeared” only owned the car a month never had any problems apart from this, it’s a 65plate 500L popstar multijet semi automatic. So I instantly pulled over and turned off the ignition. Turned it back on to still find the message but the car got us back home with no other issues it drove as normal etc. so this morning I’ve turned on the ignition and it just keeps knocking itself into Neutral. I have checked the transmission fluid it looks full does have a orangey/brown colour don’t know if this is normal, as I know nothing about cars! Any help would be much appreciated.
 

Pino65

New member
Joined
Jan 18, 2020
Messages
22
Hi all new to the forum, don’t know if I’m doing this right?! If anyone does see this…. Well, last night driving back from fireworks display a red “check transmission appeared” only owned the car a month never had any problems apart from this, it’s a 65plate 500L popstar multijet semi automatic. So I instantly pulled over and turned off the ignition. Turned it back on to still find the message but the car got us back home with no other issues it drove as normal etc. so this morning I’ve turned on the ignition and it just keeps knocking itself into Neutral. I have checked the transmission fluid it looks full does have a orangey/brown colour don’t know if this is normal, as I know nothing about cars! Any help would be much appreciated.
Have you checked the special hydraulic fluid reservoir stiuated on the top of gearbox?
I also had the same light and it actually was a worn clutch (since replaced at 127000 miles) hope that helps?
 
OP
OP
S

Sjimlee24

New member
Joined
Nov 6, 2022
Messages
6
Location
Gateshead Tyne&wear
Have you checked the special hydraulic fluid reservoir stiuated on the top of gearbox?
I also had the same light and it actually was a worn clutch (since replaced at 127000 miles) hope that helps?
Hi, thanks for your reply 👍 so I had it to the garage they said they changed the neutral switch…. All was okay for a few days and the light has come back on, I will put this forward to them when I take it back. Thanks so much
 
Top