Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 01-11-2014   #16
'13 Punto MultiAir 105
 
austenw90's Avatar
Join Date: Mar 2012
Location: Southampton
Posts: 870
Thanks: 26
Trader Rating: 0
austenw90 has donated!
United Kingdom 
Re: Running rough and engine light flashing

Quote Originally Posted by JTD_Liam View Post
Sorry, I somehow managed to miss this thread when I've logged in over the last few days. Glad the dealer was helpful. They did offer the 105 MultiAir in the MiTo but few were sold here. Most people seemed to go with the non-MultiAir 1.4 (78 or 95bhp) or the MultiAir Turbo 135.

It does seem mostly the 135 and 170 MultiAir's that the MA unit goes on, but that might be down to sales volumes as much as anything else. I'm sure at least one person had a problem with oil round the spark plugs on their 105 MultiAir Punto, which I believe is linked to MA unit failure, but if it's working again now, just keep an eye on it. It'd be running rough all the time if it'd failed. The dealer should have a log of the cars visit now, so if it does fail down the line hopefully there should be no fuss getting it replaced FOC - they cost about 900 otherwise, from reading about the Alfa failures.
Thanks Liam.

Them logging the incident was my main reason for going in to the dealers apart from making sure everything was ok or not.

I would have gone for the 135 but there were none about at the time less than 3 years old, I thought I'd play it safe and go for one within warranty.

I've had a few faster cars in the last few years and just wanted something comfortable, petrol and economical which this is. Together with the Lounge spec it's a great car and they are so cheap to pick up a year to two years old. I paid 7500 for my 13 reg with 9000 miles on.

I'm quite impressed with the little 105, it's quick enough and just has that bit more than the 1.4 8v which my parents have and is a great car.

900 isn't a huge amount in the scheme of things, especially when Skoda (VAG) typically pay 3300 excluding labour to swap the engine is the huge number of failed 1.4 twin chargers fitted in the Fabia vRS and the Polo GTi, Audi A1 and Seat Ibiza. Imagine that bill out of warranty! Some owners have had to battle to get them to sort their cars within warranty I believe.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by austenw90; 01-11-2014 at 08:02.
austenw90 is offline Reply With Quote Quote 
Old 04-01-2015   #17
Join Date: Jan 2015
Posts: 18
Thanks: 1
Trader Rating: 0
United Kingdom 
Quote Originally Posted by austenw90 View Post
Thanks Liam.

Them logging the incident was my main reason for going in to the dealers apart from making sure everything was ok or not.

I would have gone for the 135 but there were none about at the time less than 3 years old, I thought I'd play it safe and go for one within warranty.

I've had a few faster cars in the last few years and just wanted something comfortable, petrol and economical which this is. Together with the Lounge spec it's a great car and they are so cheap to pick up a year to two years old. I paid 7500 for my 13 reg with 9000 miles on.

I'm quite impressed with the little 105, it's quick enough and just has that bit more than the 1.4 8v which my parents have and is a great car.

900 isn't a huge amount in the scheme of things, especially when Skoda (VAG) typically pay 3300 excluding labour to swap the engine is the huge number of failed 1.4 twin chargers fitted in the Fabia vRS and the Polo GTi, Audi A1 and Seat Ibiza. Imagine that bill out of warranty! Some owners have had to battle to get them to sort their cars within warranty I believe.
Hi, did you ever find out the reason for the issues, or has everything been ok since? I only ask as I tried to take a test drive in the same car & the same thing happened on the test drive!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dant1875 is offline Reply With Quote Quote 
Old 05-01-2015   #18
'13 Punto MultiAir 105
 
austenw90's Avatar
Join Date: Mar 2012
Location: Southampton
Posts: 870
Thanks: 26
Trader Rating: 0
austenw90 has donated!
United Kingdom 
Re: Running rough and engine light flashing

Quote Originally Posted by dant1875 View Post
Hi, did you ever find out the reason for the issues, or has everything been ok since? I only ask as I tried to take a test drive in the same car & the same thing happened on the test drive!
It's been fine since. It splutters at start up sometimes in the cold but nothing I haven't had with other cars.

It's just completed a 900 mile round trip to Scotland without issue, couldn't recommend one more. Just wish it was the 135

I've had some major reliability issues with other brands in the last year so I'm glad to be back with trusty Fiat. Fingers crossed it's all ok now but it's still within warranty and the MultiAir failures are sub 1000 repair so I'm not too worried.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

austenw90 is offline Reply With Quote Quote 
Old 05-01-2015   #19
Join Date: Jan 2015
Posts: 18
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

Thanks for the reply 👍 I'm going to bite the bullet I think & put a reservation deposit on it, then see what they say the issue was & see how it runs on the second test drive.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dant1875 is offline Reply With Quote Quote 
Old 05-01-2015   #20
'13 Punto MultiAir 105
 
austenw90's Avatar
Join Date: Mar 2012
Location: Southampton
Posts: 870
Thanks: 26
Trader Rating: 0
austenw90 has donated!
United Kingdom 
Re: Running rough and engine light flashing

Quote Originally Posted by dant1875 View Post
Thanks for the reply �� I'm going to bite the bullet I think & put a reservation deposit on it, then see what they say the issue was & see how it runs on the second test drive.
Share some photos or details if you go for it, there are so few around now.

It may be one I looked at or made an offer on... 3 months ago, possible deal to be done.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by austenw90; 05-01-2015 at 11:48.
austenw90 is offline Reply With Quote Quote 
Old 05-01-2015   #21
Join Date: Jan 2015
Posts: 18
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

Will do 😊
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dant1875 is offline Reply With Quote Quote 
Old 13-01-2015   #22
'13 Punto MultiAir 105
 
austenw90's Avatar
Join Date: Mar 2012
Location: Southampton
Posts: 870
Thanks: 26
Trader Rating: 0
austenw90 has donated!
United Kingdom 
Re: Running rough and engine light flashing

Quote Originally Posted by JTD_Liam View Post
Sorry, I somehow managed to miss this thread when I've logged in over the last few days. Glad the dealer was helpful. They did offer the 105 MultiAir in the MiTo but few were sold here. Most people seemed to go with the non-MultiAir 1.4 (78 or 95bhp) or the MultiAir Turbo 135.

It does seem mostly the 135 and 170 MultiAir's that the MA unit goes on, but that might be down to sales volumes as much as anything else. I'm sure at least one person had a problem with oil round the spark plugs on their 105 MultiAir Punto, which I believe is linked to MA unit failure, but if it's working again now, just keep an eye on it. It'd be running rough all the time if it'd failed. The dealer should have a log of the cars visit now, so if it does fail down the line hopefully there should be no fuss getting it replaced FOC - they cost about 900 otherwise, from reading about the Alfa failures.
Something I've noticed after lots of tests is that it doesn't like being started up after being parked on any kind of slope. Whether that's slightly pointing nose up (my driveway) or one side higher than the other in a road with a big camber, which is how it was parked when I experienced the original issue.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by austenw90; 13-01-2015 at 10:19.
austenw90 is offline Reply With Quote Quote 
Old 02-02-2015   #23
Join Date: Jan 2015
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

Hi I'd like to make it clear upfront I'm not a mechanic but I do own a punto evo from new 10 plate currently 72000 miles and had exactly the same issues of misfiring, running like a pig, orange warning lights coming and going. If I park on a slope head down it will run badly misfiring big style unless I stop let it settle then start up again.
I have oil getting into one cylinder around the plug my local mechanic removes the plug cleans it and off we go until it occurs again fiat replaced the multiair system two weeks before the warranty expired (FOC) but it is back again with a vengence.
next week my local garage is removing the head to inspect the gasket around the plug I am going back to fiat tomoz to enquire about the multi air unit now I have read this thread everything this post has referred to has rung a bell with me I hope my input helps us both!
I did wonder if I had used the wrong oil (fully synthetic 5/40?) or if this is even relevant?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Dalesdipstick is offline Reply With Quote Quote 
Old 03-02-2015   #24
Join Date: Jan 2015
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

update from yesterdays post visited the main dealer this morning who confirmed I had the Multi Air unit replaced at 48k in March 2013 and replaced injector coil number 4 I am sure the recall back in 2010 involved making a hole in a gasket to improve oil distribution around the engine I intend starting a fresh thread with this issue to see what comes up
Likes austenw90 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Dalesdipstick is offline Reply With Quote Quote 
Old 04-02-2015   #25
'13 Punto MultiAir 105
 
austenw90's Avatar
Join Date: Mar 2012
Location: Southampton
Posts: 870
Thanks: 26
Trader Rating: 0
austenw90 has donated!
United Kingdom 
Re: Running rough and engine light flashing

Quote Originally Posted by Dalesdipstick View Post
I did wonder if I had used the wrong oil (fully synthetic 5/40?) or if this is even relevant?
I understand that it really is fundamental that the oil isn't just the right grade but also the correct specification. That's why I tend to stick with Selenia for peace of mind.

www.shop4parts.co.uk is great for getting hold of parts including oil.

Mine seems ok now, it has the odd splutter/hesitation when turning over every now and again. It is due a service at the end of March so will get them to ensure everything is running as it should be.

The hesitation to start that I describe only seems to be when the front of the car is pointing up slope, I may have already said this, can't remember!

Keep us/me updated or maybe post a link to your thread if possible?

Thanks
__________________
2013 Punto MultiAir 105 Lounge
2014 Suzuki Swift Sport (5 door)

Last edited by austenw90; 04-02-2015 at 08:20.
austenw90 is offline Reply With Quote Quote 
Old 04-02-2015   #26
Join Date: Jan 2015
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

I will def post a link to my new post if you could let me know how to! and a big thanks for the advice on the oil I didn't know that I will also post on your thread what happens next week when they check out the gasket my main dealer wasn't at all keen to give me any info on my previous repairs except to say they replaced the multi air unit in march 2013 I am definitely getting the feeling I am being shafted by the dealer
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Dalesdipstick is offline Reply With Quote Quote 
Old 04-02-2015   #27
Join Date: Apr 2011
Location: Near the M4
Posts: 20,156
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Running rough and engine light flashing

Quote Originally Posted by Dalesdipstick View Post
I will def post a link to my new post if you could let me know how to! and a big thanks for the advice on the oil I didn't know that I will also post on your thread what happens next week when they check out the gasket my main dealer wasn't at all keen to give me any info on my previous repairs except to say they replaced the multi air unit in march 2013 I am definitely getting the feeling I am being shafted by the dealer
this one;
https://www.fiatforum.com/punto-evo/...ng-lights.html

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 05-02-2015   #28
Join Date: Jan 2015
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Dalesdipstick is offline Reply With Quote Quote 
Old 05-02-2015   #29
Join Date: Jan 2015
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Running rough and engine light flashing

ha! cheers!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Dalesdipstick is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Engine light on, rough running? worthing Grande Punto 10 12-08-2013 22:24
(T) Technical: Engine management warning light and rough running badawn Cinquecento / Seicento 12 07-01-2010 15:10
(T) Flashing engine light & rough tickover? ian grant Panda 11 12-04-2009 10:19
(T) Engine management warning light and rough running psychocandy Punto (Mk2/2b) 4 08-01-2009 14:11