Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 19-12-2018   #1
Join Date: Jul 2012
Location: Kuala Lumpur, Malaysia
Posts: 40
Thanks: 0
Trader Rating: 0
Malaysia 
Fuel Pump Doesn't Work

Hi guys,
Need a help here for my Mk2. My Fuel pump is not working. Checked voltage thru cable, reading is none when switched on. But when switched off, it showed a blinking 12V for a split second and back to 0V.
Searched thru the forums and found some suggestive ideas:
1. Check for cut off switch.
My question: Where is the exact location?
2. Check for fuel pump relay.
My question: Where is the exact location?
Your help(s) is(are) greatly appreciated.
Thank you.
Luqluq
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

luqluq is offline Reply With Quote Quote 
Old 19-12-2018   #2
Join Date: Jan 2015
Location: Helsinki
Posts: 1,485
Trader Rating: 0
judderbar has donated!
Finland 
Re: Fuel Pump Doesn't Work

Quote Originally Posted by luqluq View Post
Hi guys,
Need a help here for my Mk2. My Fuel pump is not working. Checked voltage thru cable, reading is none when switched on. But when switched off, it showed a blinking 12V for a split second and back to 0V.
Searched thru the forums and found some suggestive ideas:
1. Check for cut off switch.
My question: Where is the exact location?
2. Check for fuel pump relay.
My question: Where is the exact location?
Your help(s) is(are) greatly appreciated.
Thank you.
Luqluq
The fuel pump relay depends upon which engine fuse box arrangement you have. They have the same fuse box with different relays and fuses. The relay is one of the ones marked with the injector picture.

The cutoff switch/relay controls the purple fuel pump earth.

You can find the cut off switch/relay under the glove box on the far right hand side of a left hand drive car. It is behind the carpet at the very top of the carpet about 30 cms from the floor.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

judderbar is offline Reply With Quote Quote 
Old 19-12-2018   #3
Join Date: Mar 2011
Posts: 7,584
Thanks: 542
Trader Rating: 0
Burkina Faso (Upper Volta) 
Re: Fuel Pump Doesn't Work

if you are sure the fuel pump works?
check the earth connection on top of your throttle body
find the fuel pump switch up the front door A post on the left side as you look out of the windscreen
the relay is behind the dash,cant remember where but look at the bsi relays first,you should hear it click when ignition first turned on assuming your key is being recognised at cranking
__________________
s and b is offline Reply With Quote Quote 
Old 20-12-2018   #4
Join Date: Jul 2012
Location: Kuala Lumpur, Malaysia
Posts: 40
Thanks: 0
Trader Rating: 0
Malaysia 
Re: Fuel Pump Doesn't Work

Dear Judderbar & S n B,

Thank you very much your your kind replies. Managed to find the cut-off switch and the relay marked T10 with the injection symbol.

So this morning, quickly sourced for the parts. Did for the cut off switch first and no effect. After that, changed the relay and ... Hurrah!!! the burst of fuel came out from the fuel pump.

Thank you very much guys for your kind helps. I'm smiling from ear to ear now, the engine is purring as before

Luqluq

(S n B, FYI, the pump that I replaced has already been checked before, thanks)
Likes varesecrazy, judderbar liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

luqluq is offline Reply With Quote Quote 
Old 26-12-2018   #5
Join Date: Jul 2012
Location: Kuala Lumpur, Malaysia
Posts: 40
Thanks: 0
Trader Rating: 0
Malaysia 
Re: Fuel Pump Doesn't Work

Last weekend, I put back the fuel pump back to the donor car where it originated. The pump is working but when installed back, it didn't work any more. I replaced the T10 relay and tried, it didn't start. After that, I replaced the cut off switch and even after that, direct connect, it still didn't start. Then I connect the fuel pump directly to battery, only it can start.
My questions:
1. What is the possible cause on the circuit? The donor car engine used to be running ok.

2. If the pump is connected to battery, means it's running continuously, will it be bad to the system?
Thank you.
Luqluq
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

luqluq is offline Reply With Quote Quote 
Old 26-12-2018   #6
Join Date: Apr 2011
Location: Near the M4
Posts: 20,124
Thanks: 719
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by judderbar View Post
The fuel pump relay depends upon which engine fuse box arrangement you have. They have the same fuse box with different relays and fuses. The relay is one of the ones marked with the injector picture.

The cutoff switch/relay controls the purple fuel pump earth.

You can find the cut off switch/relay under the glove box on the far right hand side of a left hand drive car. It is behind the carpet at the very top of the carpet about 30 cms from the floor.
@luqluq

This appear to offer the answer.

Different options on the route of power supply.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 26-12-2018   #7
Join Date: Dec 2018
Posts: 6
Thanks: 0
Trader Rating: 0
South Africa 
Re: Fuel Pump Doesn't Work

How did you connect the fuel pump
direct to the battery
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jesusminmy is offline Reply With Quote Quote 
Old 26-12-2018   #8
Join Date: Jan 2015
Location: Helsinki
Posts: 1,485
Trader Rating: 0
judderbar has donated!
Finland 
Re: Fuel Pump Doesn't Work

Quote Originally Posted by luqluq View Post
Last weekend, I put back the fuel pump back to the donor car where it originated. The pump is working but when installed back, it didn't work any more. I replaced the T10 relay and tried, it didn't start. After that, I replaced the cut off switch and even after that, direct connect, it still didn't start. Then I connect the fuel pump directly to battery, only it can start.
My questions:
1. What is the possible cause on the circuit? The donor car engine used to be running ok.

2. If the pump is connected to battery, means it's running continuously, will it be bad to the system?
Thank you.
Luqluq
Are you confidant you are using the donor cars key to start the car? does the key code light go out?


The pump can be run continuously if it is submerged in petrol otherwise it will get hot and eventually burn out. In normal operation, once the car starts the pump runs continuously until the engine stops running.

My car has a T10 relay for the pump.


Without the key in the ignition, and T10 removed, the pump should always run when the large contacts of the T10 position, which are the two nearest the fuses, are bridged or connected together by a short piece of wire. The purple yellow wire at the pumps connector under the seat is a single piece of wire going to the fuse box and then connected without fuses to the large T10 connector most far from the fuses. The large T10 connector most near to the fuses is fused by Fuse 21.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

judderbar is offline Reply With Quote Quote 
Old 27-12-2018   #9
Join Date: Jul 2012
Location: Kuala Lumpur, Malaysia
Posts: 40
Thanks: 0
Trader Rating: 0
Malaysia 
Re: Fuel Pump Doesn't Work

Quote Originally Posted by jesusminmy View Post
How did you connect the fuel pump
direct to the battery
I just drag cable from the battery to the fuel pump.
There are 4 cables at the pump. 2 small cables to send petrol level info to the tachometer. The two bigger cables are for the negative and positive which will run the motor in the pump.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

luqluq is offline Reply With Quote Quote 
Old 27-12-2018   #10
Join Date: Jul 2012
Location: Kuala Lumpur, Malaysia
Posts: 40
Thanks: 0
Trader Rating: 0
Malaysia 
Re: Fuel Pump Doesn't Work

Quote Originally Posted by judderbar View Post
Are you confidant you are using the donor cars key to start the car? does the key code light go out?


The pump can be run continuously if it is submerged in petrol otherwise it will get hot and eventually burn out. In normal operation, once the car starts the pump runs continuously until the engine stops running.

My car has a T10 relay for the pump.


Without the key in the ignition, and T10 removed, the pump should always run when the large contacts of the T10 position, which are the two nearest the fuses, are bridged or connected together by a short piece of wire. The purple yellow wire at the pumps connector under the seat is a single piece of wire going to the fuse box and then connected without fuses to the large T10 connector most far from the fuses. The large T10 connector most near to the fuses is fused by Fuse 21.
Both car are identical MK2 except the colour and key code. And yes, I was using the right key as they are not interchangeable and the key code did light out.

I'll try to sort the things after this. Thanks a lot, Judderbar for the good explanation.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

luqluq is offline Reply With Quote Quote 
Old 31-12-2018   #11
Join Date: Apr 2008
Posts: 16,588
Thanks: 911
Trader Rating: 0
Ziggy122 has donated!
Eggs Champion, Fruit Pairs Champion
United Kingdom 
Re: Fuel Pump Doesn't Work

Well if pump works in donor and doesnt works off a battery- it tells me an issue with the vehicles wiring

Id be sticking a test light into the connectors (something semi juicy like a h7 bulb) and find out which side is missing
Positive or negative

Ziggy
Likes judderbar liked this post
__________________
!!WANTED!! 3dr Mk2 Punto Roof Bars !!WANTED!!

Meet Bumble-Bee


Ziggy122 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) fuel float on sending unit doesn't work no more huggie241 Barchetta 10 13-06-2016 12:09
(T) A/C doesn't work gonz81bs Bravo / Brava 15 01-08-2012 18:23
Why doesn't It Work??? chaazureblue Blue and Me 2 14-12-2010 15:17
(T) Fuel pump doesn't prime with key-on: Mk1 Uno Turbo - why? alexGS Uno 5 14-01-2009 19:28