Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 28-12-2009   #1
Join Date: Dec 2009
Location: Warwickshire
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Electrical Problems

I have owned my 2000 punto (mark2) for a few months now and everytime i go to start the car up its dead, i have tried a new battery on the car and that went dead after the first drive. so i thought it would be the alternator so i checked that with the multi-meter and all was working in order, does anyone know what i should check?
And also on the instrument cluster i keep having a light apear underbreaking and i looked in the manual and it said i light would be out, but got someone to look and they was all working.
any ideas?

all appreciated
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Copeycfc is offline Reply With Quote Quote 
Old 28-12-2009   #2
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1226
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Electrical Problems

The light is probably the brake warning light. Generally it means your brake fluid is low. Check that.

For the battery issue, try peering under the bonnet while someone tries to start the car. Any orange flashes around the battery, starter motor or earth points indicate the source of your problem.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 28-12-2009   #3
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,430
Thanks: 1145
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Electrical Problems

If your brake fluid is low, and there is no leak then it will be time to change your friction material. The fluid takes up the space of the missing material.

However, the same light also comes on with the handbrake, make sure the switch is sitting correctly.

If its not that light, there is a simple rule of dashboard lghts. If its red, stop.

Cheers

SPD
__________________
rallycinq is offline Reply With Quote Quote 
Old 28-12-2009   #4
Join Date: Dec 2009
Location: Warwickshire
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Electrical Problems

i have checked the brake fluid and its like brand new and at the max point, and its only recently had new brakes fitted onto it has i did have problems while braking and it was getting scary. i have also checked along the break lines and there are no leaks and no buldges.
i got someone to start the car while i looked underneeth and there was no sparks anywhere.
also looking for the switch behind the dash for the light problem the temperature gauge switch has stopped working and i never touched anywhere near that area.

thanks for your sugestions.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Copeycfc is offline Reply With Quote Quote 
Old 28-12-2009   #5
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1226
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Electrical Problems

We need more information about which light came on.

How did you check the alternator with the multimeter? What were the results?

Any extra ICE?

I'm still inclined to suspect an earth fault. Try a single jump lead from the battery -ive to somewhere near the starter motor.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 28-12-2009   #6
Join Date: Dec 2009
Location: Warwickshire
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Electrical Problems

the car has a non-standard stereo in the car. was fitted from one of the previous owners.
i dont really know how to explain about the light because the car doesnt get stored at my house and the books with the car, but if i remember correctly the manual says that its bulb warning light, and it only happens under braking.
Car has a factory fitted subwoofer.
ill check the earths next time ill be with the car which will be tomorrow.

with the multi-meter on the battery was 12.6volts as standing still. volt drop was down too 10.3volts. and the battery went up to 14.2volts.

alternator reads 13volts when running.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Copeycfc is offline Reply With Quote Quote 
Old 28-12-2009   #7
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1226
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Electrical Problems

13 volts suggests an alternator issue -- should be more like 14 - 14.5.

I think the sub is probably draining the battery, but I'm no ICE expert.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 28-12-2009   #8
Join Date: Dec 2009
Location: Warwickshire
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Electrical Problems

ohh okay, but the subwoofer is factory fitted though but i think im just going to have to check the earths and alternator again, thanks for the suggestions
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Copeycfc is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Electrical problems gentil303 Coupe 3 25-11-2009 00:08
(T) electrical problems polerafon Uno 0 21-10-2008 15:23
(T) Electrical Problems aj287 Barchetta 8 05-03-2007 00:11
(G) Electrical Problems Alan.D Panda (Classic) 11 05-04-2006 23:48
(T) Electrical Problems! arc Cinquecento / Seicento 2 02-05-2005 14:18