Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 20-05-2019   #1
Join Date: May 2019
Posts: 5
Thanks: 1
Trader Rating: 0
Croatia 
Wipers control not working

Hi guys!

I'm in need of some assistance. My wipers don't work, but let me explain.

They stopped working gradually. Sometimes they would work and sometimes they would. When they finally died the only way I could turn the wipers on was to set it on a desired speed and then squirt some water and then they start going in the desired speed.

I took out the control unit and disassemble it and it seems to be fine form electrical point of view. I measured the resistance coming out the 3 pin connector and it changes resistance on pins 1 and 2 depending on the selected speed (third one is for the button on the handle).

It goes like this:
]
  • Full speed - 0 ohm
  • Normal speed - 93 ohms
  • Intermittently - 316 ohms
  • Off - 1160 ohms

Are these the correct values for the speed selector on the control handle?

Assuming they are I tried to find the relay box to check there but the cables go behind the steering wheel and I could not reach there.

Where is it located? My conclusion is that the motors are working fine since the wipers work then squirting washer fluid. The switch works because there are different values when rotating the switch and I could turn them on by engaging the wiper fluid squirt. The only thing that remains is the relay box that I cant find. Any help?

Car is Fiat Grande Punot 1.3 Diesel 55kW 2008.

Thank you!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Codebreaker is offline Reply With Quote Quote 
Old 21-05-2019   #2
Join Date: Jan 2017
Posts: 2,506
Thanks: 332
Trader Rating: 0
Belgium 
Re: Wipers control not working

The "relay box" You're talking about is actually the Body Control Module (aka BCM) and is located under the dashboard behind/under the fuse board...
Crawl under you wheel, warp/wry yourself and you'll eventually get at it after loosing a couple of finger on sharpies steel parts, be careful! Disconnect the plugs and inspect for corrosion/moisture/pulled pin etc.

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
Attached Thumbnails
Click image for larger version

Name:	Wiper wiring front.JPG
Views:	7
Size:	88.2 KB
ID:	200425  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 21-05-2019   #3
Join Date: May 2019
Posts: 5
Thanks: 1
Trader Rating: 0
Croatia 
Re: Wipers control not working

Thank you for the information!

I went down under and I'm sad to say I didn't find anything. Behind the fuses is empty space (IMG1). When I engage the washer fluid squirt I can hear the relay in the fuse box (IMG2). Since that the only thing there am I to assume that this is the BCM? Googling the serial number does say that this is a "Comfort Control Module"

Am I on the right tack to diagnose the issue? Could it actually be the problem with the BCM? Because my car mechanic claims that the problem is the control handle that and wants almost 250 euros to fix it (which is almost 10% of what I paid for the whole car, seems a bit much) but my testing shows that the wiper speed control switch does indeed "switch". Could I be mistaken with testing?
Attached Thumbnails
Click image for larger version

Name:	IMG1.jpg
Views:	7
Size:	937.5 KB
ID:	200439   Click image for larger version

Name:	IMG2.jpg
Views:	8
Size:	973.3 KB
ID:	200440  

__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Codebreaker is offline Reply With Quote Quote 
Old 22-05-2019   #4
Join Date: Jan 2017
Posts: 2,506
Thanks: 332
Trader Rating: 0
Belgium 
Re: Wipers control not working

Where and how have you made your measurements ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 22-05-2019   #5
Join Date: May 2019
Posts: 5
Thanks: 1
Trader Rating: 0
Croatia 
Re: Wipers control not working

I checked continuity and resistance measurements on the 3-pin connector coming out of the handle on the control unit as well as on the output pins on the control unit. Checked the continuity on the PCB traces.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Codebreaker is offline Reply With Quote Quote 
Old 22-05-2019   #6
Join Date: Jan 2017
Posts: 2,506
Thanks: 332
Trader Rating: 0
Belgium 
Re: Wipers control not working

That's the 1K6 when OFF that I don't like...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 22-05-2019   #7
Join Date: May 2019
Posts: 5
Thanks: 1
Trader Rating: 0
Croatia 
Re: Wipers control not working

I just got home so I'm going to disassemble and take out the control unit and check the voltage on those pins and see if I can possibly trigger the wipers manually.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Codebreaker is offline Reply With Quote Quote 
Old 22-05-2019   #8
Join Date: Jan 2017
Posts: 2,506
Thanks: 332
Trader Rating: 0
Belgium 
Re: Wipers control not working

Very good idea, mimic the stalk with a set of resistor/switches and see how the bcm respond ...

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
Thanks Codebreaker thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 23-05-2019   #9
Join Date: May 2019
Posts: 5
Thanks: 1
Trader Rating: 0
Croatia 
Re: Wipers control not working

Fixed!

The problem was... disconnected header pin on the PCB in the control unit. The solder on the pin was pressed against the cooper and since it was a tight fit, connecting and disconnecting the connector didn't move it (I'm sure it did when connecting but then returned when disconnecting) and it's the reason I didn't see it being soldered properly. Had to clean it and resolder the pin to the PCB.

What still baffles me is why I got 1160 ohms on the output of the handle connector pins and when I soldered the header pin to the PCB it was 2k ohms. It wasn't connected to anything, open circuit. I'm sure it was my mistake, but how...

In hindsight, an easy fix.

Thank you for all the help!
Thanks Bernievarian thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Codebreaker is offline Reply With Quote Quote 
Old 23-05-2019   #10
Join Date: Jan 2017
Posts: 2,506
Thanks: 332
Trader Rating: 0
Belgium 
Re: Wipers control not working

Thanks for the update and congrats for your pugnacity !!

BRs, Bernie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) One of front wipers stop working other working intermittently. Chickoo67 Stilo 13 16-05-2013 17:22
(T) Wipers stopped working, Clicking fuse? & temp gage and rev counter not working? JordanJ Grande Punto 1 12-02-2011 08:25
(T) Front and rear wipers working then not working jamierae Stilo 9 31-01-2011 09:10
Windscreen wipers and climate control fans on Turbo V20 not working turbonuts Newbie Central 2 13-08-2008 13:37
(T) HELP! My wipers are out of control! cozzy28 Punto (Mk2/2b) 5 29-03-2007 16:05