Technical Punto JTD no poke after 3k RPM

Currently reading:
Technical Punto JTD no poke after 3k RPM

Steve-0

Born to be riled
Joined
Dec 20, 2005
Messages
183
Location
Wakefield
As above, it pulls like chuff up to 3k rpm then after that it seems to struggle.

It's a 2001 1.9 JTD.

Just had all the filters changed including fuel.

It has 20k on the clock

And no I don't want a remap ;)

Cheers

Setve
 

custard

Status: DEFCON Grumpy
Joined
Nov 4, 2003
Messages
48,610
Location
Edinburgh
no real experience of oil burners as the ones i have drivin have been clapped out.thought you had peak power by 3000 on ,so used to torque to pull ,no

setve? ;)
 

stylers

New member
Joined
Aug 18, 2005
Messages
503
Location
Westmeath, Ireland.
This could be a MAF sensor problem, but I'm not sure if they changed the sensor after the early ones. you can disconnect it (well you could on the bravo's anyway) to see if it goes better without it (but dont bother with this test if the engine light comes on). It shouldnt really be a problem on a car with low miles like this though. Any engine light on or anything ?

Owen.
 

Citizen Smith

is one with the dark side
Joined
Jul 30, 2004
Messages
1,928
Location
Surrey
stylers said:
This could be a MAF sensor problem, but I'm not sure if they changed the sensor after the early ones. you can disconnect it (well you could on the bravo's anyway) to see if it goes better without it (but dont bother with this test if the engine light comes on). It shouldnt really be a problem on a car with low miles like this though. Any engine light on or anything ?

Owen.

:yeahthat:
 
OP
OP
Steve-0

Steve-0

Born to be riled
Joined
Dec 20, 2005
Messages
183
Location
Wakefield
You were right boys and girls (y)

Disconnect the MAF sensor and it's off like chuff :slayer:

Will it harm the car to leave it disconnected or should I fit a new one?

Any ideas on price, being a Yorkshire man I am rather tight in the money department :D

Cheers

Steve
 
Top