Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools Search this Thread
Old 17-12-2007   #1
*custom name*
 
j0nny's Avatar
Join Date: Aug 2007
Location: NI
Posts: 725
Thanks: 20
Trader Rating: 0
j0nny has donated!
United Kingdom 
this is a new one P0105?

well yet another problem has occured, have no indication as to why this has happened, was being reli easy on the engine today drove fine for the first hour or so, parked it and it was there for a good few hours while i went and did the christmas shopping, now ive been gettin bulb failure non stop for the last few days, theres another post on that so i hope someone can shed some light on how to fix it and where the circut board is. but this happened as soon as i came back and started the car, typical beep beep beep then "engine failure" as well as the bulb failure. now due to previous occurences i now keep the OBDII dongle in the car so ran a diag in the car park, got P0571 (i think, the brake switch one) i reset the switch the other day but forgot to erase the code so im not too worryed about that

but then i got P0105 which i had as MAP / BARO circut malfunction now that is way out of my league, if i opened the bonnet i wouldnt have a clue wat to look for. im hoping this is an easy fix could anyone please shed some light on this?

really hasnt been a good day with the car, first off, both brake lights failed in the morning, then started workn, then the right failed, then the left, then both and it kept mixin about like that everytime i braked, so i took it really easy all day just incase. someone has hit my car, scrape right along the pasenger trim and onto the rear arch gona hav an attempt of t-cutting it tomorrow. and all these faults. i dont know if i should give it up before anything majorly goes wrong with it and just cut my loses, i love the car to bits but i dont know what to do, i wouldnt get much for it and theres no car you can get with the same beauty and spec as the stilo for anywhere near that money sorry for the long post!
__________________
1.2 3dr stilo dropped on claws & a suzuki bandit v
j0nny is offline Reply With Quote Quote 
Old 17-12-2007   #2
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1066
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: this is a new one P0105?

IGet software update for ECU.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T14086 is offline Reply With Quote Quote 
Old 17-12-2007   #3
Dislikeskeyboardwarriors
 
Steely's Avatar
Join Date: Feb 2007
Location: Depressive Doncaster
Posts: 1,240
Thanks: 35
Trader Rating: 0
Steely has donated!
United Kingdom 
Re: this is a new one P0105?

As T14086 said poss ecu update,


I had this fault about 9 months back... but it was down to a faulty MAP sensor, easy fix... held in with 2 self tappers on the left hand side of the air intake/inlet manifold,

best i got was £60 for a new sensor... from what i remember about £108 list from fiat

try disconnecting it and cleaning the contacts... dont just buy a new one... and im sure the dash warning/fault has to be reset by a fault codereader/diag kit can get em' about 15 quid off the net ... not sure... sure someone will know



but looking at the other prob you have been having, its very hard to say
__________________

Last edited by Steely; 17-12-2007 at 23:56.
Steely is offline Reply With Quote Quote 
Old 17-12-2007   #4
*custom name*
 
j0nny's Avatar
Join Date: Aug 2007
Location: NI
Posts: 725
Thanks: 20
Trader Rating: 0
j0nny has donated!
United Kingdom 
Re: this is a new one P0105?

aye ive got the tool to erase the codes, i havent erased these codes yet as i dont like to erase them until i know wat is going on.
i apoligise if this seems lik a stupid question but do you have to pay for the eu update?
and can you describe the map sensor so i know wat im doing 2moro plz. thanks!!
__________________
1.2 3dr stilo dropped on claws & a suzuki bandit v
j0nny is offline Reply With Quote Quote 
Old 18-12-2007   #5
Dislikeskeyboardwarriors
 
Steely's Avatar
Join Date: Feb 2007
Location: Depressive Doncaster
Posts: 1,240
Thanks: 35
Trader Rating: 0
Steely has donated!
United Kingdom 
Re: this is a new one P0105?

Its is a 1.6 isnt it???

have a look at item 8 on this eper drawing, http://eper.fiatforum.com/eper/navi?...=3&WINDOW_ID=1

thats the MAP (Manifold Absolute Pressure) sensor, take off the big engine cover held on by 4 nuts to get to it
__________________
Steely is offline Reply With Quote Quote 
Old 18-12-2007   #6
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 721
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: this is a new one P0105?

Try the procedure I outlined in post 27 here
https://www.fiatforum.com/stilo-tech...hat-can-2.html
You have nothing to lose and should get your MAP sensor back on line if it's going to otherwise you'll be drinking fuel. Still may need the ecu update

Clean up the circuit boards connector contacts on the rear light clusters to hopefully fix the brake light problems
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 18-12-2007 at 00:54.
Deckchair5 is offline Reply With Quote Quote 
Old 18-12-2007   #7
*custom name*
 
j0nny's Avatar
Join Date: Aug 2007
Location: NI
Posts: 725
Thanks: 20
Trader Rating: 0
j0nny has donated!
United Kingdom 
Re: this is a new one P0105?

cheers, its the 1.2 model but that gives me an idea of shape and size and where it is so im going to have a go at that now. il look it up on ePer now to get a better idea. and cheers for the brake light info. ive been in a bad mood all day cz of the car im worryed that more is going to go wrong and stuff that is impossible for me to fix or afford to pay someone else to do it. dnt know wat to do.

o yes, about the ecu update. dealership job? how much?
__________________
1.2 3dr stilo dropped on claws & a suzuki bandit v
j0nny is offline Reply With Quote Quote 
Old 18-12-2007   #8
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 721
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: this is a new one P0105?

Don't think there is an ECU update for the 1.2. I think everyone assumed you had a 1.6 as the 1.2 is a very trouble free unit

MAP sensor is real easy to find on the 1.2 and looks the same as the 1.6 in the picture
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 18-12-2007 at 18:57.
Deckchair5 is offline Reply With Quote Quote 
Old 18-12-2007   #9
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1066
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: this is a new one P0105?

Update does cover 1.2 models (and 1.4).
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T14086 is offline Reply With Quote Quote 
Old 18-12-2007   #10
*custom name*
 
j0nny's Avatar
Join Date: Aug 2007
Location: NI
Posts: 725
Thanks: 20
Trader Rating: 0
j0nny has donated!
United Kingdom 
Re: this is a new one P0105?

i cant find it im a total newbie when it comes to the engine bay, sry bt can u describe it to me? is it exactly the same as the 1.6, cz from wat i see i wont b able to even see the map sensor if it is at the rear of the engine
__________________
1.2 3dr stilo dropped on claws & a suzuki bandit v
j0nny is offline Reply With Quote Quote 
Old 18-12-2007   #11
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 721
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: this is a new one P0105?

Here it is, next to the oil filler cap
Click image for larger version

Name:	 <a href='http://www.fiatforum.com/autolink.php?id=15&script=showthread&forumid=33' target='_blank' title='Manifold Absolute Pressure' class='gal'>MAP</a> 1.2.JPG
Views:	143
Size:	26.2 KB
ID:	35761
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX
Deckchair5 is offline Reply With Quote Quote 
Old 18-12-2007   #12
*custom name*
 
j0nny's Avatar
Join Date: Aug 2007
Location: NI
Posts: 725
Thanks: 20
Trader Rating: 0
j0nny has donated!
United Kingdom 
Re: this is a new one P0105?

aww thts wat i thot it was bt i was not going to risk taking things off, bt i will do that before the end of the nite, lol.
now deckchair, your bound to be the man for this. rite took the rear clusters off, cleaned the connectors and board for the rear lights, did them al except indicitors. wel i put it all back together stil both were out. so i moved the car onto the drive and then somehow the right one started working again. left one still out, so i figured il test the voltages for the voltage running into each connector, there is six connections on the connector block, heres the connectors i figured out, looks something similar to this
I - dont know
I - reverse light i think

I - rear tail light
I - brake light

I - dont know
I - fog

rite its just the middle two connections im worried about, both bulbs in both rear tail lights are working fine meaning the bulbs are ok as its the top bulb that illuminates when braking.

now in both clusters, the rear tail light stays constant at 11-12V
in the right cluster (one that works) the voltage is around 0.13 when the brakes off and again 11-12V when brakes are applied
in the broken left cluster the brake light connection is 9V when the brakes are off then 11-12V when the brakes are applied, i dont get this at all
any ideas?
__________________
1.2 3dr stilo dropped on claws & a suzuki bandit v
j0nny is offline Reply With Quote Quote 
Old 18-12-2007   #13
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 721
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: this is a new one P0105?

I can't guess what you're testing. Sounds like it could be bad earths. With engine running put your sidelights on and indicators, have a look and see if weird things happen like sidelights dimming in time with indicators.

With ignition on, have someone operate the footbrake or jam something like a piece of wood on the brake pedal and see what happens at the rear lights. Give the cluster a thump with your hand and see if the brake light now illuminates showing a bad contact is there.
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX
Deckchair5 is offline Reply With Quote Quote 
Old 19-12-2007   #14
*custom name*
 
j0nny's Avatar
Join Date: Aug 2007
Location: NI
Posts: 725
Thanks: 20
Trader Rating: 0
j0nny has donated!
United Kingdom 
Thumbs up Re: this is a new one P0105?

decks you are a genious, somehow through a simple explanation you can diagnose and list procedures for fixing next to anything, did your guide for the map sensor and erased the code, seems to have done the job
and the thumping the cluster did it so ive stripped the light and connected it and tested the connections with the multimeter with the brakes on and came to the conclusion that it is the actual connection between the light and the spring bit below as the voltage even gets to there. spent about two hours on that one thing alone tonight, i think im going to try two new bulbs and see if that does the trick, there is a bit of coating around the bottom of the bulb, i tried scraping it off but didnt do much. thanks very much, ive a bit more confidence in keepin the stilo knowing theres a great forum to help out wenever needed, cheers
__________________
1.2 3dr stilo dropped on claws & a suzuki bandit v
j0nny is offline Reply With Quote Quote 
Old 19-12-2007   #15
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 721
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: this is a new one P0105?

Good stuff
Sometimes the spring contacts on the connector to the rear cluster circuit board become a bit weak and are not making real contact but you have to be VERY CAREFUL to prise them back into spring contact. Sometimes cleaning up the electrical contact where the base of the bulb meets the spring contact there needs a little scratching to remove the surface oxidation and make better contact

And yes, the MAP sensor is being recognised just fine now and back up to 35mpg around town which is on par for the 1.6
Thanks j0nny thanked for this post
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 19-12-2007 at 08:56.
Deckchair5 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump