Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 17-11-2010   #1
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
My Evo faults

Going to the dealer after work today with a small list of faults:

Engine Faults:

Engine has twiced stalled while moving at approx 1500rpm in second gear. The engine would just stop without warning causing the car to come to an fast stop due to engine braking.

Often when car is cold and in 2nd gear seems very rough and unwilling to rev, almost feeling like it is misfiring. This goes away completely after approx 500 yards

Yesterday (16/11/10) the engine started after standing for 2.5 hours. Idle up to 1400rpm was very rough and juddery. The engine revved fine but as soon as it dropped back to these revs it would shake. I drove off and after approx 100 yards of slow driving the emissions warning light started flashing. After turning the engine off and back on the idle went back to normal and the light went out.

The engine will often sound very tappety with an almost plastic rattling at engine speed. This seems to happen when In slow moving traffic and will remain at low engine speeds when the engine is warm until I drive at a good pace for an hour! – First noticed at 770miles, mentioned to technician at approx 1000 miles and still remains.

The start stop seems to be functioning perfectly but if I have anything electrical on the engine will often stop for only a second before immediately re-starting – Is there a software update available to fix this?

Interior faults:

Panel on dashboard by drivers knee will not stay on because 3 of the tabs broken. Discovered day after collection when panel fell off while driving.

Exterior faults:

Scratch on front bumper (as mentioned during inspection on collection).

Boot lid not perfectly aligned so will “catch” slightly on opening. – Discovered very first time I opened the boot.

Boot lid seems to hold water which then leaks out of the rubber buffers on the lower corners soaking me. Only noticeable after heavy rain or washing the car.
--------


Not bad in 2000 miles/7 weeks.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 17-11-2010   #2
Join Date: Jun 2010
Location: romford, essex
Posts: 80
Thanks: 0
Trader Rating: 0
puntoevogp has donated!
United Kingdom 
Re: My Evo faults

Quote Originally Posted by Ransoman View Post
Going to the dealer after work today with a small list of faults:




Not bad in 2000 miles/7 weeks.
have done 4500 miles since the 1st of september
__________________
puntoevogp is offline Reply With Quote Quote 
Old 23-11-2010   #3
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: My Evo faults

Going in on thursday. Hopefully coming back to me faultless. And it stalled on me again, thats the 3rd time now.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 28-11-2010   #4
Join Date: Sep 2010
Location: Bucks
Posts: 59
Thanks: 4
Trader Rating: 0
United Kingdom 
Re: My Evo faults

shame to hear about the engine, mine has no problems so far.

The boots seem to be out on all the Evos ive seen. I got the dealership to realign mine and its still not 100%.

The Evo i test drove had a broken panel by the knee, maybe it is one of the common problems?

Mine has an issue with the petrol gauge. It doesnt go up after a fill up. instead it gradually increases as you drive, the Range counter seems to go with it! bloody annoying

think ill call fiat this time instead of the dealership
Thanks Ransoman thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CrAiG 135T is offline Reply With Quote Quote 
Old 29-11-2010   #5
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: My Evo faults

Update.

Craig, after much discussion and comparing of other cars in the dealer we came to the conclusion that that is normal for Evo's and by design. The broken knee panel had 3 of the four tabs snapped so this was replaced under warrenty.

I think the engine is sorted. 105 multiair owners expect another Recall soon to do with the engine. It just so happened my car was booked in on the day the recall was announced so the work was carried out there and then which may fix that issue. The warning light was an ignition failure on cylinder 1 and the plug was found to be "fowled".

Since picking the car up though:

The front passenger side wheel has developed an awful grinding under braking

The Blue and Me died for a day causing the Mileometer to flash

Warning light came up on Dash ! in a triangle. not near my manual so don't yet know what it means.

Love the car, hate the faults.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 30-11-2010   #6
Join Date: Jul 2009
Location: Bristol
Posts: 857
Thanks: 23
Trader Rating: 0
United Kingdom 
Re: My Evo faults

Quote Originally Posted by Ransoman View Post
Update.

Craig, after much discussion and comparing of other cars in the dealer we came to the conclusion that that is normal for Evo's and by design. The broken knee panel had 3 of the four tabs snapped so this was replaced under warrenty.

I think the engine is sorted. 105 multiair owners expect another Recall soon to do with the engine. It just so happened my car was booked in on the day the recall was announced so the work was carried out there and then which may fix that issue. The warning light was an ignition failure on cylinder 1 and the plug was found to be "fowled".

Since picking the car up though:

The front passenger side wheel has developed an awful grinding under braking

The Blue and Me died for a day causing the Mileometer to flash

Warning light came up on Dash ! in a triangle. not near my manual so don't yet know what it means.

Love the car, hate the faults.
Yikes, we'll my 105 Evo went in for the airbag recall last week + engine management light came on earlier in the week and the situation seemed strikingly similar to your experience with the juddering, i.e engine on, juddering really badly, rev & muck about, still no use, restarted engine a couple of times & all was normal again.

Anyway Airbag update was done, I also told them about the engine management light & informed me of a tappet cap recall that had to be done aswell apparently the tappet thing could cause the car to burn oil & do strange things. (such as the engine management light, but im pretty sure this was bullsh!t)

Only issues I have right now is down to the Media Player, while playing music it just says "MEDIA PLAYER - 00:00" has stopped coming up with the names of songs etc on the headunit, cant seem to figure out why.... Will have to take it in at some point, hoping the engine management light comes on again so I have a bigger reason to go in!

What about your boot "catching" did they sort that? mine certainly seems fine, other than it pee'ing on my head from a random corner after some good rain, but i figure that's just a quirk.

Also that Triangle ! light, is that yellow? not sure if the Dynamic has it but i think that's down to the ASC/ESP usually comes on when its stepping in (which brakes on the wheel that's lost grip etc)
__________________

2010 Punto Evo Eleganza - 1.4 Multiair (105) - Progressive Black

Last edited by Blank2k2; 30-11-2010 at 16:05.
Blank2k2 is offline Reply With Quote Quote 
Old 01-12-2010   #7
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: My Evo faults

It was the tappet cap recall mine had. Must admit that a week later and it seems perfect, i can believe the burning oil thing as apparently my no.1 sparkplug was filthy when it came out.

The warning light was a "general failure with the start/stop" (aka, a technical failure, not the "start stop not available" thing).

The boot lid sticking seems to be normal having compared it to a few others.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 07-12-2010   #8
Join Date: Aug 2010
Location: Ickenham
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
grinding under braking

Quote Originally Posted by Ransoman View Post
Update.

Craig, after much discussion and comparing of other cars in the dealer we came to the conclusion that that is normal for Evo's and by design. The broken knee panel had 3 of the four tabs snapped so this was replaced under warrenty.

I think the engine is sorted. 105 multiair owners expect another Recall soon to do with the engine. It just so happened my car was booked in on the day the recall was announced so the work was carried out there and then which may fix that issue. The warning light was an ignition failure on cylinder 1 and the plug was found to be "fowled".

Since picking the car up though:

The front passenger side wheel has developed an awful grinding under braking

The Blue and Me died for a day causing the Mileometer to flash

Warning light came up on Dash ! in a triangle. not near my manual so don't yet know what it means.

Love the car, hate the faults.
my evo 1.4gp has just developed the grinding when braking and i've booked it in for friday - how was this problem resolved
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

satinred is offline Reply With Quote Quote 
Old 08-12-2010   #9
Join Date: Sep 2006
Location: Aberdeen
Posts: 399
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: grinding under braking

They didn't look at it (because they didn't read the updates i wrote on the job sheet).

It is getting worse so i am going back soon.

Start and stop is still impressing me. It is now restarting as it in the process of stopping.
__________________
Driving: Alfa GT 3.2 V6 in black and Abarth 595 145bhp in Red.
Ransoman is offline Reply With Quote Quote 
Old 10-12-2010   #10
Ginger
 
MrBoney's Avatar
Join Date: Jan 2009
Location: Bournemouth
Posts: 411
Thanks: 14
Trader Rating: 0
MrBoney has donated!
United Kingdom 
Re: My Evo faults

My EVO started with the same engine problem you guys have suggested, caused by oil leaking through the headgasket and into a cylinder and creating a missfire. I had a whole new headgasket fitted
__________________
Punto Evo, 1.4 MultiAir 105 Eleganza 5dr, ESP + Hill Holder, Ambient White, Leather Interior (front armrest and ambient lighting), Skydome Roof, Style Pack (cornering fogs, rear electric windows and side rubbing strips), Metallic Bumper Mouldings, Reverse Parking Sensors, Mudflaps.
MrBoney is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) whats the difference between a punto evo and a abarth punto evo? the green stilo Abarth Punto Evo / Supersport 1 12-09-2010 09:59
(G) several faults help.. balny2000 Stilo 22 01-05-2010 20:35