Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 23-01-2015   #1
Join Date: Jul 2008
Location: brighouse
Posts: 149
Thanks: 9
Trader Rating: 0
United Kingdom 
Earth fault?

Hi guys, been having electrical problems on my 4x4.

When I start the car the engine fires up normally as do the dash lights and gauges. I turn the headlights switch on and the lights won't come on and the gauges and dash lights turn off.

If I restart the car the dash works again but as soon as I do the lights it happens again,

This happened last week too but it was because the alternator belt was too slack. Once tensioned correctly the problem went away, and now the same problem is back with a vengeance.

Help anyone?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth stabler is offline Reply With Quote Quote 
Old 23-01-2015   #2
Rollin' On Steelies
 
AndyPanda4x4's Avatar
Join Date: Apr 2013
Location: Masham, North Yorkshire
Posts: 2,339
Thanks: 300
Trader Rating: 1
AndyPanda4x4 has donated!
United Kingdom 
Re: Earth fault?

Check the light switch itself, they are prone to melting on the back. Also check the dim/dip resistor located on the offside shocker pillar (looks like a coil). Take a look at the "hedgehog" earths which are located next to the resistor on the offside shocker pillar, and on the inside of the nearside wing (re-do the spade connections and clean up contacts). Check the negative battery lead where it runs down the bulkhead in the engine bay, this is a common cause of electrical faults as it gets visibly warn away from movement. If all this looks ok then it's likely to be your alternator brushes that have had it. Good luck fault hunting, hope you sort it :thumbup:
__________________

Fiat Panda 4x4 - What the Yorkshire Dales were made for.
AndyPanda4x4 is offline Reply With Quote Quote 
Old 24-01-2015   #3
I Void Warranties
 
Dragon Man's Avatar
Join Date: May 2011
Location: The East Midlands, Derby.
Posts: 5,000
Thanks: 287
Trader Rating: 0
Dragon Man has donated!
United Kingdom 
Re: Earth fault?

...

.. what he said..
Dragon Man is offline Reply With Quote Quote 
Old 24-01-2015   #4
Join Date: Jul 2008
Location: brighouse
Posts: 149
Thanks: 9
Trader Rating: 0
United Kingdom 
Re: Earth fault?

Thanks Andy, doubt it will be the hedgehoggy thing as I cleaned that up and greased it about a fortnight ago. My horn had a mind of it's own too until last week when I disconnected it. Driving through town and it decided to beep at police officers and pensioners, I looked like a right wazzok.

I will check the switch over, are they easy to remove? I have a spare if it has packed in. Also do you know where I can buy new alternator brushes?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth stabler is offline Reply With Quote Quote 
Old 29-01-2015   #5
Join Date: Jul 2008
Location: brighouse
Posts: 149
Thanks: 9
Trader Rating: 0
United Kingdom 
Re: Earth fault?

Just sorted the problem after 4 hours prodding about with multimeter and jiggling various wires around and testing switches.

Turns out the ignition barrel is worn and the wires that plug into the ignition switch were slack as hell. Tightened all the spade connectors cleaned them up and greased them, removed the switch from the ignition barrel, stripped and rebuilt that, put everything back together and now it all works better than ever.

Happy days
Thanks onemanmade thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth stabler is offline Reply With Quote Quote 
Old 29-01-2015   #6
Join Date: Mar 2013
Location: Ayrshire
Posts: 3,022
Thanks: 173
Trader Rating: 0
onemanmade has donated!
United Kingdom 
Re: Earth fault?

Quote Originally Posted by abarth stabler View Post
Just sorted the problem after 4 hours prodding about with multimeter and jiggling various wires around and testing switches.

Turns out the ignition barrel is worn and the wires that plug into the ignition switch were slack as hell. Tightened all the spade connectors cleaned them up and greased them, removed the switch from the ignition barrel, stripped and rebuilt that, put everything back together and now it all works better than ever.

Happy days
Brill, nice fix!
__________________
750L Progress thread:https://tinyurl.com/m5ra2gt

1.1 Active Progress Thread: https://tinyurl.com/y86qyray

http://badges.fuelly.com/images/sig-uk/620023.png
onemanmade is offline Reply With Quote Quote 
Old 29-01-2015   #7
Rollin' On Steelies
 
AndyPanda4x4's Avatar
Join Date: Apr 2013
Location: Masham, North Yorkshire
Posts: 2,339
Thanks: 300
Trader Rating: 1
AndyPanda4x4 has donated!
United Kingdom 
Re: Earth fault?

Well done!

Another earth issue "area" noted :thumbup:
Likes Dragon Man liked this post
__________________

Fiat Panda 4x4 - What the Yorkshire Dales were made for.
AndyPanda4x4 is offline Reply With Quote Quote 
Old 30-01-2015   #8
Join Date: Jul 2008
Location: brighouse
Posts: 149
Thanks: 9
Trader Rating: 0
United Kingdom 
Re: Earth fault?

Quote Originally Posted by AndyPanda4x4 View Post
Well done!

Another earth issue "area" noted :thumbup:

Yeah it took some finding but it seems to have sorted out several issues, before when my lights were playing up I used to sit and look at eBay for 5 mins, calm myself down after getting frustrated and it would work( temporarily).

Turns out it doesn't have a mind of it's own like herbie .... Just loose and worn out wiring.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth stabler is offline Reply With Quote Quote 
Old 30-01-2015   #9
Just Drive It
 
JamieK's Avatar
Join Date: Jul 2012
Location: Cloud number 9
Posts: 1,380
Thanks: 71
Trader Rating: 0
JamieK has donated!
United Kingdom 
Re: Earth fault?

Excellent work not sure that fault's been flagged up before so you've probably saved a few people a lot of time in the future
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

JamieK is offline Reply With Quote Quote 
Old 25-02-2019   #10
Join Date: Aug 2010
Location: Lewisham
Posts: 74
Thanks: 2
Trader Rating: 0
Torridon1 has donated!
United Kingdom 
Re: Earth fault?

my 1992 CLX is suffering from the same symptom as this original post (everything works until the headlights are turned on, then all the dash lights light up dimly and the indicators stop working.)
I'll be checking the ignition switch and connections ( I replaced the ignition switch in the summer so maybe didn't put things back together firmly enough) and I will also check hedgehogs etc.
In the past I added an additional earth cable from the battery to the bodywork, but have read in a few threads about an additional earth cable from the engine to the bodywork. This sounds like it would be worth doing for the cost of an earth strap, but where on the engine would I connect the earth to?
Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Torridon1 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Indicator Issues - Earth Fault johnooo Punto (Mk2/2b) 24 10-12-2012 20:26
(T) mk 2b earth fault? siadz Punto (Mk2/2b) 8 29-09-2011 00:31
(G) Earth / Electrical fault - Seicento '03 Fix It Again Tommorow Cinquecento / Seicento 15 03-12-2010 08:46
(T) Earth Fault Cinquecento Mutley8979 Cinquecento / Seicento 4 10-02-2010 18:04
bad earth fault d225859e Newbie Central 0 21-01-2009 18:10