Register Login
im Axle Specialists
Reply
 
Thread Tools Search this Thread
Old 01-08-2009   #1
Join Date: Jun 2007
Posts: 24
Thanks: 1
Trader Rating: 0
United Kingdom 
Question Marea 125 HLX TD - Acceleration Issues

Hi Folks,

I've posted here in the not so distant past about accleration issues with my 1998 Marea 125 HLX Turbo Diesel. I've now identified the cause of the symptoms (but not the root cause of the problem itself).

I do a lot of motorway driving on the M1 and M25 between Sheffield and Folkestone at the moment. At times, usually after driving through roadworks, I noticed I could no longer accelerate beyond 70mph going uphill, and struggled to get more than 80mph going downhill. I currently have the pleasure of regularly driving through the 50mph average speed check between Junctions 28 and 24 on the M1, and the 40mph - 50mph average speed roadworks zone on the Northern stretch of the M25, when driving East.

Here's what happens. Prior to entering any protracted set of roadworks, I always have full power. My car will comfortably drive both uphill and downhill at significant speeds with full acceleration.

After driving through roadworks for any longer than 10 mins at a constant speed of 50mph at around 1500rpm, by the time I come out the other side of the roadworks, I cannot get beyond the speeds mentioned above when travelling uphill/downhill. Acceleration is very weak - it's like there's nothing there (which in a 5 cylinder Turbo Diesel, is completely wrong). This happens every time, without fail.

However, all I need to do to resolve it is leave the motorway and come to a halt (with the engine still running) at, say a roundabout junction or set of traffic lights. Full power is then restored on lift off, and I can rejoin the motorway a happy bunny!

The key question I have is, what could be causing this? Could it be the Mass Air Flow Sensor playing up? No warning lights are coming on. I've experienced a knackered injection pump before, and this is nothing like it. At the end of the day, full power is smoothly restored after I've come to a halt. If the injection system had major issues, this would not happen!

I'm open to any suggestions....?

Cheers.

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jimbo1 is offline Reply With Quote Quote 
Old 04-08-2009   #2
Join Date: May 2005
Location: S Wales
Posts: 124
Thanks: 5
Trader Rating: 0
United Kingdom 
Post Re: Marea 125 HLX TD - Acceleration Issues

I've scoured the forum looking for answers to just this problem on mine too. Having been through all the EGR suggestions & blanked it off, then EGR control solenoid which I changed all to no avail, I've found it to be the MAF.

If I disconnect this, then the acceleration is fine throughout the range in all conditions. Reconnect the MAF & as soon as I cruise & maintain a speed from 50-80 mph for 10 seconds, then all subsequent acceleration is lost. Dipping the clutch & letting it idle for 2-3 secs, then releasing the clutch will allow acceleration.

MAF disconnected, the engine feels a little rough, acceleration is about 90% of normal & mpg down a bit.

With a functioning MAF, the engine feels great, & acceleration is better, but how to keep a MAF working is the issue I haven't cracked: when I got the car the MAF was surreptitiously blanked from the wiring plug, so as to LOOK connected, but it had no platinum film inside the plenum chamber. I bought a new MAF from Ebay & all was well for 6 months then it failed though clean as a whistle.

I fitted a new Ebay MAF about three weeks ago & it failed Saturday, so I'll be Emailing supplier for a replacement. Any ideas for a more permanent source of the MAF?
Bosch 0 281 002 144
Fiat 464 116 75
Opel / Vauxhall 91 153 783/ 93 171 356
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

pycoed is offline Reply With Quote Quote 
Old 09-08-2009   #3
Join Date: Jun 2007
Posts: 24
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Marea 125 HLX TD - Acceleration Issues

Thanks pycoed.

I think I'll try disconnecting the MAF to prove this (just need to find out where it is first). This is where I wish there was a Haines Manuel for the Marea. Still, I've got a CD manual I got hold of on Ebay, so I'll see what that yields.

Since making that last post, I've discovered that when I have the power issues, if I pop the gearbox into neutral and take my foot off the gas pedal, this is enough to restore full power when I pop her back into gear and floor it.

Disconnecting the MAF should be enough to prove this once and for all.

Unfortunately, I don't think I can help you with this:

Quote Quote:
Any ideas for a more permanent source of the MAF?
I will very probably be looking for a new MAF of my own in the not so distant future though, so I'll come back to you with any supplier I can find who proves to be reliable. Thinking of just trying the local Motor Factor first though, in all honesty.

Thanks a lot for your help anyway. It beats taking it down to the local garage and hearing all the usual fuel filter/injection cleaner suggestions. They're helpful enough in the right context, but when you KNOW your car is fine in that respect, it can get a little annoying. The most appropriate response I've had so far is "We'll plug in our diagnostic kit and see if we can find anything.......".

Cheers.

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Jimbo1; 09-08-2009 at 10:55.
Jimbo1 is offline Reply With Quote Quote 
Old 09-08-2009   #4
Fiats since 1973
 
johnson550's Avatar
Join Date: May 2006
Location: North East
Posts: 1,331
Thanks: 43
Trader Rating: 0
johnson550 has donated!
United Kingdom 
Re: Marea 125 HLX TD - Acceleration Issues

I believe theres a guide on here for cleaning the maf or if not its on fiat boo Ive done it myself successfully the only thing you have to watch out for is not to drench it with fluid.
__________________
2007 Stilo Sporting M/Jet 150bhp
2001 Marea Weekend JTD 110bhp now 171bhp (Gone but not forgotten)
http://www.fiatforum.com/garage_vehi..._vehicle&id=24
He who works and does his best
gets his cards just like the rest
johnson550 is offline Reply With Quote Quote 
Old 05-09-2009   #5
Join Date: Sep 2009
Posts: 6
Thanks: 0
Trader Rating: 0
Re: Marea 125 HLX TD - Acceleration Issues

I have a problem with my 2.4 JTD engine which seems to be similar to various problems I have read about on these pages.
I got the car about 6 months ago and thought I had bought a dud as when doing about 70 on the motorway a slight upward incline meant the speed would drop right off even with more throttle being gradually applied. Changing down didn't help at all and resulted in finally driving at embarassingly lower motorway speeds
About 5 weeks ago in total frustration I really revved the car in each gear up the slip road onto a motorway one time and suddenly all those problems seemed to be behind me. The engine started to deliver what I had originally expected from a 2.4td and the accleration was fantastic from 50 right up to a ton. That state of affairs lasted about 1 month. When it was running well I was reminded of my great old tipo 1.9td which I bought new in 1990 and could leave all it's td contemporaries behind.
Now the orignal problem is back only worse. The car stars to slightly misfire even on the level once 70 is approached and it dies(misfires) more as more throttle is applied. It picks up and feels happier if driven with minimal throttle, the actual road speed achieved being dictated by whether you're driving up, down or on the level. When I first got the car it would kick out typical amounts of old-style turbo diesel exahust smoke under heavy acceleration whereas now it just dies under hard acceleration.
I am a little wary of starting work on a job I cannot finish with the limited tools avaliable to me and considering the shoe-horn job of the 2.4 td in the marea engine bay. Unfortunately I also haven't been 100% able to tell which are the maf and egr parts on the engine before I try to independantly blank/disconnect them in an attempt to isolate the problem. Any pics/better descriptions of these devices would be greatly appreciated as would any further advice.
Cheers.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gerragrip is offline Reply With Quote Quote 
Old 05-09-2009   #6
Fiats since 1973
 
johnson550's Avatar
Join Date: May 2006
Location: North East
Posts: 1,331
Thanks: 43
Trader Rating: 0
johnson550 has donated!
United Kingdom 
Re: Marea 125 HLX TD - Acceleration Issues

Youl find a lot of solutions to problems in the search like this
http://www.fiatboo.co.uk/photogal/guidepics/maf/maf.pdf
__________________
2007 Stilo Sporting M/Jet 150bhp
2001 Marea Weekend JTD 110bhp now 171bhp (Gone but not forgotten)
http://www.fiatforum.com/garage_vehi..._vehicle&id=24
He who works and does his best
gets his cards just like the rest
johnson550 is offline Reply With Quote Quote 
Old 06-09-2009   #7
Join Date: Sep 2009
Posts: 6
Thanks: 0
Trader Rating: 0
Re: Marea 125 HLX TD - Acceleration Issues

Just wondered if another fault I forgot to mention could be playing a part in all the above mentioned symptoms, even though it was also faulty when the engine was performing excellently.
The problem is that the revcounter shows almost 0 on tickover. When doing about 70 it's doing about 2500 or so if I remember rightly(which I would guess is about right for that speed. So the correct revs seem to be indicated at mid to high range revs. I suppose it would be the clock device that is indicating in error and definitely not in a linear fashion.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gerragrip is offline Reply With Quote Quote 
Old 06-09-2009   #8
Join Date: Sep 2009
Posts: 6
Thanks: 0
Trader Rating: 0
Re: Marea 125 HLX TD - Acceleration Issues

Just checked for the MAF, couldn't find it.
Looking at mareas technical manual pages on the link

storage.fiat-bg.org/Books/Bravo_Brava_Marea/Marea_Workshop_Manual/Volume%201/Vol1.htm

the engine pages show the debimeter which also has some kind of airflow sensor. Is the MAF the sensor mentioned within the debimeter or is it before the debimeter or after it in the intake system????
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gerragrip is offline Reply With Quote Quote 
Old 12-09-2009   #9
Join Date: May 2005
Location: S Wales
Posts: 124
Thanks: 5
Trader Rating: 0
United Kingdom 
Re: Marea 125 HLX TD - Acceleration Issues

Quote Originally Posted by gerragrip View Post
Just checked for the MAF, couldn't find it.
Looking at mareas technical manual pages on the link

storage.fiat-bg.org/Books/Bravo_Brava_Marea/Marea_Workshop_Manual/Volume%201/Vol1.htm

the engine pages show the debimeter which also has some kind of airflow sensor. Is the MAF the sensor mentioned within the debimeter or is it before the debimeter or after it in the intake system????

If you are seeing a reference to a debimeter, you are looking at info for an early TD125 NOT the JTD. The later 1998 TD125's & JTD's all used MAFs.
Just follow the trunking from the air filter to the turbo & you'll find the MAF somewhere along the line! It'll have a 5 pin plug (4 on the TD, whcih has a separate air temperature sensor)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

pycoed is offline Reply With Quote Quote 
Old 14-09-2009   #10
Join Date: Sep 2009
Posts: 6
Thanks: 0
Trader Rating: 0
Re: Marea 125 HLX TD - Acceleration Issues

Sorry, my ignorance, thought all 2.4TDs were JTDs. My vehicle was first registered Nov 1997.
My car definitely has what is described in the Bulgarian website's Fiat technical spec as the Debimeter. I unscrewed a round multipin plug(it was at least 4-pin) from the underneath of it. If a Debimeter is part of the intake system is there still a MAF as described in the precious replies? If so, is the MAF inside the Debimeter? In that case does it mean unmounting and dissembling the Debimeter to get to it for servicing/cleaning? If the debimeter uses another system is there something comparable to the MAF that could be causing my problem?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gerragrip is offline Reply With Quote Quote 
Old 19-09-2009   #11
Join Date: Sep 2009
Posts: 6
Thanks: 0
Trader Rating: 0
Re: Marea 125 HLX TD - Acceleration Issues

Have tried independantly disconnecting pressure pipe to top of EGR valve(problem still exists) and disconnecting Debimeter(MAF) sensor cable(problem still persists), even combining the above. Will try the possible fix mentioned here of blanking the EGR valve next to see if that fixes the problem, hope i have some suitable metal lying around.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gerragrip is offline Reply With Quote Quote 
Old 05-10-2009   #12
Join Date: Sep 2009
Posts: 6
Thanks: 0
Trader Rating: 0
Re: Marea 125 HLX TD - Acceleration Issues

Blocked off egr exit with cutoff from an alufoil cake tray, didn't help, maybe slightly worse power problems, so ended up removing it again. Not sure what someone on this site was was talking about selecting the metal carefully as it could melt from hot exhaust gases. I suspect taht was nonsense really as if it's blocked off there is no hot exhaust gas flowing over the metal used(blocked flow) or does anyone believe that the hot exhaust flows all the way to the blockage point just so it can flow all the way back again even when there is an escape for it, albeit with some slight throttled back pressure, through the rest of exhaust system.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gerragrip is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Marea TD 125 acceleration & starting(long & sad tale) pycoed Marea 16 16-11-2008 15:53
(T) 99 (T) Bravo SX 80 - Acceleration Issues substance Bravo / Brava 1 27-06-2008 11:48