Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 14-11-2009   #1
Join Date: Oct 2009
Location: St Albans
Posts: 114
Thanks: 6
Trader Rating: 0
United Kingdom 
Weird front end problem

Hi, After going over a large speed bump (slowly and carefully) I've developed a strange front end problem. It's difficult to explain and I'm going to sound really flakey now but it feels weird through the clutch as you pulll away. You can also feel it when you brake to a standstill. There is no noise but it feels like the engine isn't connected properly to something important. My best guesses would be engine or transmission mounts or possibly suspension bushings. I'd have thought broken mounts would make some clunking noise..? Sorry about the crappy explanation but I can't think of another way of describing it. Any ideas? Nick
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nick600 is offline Reply With Quote Quote 
Old 14-11-2009   #2
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1226
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Weird front end problem

Could well be a mount. Need to get under and take a look.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 22-11-2009   #3
Join Date: Oct 2009
Location: St Albans
Posts: 114
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Weird front end problem

While changing the clutch I had a good look at the mounts and suspension bushings and they all look OK. The rear gearbox mount had a lot of flex in it when the plastic bush was removed, is that normal? I guess this problem could have been a symptom of the clutch packing up as the issue is not there at the moment. Fingers crossed it's gone for good.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nick600 is offline Reply With Quote Quote 
Old 22-11-2009   #4
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,369
Thanks: 1144
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Weird front end problem

If you are refering to the plastic bit in the middle of mount, it shouldn't come out.

This might be your problem.

Cheers

SPD
__________________
rallycinq is offline Reply With Quote Quote 
Old 22-11-2009   #5
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1226
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Weird front end problem

You might check that it's been fitted the right way round -- shiney side should be up.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 22-11-2009   #6
Join Date: Oct 2009
Location: St Albans
Posts: 114
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Weird front end problem

Ah, it just fell out so looks like that might be the problem. Off to Fiat again!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nick600 is offline Reply With Quote Quote 
Old 22-11-2009   #7
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,369
Thanks: 1144
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Weird front end problem

Quote Originally Posted by Nick600 View Post
Ah, it just fell out so looks like that might be the problem. Off to Fiat again!
Made of money?

Why not try Fluffy

Cheers

SPD
__________________
rallycinq is offline Reply With Quote Quote 
Old 22-11-2009   #8
Join Date: Oct 2009
Location: St Albans
Posts: 114
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Weird front end problem

I'll try Fluffy, I was just being impatient, certainly not made of money...I spend every last penny on my cars, my other car is a BMW 850 money pit, but I love both of them really

The plastic bit may be on the wrong way round as it's rattling like a bstod on decelleration. I'll live with it to the weekend, my wife is losing her sense of humour.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nick600 is offline Reply With Quote Quote 
Old 22-11-2009   #9
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,369
Thanks: 1144
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Weird front end problem

Quote Originally Posted by Nick600 View Post
wife is losing her sense of humour.
Thank your lucky stars that she at least has one to loose!

Cheers

SPD
Thanks Nick600 thanked for this post
__________________
rallycinq is offline Reply With Quote Quote 
Old 23-11-2009   #10
Join Date: Oct 2009
Location: St Albans
Posts: 114
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Weird front end problem

Turned the plastic thing around and the rattling has gone.
I had another look at the mount and it's totally shagged, I better change it before it gives out.

Thanks for your help chaps, I appreciate it. Nick
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nick600 is offline Reply With Quote Quote 
Old 23-11-2009   #11
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1226
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Weird front end problem

If you have any knocking about, it may just be worthwhile filling it with Sikkaflex, leave it to cure off the car, and then bolt it up.
Thanks Nick600 thanked for this post
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 07-12-2009   #12
Join Date: Oct 2009
Location: St Albans
Posts: 114
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Weird front end problem

I put on a new rear gearbox mount at the weekend and all my woes have now gone. The old mount was hanging onto life by a thread and was almost ready to give up entirely. Got the mount from shop4parts for about 20 all in. It's an easy job to fit, you have to remove the entire bracket then bolt the new mount onto the bracket off the car otherwise you can't tighten it down as it has no captive bolt. Other than that, piece of cake.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Nick600 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Cinquecento Front End Questions... Shunted Up Front steve38 Cinquecento / Seicento 6 03-06-2008 13:03
help weird whineing noise coming from front of the car sjones280982 Newbie Central 4 24-05-2008 15:21
(T) A weird problem... Sonic74205 Cinquecento / Seicento 2 12-02-2007 14:51
Weird Problem.... jdillon Lets Talk FIAT 1 11-01-2005 10:58
(T) A weird problem The younger modder Cinquecento / Seicento 2 08-06-2004 17:18