Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 06-11-2007   #1
Join Date: Nov 2007
Location: barnsley
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Question mk2 uno turbo starting problem???

hi there lads. right ive got a problem with my uno turbo. it wont start, its nearly starting btut wont fire up. theres a spark, weve checked the air flow meter, new distributor cap, new plugs, had an auto electrician out and he seems to think it is crank sensor. any ideas, thanks Gary.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gaz110uno is offline Reply With Quote Quote 
Old 06-11-2007   #2
Burninator of threads!
 
faster4_tec's Avatar
Join Date: Oct 2004
Location: Sunderland and LakeDistri
Posts: 4,242
Thanks: 9
Trader Rating: 0
faster4_tec has donated!
Mongolia 
Re: mk2 uno turbo starting problem???

could be. although I'm not sure it has one! although TBH I haven't got up close and personal with mine yet. just acquiring parts for a minor overhaul when the time comes
__________________
Volvo for Life
faster4_tec is offline Reply With Quote Quote 
Old 07-11-2007   #3
Join Date: Mar 2004
Location: staffordshire
Posts: 948
Thanks: 13
Trader Rating: 1
United Kingdom 
Re: mk2 uno turbo starting problem???

unplug the airflow meter and try starting it, if it runs but sounds like a tractor then you have a air leak inbetween the airflow meter and the intake i.e a split boost pipe
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

oldskoolmk1unoturbo is offline Reply With Quote Quote 
Old 08-11-2007   #4
Join Date: Mar 2004
Location: staffordshire
Posts: 948
Thanks: 13
Trader Rating: 1
United Kingdom 
Re: mk2 uno turbo starting problem???

hey mate got your pm, try and get a known working crank sensor and try it.

check everything is plugged in properly especially to the ignition coil, Louis on here has a mk2 which he is breaking for spares if not try on turbo collective theres always people breaking them on there
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by oldskoolmk1unoturbo; 08-11-2007 at 21:32.
oldskoolmk1unoturbo is offline Reply With Quote Quote 
Old 08-11-2007   #5
Shut Up, Fool!
 
thepottleflump's Avatar
Join Date: Jan 2005
Location: Surrey
Posts: 2,538
Thanks: 22
Trader Rating: 0
thepottleflump has donated!
United Kingdom 
Re: mk2 uno turbo starting problem???

If it was the crank sensor you'd be unlikely to get a spark, they also have a flywheel sensor so you need to check both. If you've got a Haynes manual it will tell you the resistance of both sensors, also check that the sensors pulse when cranked. Are your injectors working if you've got some noid lights you can test the injectors are getting a signal. Is your electric pump working?
__________________
1999 Alfa Romeo GTV V6
thepottleflump is offline Reply With Quote Quote 
Old 10-11-2007   #6
Experinced life risker
Join Date: Mar 2007
Location: Durham
Posts: 60
Thanks: 0
Trader Rating: 1
Gti180dom has donated!
United Kingdom 
Re: mk2 uno turbo starting problem???

Is there fuel getting into your rail? usually if its firing the odd time its the afm but it definately sounds pretty electrical. Did it cut out during driving or had it been left stood a while or what?
__________________
WWW.TURBOCOLLECTIVE.NET

FOR UNO - PUNTO - COUPE and LANCIA DELTA LOVERS!!!

Last edited by Gti180dom; 10-11-2007 at 13:50.
Gti180dom is offline Reply With Quote Quote 
Old 12-11-2007   #7
Join Date: Nov 2007
Location: barnsley
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: mk2 uno turbo starting problem???

hi mate, i drove the car back from london it was fine, it was stood for about a week, it started missing a little wen it started then i left it another week and it wouldnt start at all. wot do you mean afm? thanx mate
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

gaz110uno is offline Reply With Quote Quote 
Old 12-11-2007   #8
Join Date: Mar 2004
Location: staffordshire
Posts: 948
Thanks: 13
Trader Rating: 1
United Kingdom 
Re: mk2 uno turbo starting problem???

AFM is the Air Flow meter
Attached Thumbnails
Click image for larger version

Name:	P8050044 (Large).JPG
Views:	49
Size:	140.9 KB
ID:	34727  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

oldskoolmk1unoturbo is offline Reply With Quote Quote 
Old 28-11-2007   #9
Experinced life risker
Join Date: Mar 2007
Location: Durham
Posts: 60
Thanks: 0
Trader Rating: 1
Gti180dom has donated!
United Kingdom 
Re: mk2 uno turbo starting problem???

Quote Originally Posted by gaz110uno View Post
hi mate, i drove the car back from london it was fine, it was stood for about a week, it started missing a little wen it started then i left it another week and it wouldnt start at all. wot do you mean afm? thanx mate

That is wierd. Cant really comment without looking at it tbh. Check spark and fuel first, if theyre both there then that points to AFM, pick one up regardless cos theyre about 30 and its always good to have a spare one cos theyre a common problem. If that still doesnt start it, do a compression test. If compression is fine, uve fitted a new AFM and the engines getting fuel and spark and its STILL isn't starting.......youve stuck diesel in it!
__________________
WWW.TURBOCOLLECTIVE.NET

FOR UNO - PUNTO - COUPE and LANCIA DELTA LOVERS!!!
Gti180dom is offline Reply With Quote Quote 
Old 31-08-2017   #10
Join Date: Aug 2017
Posts: 1
Thanks: 0
Trader Rating: 0
Portugal 
Re: mk2 uno turbo starting problem???

Hello, i have a problem with my mk1 uno turbo ie, it have spark, so the crank sensors are ok
But the injectors just don't open, i have fuel on them and if I force them manually they let fuel out but when I try to start he does not open
I see the Voltage in the pins on the ecu all are ok,
If I change some wires it fires as he should but there is no spark
Anyone?? please
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

silvioss is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) How many Puntos are there on the Forum? - The Thread FiatStiloJTD Punto (Mk2/2b) 543 06-06-2008 17:15