Technical Washer not working

Currently reading:
Technical Washer not working


New member
Oct 21, 2022
Hi, my washerpump has stopped working - that is: the pump is OK when I connect power to it directly, fuse is OK and I have tried to change the relay in the engine compartment that should go to the front head light washer - even I dont think there is any - so I presume it is for the washerpump.

Could it be the contact? - but I think this is strange as is it is only front and rear sprinkler that is not working - and there is only one pump - it is just as I understand it the computer that changes the direction of the power to the pump.

Could I have overlooked something - or someone has better ideas than to take the contact apart - and do I need to take off the steering wheel to get to the contact?
Hi :)

Can you measure power at the pump connector...? its a lousy place for electrics.. so worth checking that 1st

Not a job I have done on a grande
I did not check that, as the pump worked fine with power directly from a battery and the connecter looked very nice.

I had a bit of trouble remowing the connecter and suddenly the pump came off the tank and I got a bit wet - then I removed the wheel and the wheelarch plastic-cover, so I could get better access and put the pump and connecter back again.
Gave up on finding the fault and drew a new electric wire directly from the battery, through af fuse to a very old spring operated switch (from when they still could make switches that lasts longer than the car) I drilled a hole for between instruments and the radio - went to inspektion and he just said: "You found a solution and that is fine".

It is only that it does not work a the rear - but who needs that anyway? - often I just remove the wiper and the motor to save weight - and it is much easier and more effective to wash and clean the rear window at the gasstation.
I have wondered if it could be a problem with the contact? If someone has experienced changing that could solve the problem - I might invest in a new one and have the trouble changing it when I anyway might have to do something about the digitals not showing properly on my speedometer cluster.