Technical Various issues

fowget

New member
Joined
Oct 30, 2009
Messages
3
We have an 03 Punto 5000000 which has been fine for the 3 years we have owned it. We have it serviced and MOT'd at Nationwide Garages as we save up our Tesco Clubcard vouchers, we have had no issues until this year. We were told at the service in August that the car was due a CAM Belt change due to the age of the car. We saved up and had this done in September. Two weeks later the exhaust started blowing and the engine management light started to appear now and again. We took it in last week and had the front flexy pipe replaced and a coil pack and plugs replaced. All was fine during the week but yesterday the engine management light came on again whilst the Wife was driving it.

Are we being taken for a ride, does it just need having a quick look at and some settings tweeked, or is it possible the other coil pack has now gone?

Please help.
 
OP
OP
F

fowget

New member
Joined
Oct 30, 2009
Messages
3
I think they are.

They said that they only changed one coil pack due to the cost of doing both but the other may fail soon. It just seems odd that we have had this trouble since they changed the cam belt as everything was fine before. Could they have damaged the coils when changing the belt?
 

rallycinq

Autotest Special
Joined
Mar 19, 2002
Messages
23,486
Location
Lake District....Moist
I think they are.

They said that they only changed one coil pack due to the cost of doing both but the other may fail soon. It just seems odd that we have had this trouble since they changed the cam belt as everything was fine before. Could they have damaged the coils when changing the belt?

Highly unlikely, but coil packs are not expensive. What did they charge you for a coilpack?

Cheers

SPD
 
Top