General Injector light error

Currently reading:
General Injector light error

coop67

New member
Joined
Sep 11, 2007
Messages
12
Hi everyone.
Today a light came on my dash. I have a 1.8 fiat marea on a S reg. the injector light appeared whilst going up a hill. i had travelled about 10 miles. the car did not have any difference in power or performance. i turned back for home when about 4 miles back the light went off. so i tried again but went a different way (ie not up that hill) i had travelled about 40 miles without the light coming on so i thought ok it was just a little blip. then again there was a hill, i had no option to go up it. half way up the hill the light came back on. again no difference in driving. so i carried on to my destination and the light went off. i managed to drive all the way back home, about 50 miles with no hills and the light didnt come on at all. i have spent the afternoon reading all the fiat injector probs on here, but would like to ask everyones advice aswell. many thanks in advance
BUT
update on injector light. i went for another drive today and the light came on, so it doesnt only happen up a hill. Also i saw that the temp gage was very static all the way back so out of curiosity i put the heater on warm and turned it to number2. within minutes the temp gage went down a bit and the injector light went OUT. any ideas???
 

jug

blessed are the apostates
Joined
Nov 28, 2005
Messages
27,935
Location
Durham
it means a sensor is intermittently going out of range or the ecu isnt getting a signal from it. at this stage its hard to diagnose because there is no noticable difference, also at this stage there is no guarantee that the ecu will have recorded a fault code. its probably best to leave it for now and see if the problem gets worse.
 
OP
OP
C

coop67

New member
Joined
Sep 11, 2007
Messages
12
Hi everyone.
Today a light came on my dash. I have a 1.8 fiat marea on a S reg. the injector light appeared whilst going up a hill. i had travelled about 10 miles. the car did not have any difference in power or performance. i turned back for home when about 4 miles back the light went off. so i tried again but went a different way (ie not up that hill) i had travelled about 40 miles without the light coming on so i thought ok it was just a little blip. then again there was a hill, i had no option to go up it. half way up the hill the light came back on. again no difference in driving. so i carried on to my destination and the light went off. i managed to drive all the way back home, about 50 miles with no hills and the light didnt come on at all. i have spent the afternoon reading all the fiat injector probs on here, but would like to ask everyones advice aswell. many thanks in advance
BUT
update on injector light. i went for another drive today and the light came on, so it doesnt only happen up a hill. Also i saw that the temp gage was very static all the way back so out of curiosity i put the heater on warm and turned it to number2. within minutes the temp gage went down a bit and the injector light went OUT. any ideas???

had the ecu read today with 16 key faults but NO injector faults.
he cleared the readings so i start afresh
he told me to go back to him with the light ON
so im off for a 50 mile round trip to see
 

jug

blessed are the apostates
Joined
Nov 28, 2005
Messages
27,935
Location
Durham
the key faults are definately old faults because they dont illuminate the injector light so ignore them.

the injector light is the same as the engine managenent light on other cars, it doesnt mean the problem is anything to do with an injector or even the fuel injection. it simply means there is a fault that is not the immob/airbag/abs, but it could be anything else.

it is often the case that a fault code is not stored until the problem becomes less intermittent. there are also several faults that will illuminate the light yet not create fault codes (even though they should in many of these cases). for example the lambda sensor, inlet temp sensor and battery voltage problems (alternator/earth strap) often do not cause fault codes to be stored when they should. i dont know why.
 
OP
OP
C

coop67

New member
Joined
Sep 11, 2007
Messages
12
hiya, thanks for your input , the bloke at the garage did say that the lambda sensor is working, BUT it could/should cut in a little earlier (whatever that means). apart from that all other tested things were 100% ok.

is it worth changing the lambda sensor myself to see if it cures the light problem, or run it and see what happens?

i have been quoted £65 from a car spares shop, for a new one
 

jug

blessed are the apostates
Joined
Nov 28, 2005
Messages
27,935
Location
Durham
at this stage i would only add some redex to the fuel tank, that can often clear up minor lambda faults. if your emissions test ok that is a sign that a new lambda would be wasted money at this stage and you should wait.
 
OP
OP
C

coop67

New member
Joined
Sep 11, 2007
Messages
12
hiya ppl . my light came on again today, so i went to the garage and he read the ecu for errors. the lambda was the only fault on there. so here is my queston. before i change it, is it possile for any other sensor having a problem, but the lambda was the only one picking it up?? from what i have read , the lambda controls petrol air mixture correct?? by the way adding redex had no effect. the light did go out on its own when the rad fan cut in outside the garage.
 

jug

blessed are the apostates
Joined
Nov 28, 2005
Messages
27,935
Location
Durham
is it possile for any other sensor having a problem, but the lambda was the only one picking it up??
many sensor faults can go unnoticed by the ecu. the ecu cant determine if the signal it is getting from any sensor is actually correct, all it can determine is if the signal is missing or out of range. by out of range i mean the signal is obivously wrong, for example because the voltage is lower or higher that it ever should be.
 
Joined
Aug 22, 2007
Messages
412
Location
Varazdin,Croatia
I had same problem with my 1.8 Marea but i have LPG multipoint injection. Light was on first ,last week, for few minutes,then off for one day and then on for 20 min and now its OK.I drive 2000 miles every month
 
Top