Technical fiat marea not running right

Currently reading:
Technical fiat marea not running right

hfiveplustwo

New member
Joined
Mar 2, 2012
Messages
1
please:confused: please:confused: please :confused:help my marea weekend 1.6 16v 2000 reg 86000 miles has stopped running right a couple of weeka ago my marea injector light came on then was flashing so had to nurse car home when i got home could not see what was wrong so i replaced the spark plugs then the ht leads still nothing so changed the temp sensor still nothing so disconnected battery because car was flat when i connected it back it was running fine again but after running it a bit it went wrong again same problem so i changed the coil pack still nothing so swallowed my pride and took it into garage to be daiognosised it came up with all the sensors i had unplugged and also injector 4 open curcuit so i stripped done car and replaced injector ran a bit better but still not right can anybody please help:bang:
 

MareaWeekend

New member
Joined
Mar 10, 2012
Messages
3
Try replacing the air filter and the fuel filter. My Weekend is playing about still (done the same mileage as you), changing the fuel filter has improved things a lot, but I still have a bad problem (loss of power in some situations, accompanied by lots of smoke). I'm changing the air filter tomorrow as maybe there's a blockage in the air intake? Both filters are cheap and relatively easy things to try if you are out of ideas...My car showed up no fault codes on the diagnostic tests at the garage, but the mechanic said it could possibly be an ECU-based sensor problem (e.g., the fuel injection rate being calculated incorrectly due to mis-sensing the load parameters?? e.g., the throttle positioning sensor may be faulty?).
 
Last edited:
Top