General Faulty thermostatic switch?

Currently reading:
General Faulty thermostatic switch?

Joined
Dec 5, 2005
Messages
2,849
Points
535
Location
Sleepy Suffolk
Hi all

Everything seems to be ok with my recently MOTd little car except for one thing - the engine fan does not come on when the temperature exceeds normal running temperature. I was stuck in traffic this morning running at 110 when I decided to turn around and go back home - the car quickly cooled down to between 70 / 90 when moving. In fact the car rarely reaches 90 and seems to be happy (even on long journeys) at around 70 - does this sound ok or is the thermostat faulty? Should it run 'hotter' in normal use?

The fan works as I have connected it straight to the battery - any ideas re. fixing this? (parts, cost etc.) I am looking to avoid fitting a switch to manually put the cooling fan on (but will do so if I cannot fix it as I don't fancy being stuck in traffic in the summer with no way to cool the engine down).

Would appreciate you educated advices!
 
unplug the switch, ignition on and then bridge the connections on the wire you've unplugged. the fan should spin. if it does, faulty swtich. if it doesn't check the fan fuse, and wiring.
 
lloydtyphoon said:
Ive just put a fan switch in mine and its a 10 minute job.

Lloydtyphoon, how much did you pay for a new switch? Is the 769 FIRE switch the same as a 999 FIRE switch? Or do you mean that you wired a seperate switch off the battery?
 
Many apologies....yes I have one, but.......one question to anyone that knows. The switch on my current panda the wiring part is in the middle but this one is to one side. I can't for the life of me think that it won't work exactly the same but why the difference in shape?

BTW I'll send off in the morning.
 

Attachments

  • thermoswitch.JPG
    thermoswitch.JPG
    49.6 KB · Views: 47
  • Thermoswitch1.JPG
    Thermoswitch1.JPG
    47.3 KB · Views: 19
Alan.D said:
Many apologies....yes I have one, but.......one question to anyone that knows. The switch on my current panda the wiring part is in the middle but this one is to one side. I can't for the life of me think that it won't work exactly the same but why the difference in shape?

BTW I'll send off in the morning.

Cheers Alan, I will let you know how I get on

Thanks again!
 
Pandarus said:
Lloyd, did that sort the problem?

Yes, it did solve the problem. Thats the reason my car has an emission failure on its test sheet! It didnt actually fail the emissions, just started overheating whilst he was about to do it, so he didnt feel safe to continue!
 
Hi Alan

Found an hour to get out and fit / test the new switch. The fan now cuts in around 95 - thank you so much, I don't have to worry about queuing in the traffic now!

Have updated your trader rating and hopefully will be able to re-pay the favour some day from my (currently limited) stock of spares!
 
Pandarus said:
Have updated your trader rating and hopefully will be able to re-pay the favour some day from my (currently limited) stock of spares!
It'll grow whether you want it or not... however if you arrive at the point where you have something that Alan hasn't... it's time to start getting rid of some of it.
 
Back
Top