General fault finding fun!

Currently reading:
General fault finding fun!

arc

this is where i stand
Joined
Oct 8, 2003
Messages
19,719
Location
Manchester
decieded yesterday i needed to get out of stafford for a bit, so jumped in my car and set off for home. got round the block, realised i forgot my phone so went back to the house. i stopped at a junction,hitting a dip in the road as i did. the engine made a really odd noise and stalled. so i started it back up, revved it a bit and the exhaust sounded really loud and the engine did not sound happy.let go of the throttle and it stalled. started it again, and then it stalled. i was now getting very annoyed with it. i couldn't get it to idle, without me holding the throttle open so i couldnt get to the engine to have a listen to see what was wrong. so i got it started again, and drove back round the block to my house. very loud exhaust going on, and pretty much no power from the engine (n)

checked fuel pressure at the rail, that was fine so then checked spark, fine on one coil pack, but nothing on the other. swapped the inputs over, the fault moved - so the coil packs were fine. :confused:

quick look on the laptop, no config errors. checked the LEDs on the ECU and both ignition drivers were triggering like they should. checked the tech docs and diagrams i'd made when wiring the ECU in, and worked out which wire must've been at fault. climbed upside down into the passenger footwell, and looked at the wiring. problem was pretty obvious.. the main loom plug had half come out. plugged it back, and it fired up and idled perfectly. solved. :slayer:

oh the joys of an 'odd cento' hehe. (y)
 
OP
OP
A

arc

this is where i stand
Joined
Oct 8, 2003
Messages
19,719
Location
Manchester
haha nice one (y) least it wasn't too serious :p might wanna think about getting that loom plug held in securely though!

aye, there are two little screws that hold it in (like a on computer monitor cable). i've put them in place now (y)

Glad it was an easy fix! How do you connect it up to your lappy?

Its a Megasquirt, so just links up with a serial cable (y)

Kristian

:yeahthat:
 
Top