Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 27-10-2008   #1
Join Date: Oct 2008
Posts: 26
Thanks: 3
Trader Rating: 0
The Usual Speedo Problems - MK1 Punto

Hi everyone, first post, and guess what, some issues!

Have recently bought a '99 60sx and the speedo has started to play up.

Have had a trawl through the forums and it seems that this is a fairly common set of problems - the speedo sits at 20, and sometimes goes to 120 and above with the mileage ticking over too. when you turn off the ignition the needle goes to zero as normal. there's quite a few old threads but they generally seem to peter out before any conclusion, so my apologies for raking this up again!

Have taken off the instrument panel and it looks ok, no obvious cracks or faults with the circuit board, and all the connections seem to be tight - only thing here is that the copper is a little dirty on the pcb where the connectors slide on and off - am i right in thinking this only shows that there is a good tight connection here, or should i give these a rub with a little contact cleaner?

All fuses look good, no probs at all, they seem very clean (worryingly so possibly!)

Once I had looked at the instruments and panel i took off the speedo sensor and worm gear - they also seem fine - the sensor seems dry and no obvious loose connections - I actually get the impression it may have been changed before due to a different colour sheathing on the cables.

The little plastic worm gear looks to be in decent order too - no major wear or damage at all. would i be able to visually tell if it was screwed though?

anyway, put it all back together and then the speedo needle now wasn't working - mileage was ticking over fine, but nothing from the needle. This is leading me to believe that it's actually a fault somewhere in the speedo unit itself - there must be decent signal to it for the mileage to tick over correctly is my reasoning - can anyone confirm that? (or shoot me down in flames )

So, in summary, if anyone can pick through my reasoning i'd appreciate it, my plan for next course of action is to buy a 2nd hand panel and see if that fixes the probs - is this my best way to go? if i can find a breaker locally (dubln) who'd let me do it, would the best thing be to drive over and try the panel / and or speedo sensor?

thanks in advance for any advice!
spf
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spf is offline Reply With Quote Quote 
Old 03-11-2008   #2
Join Date: Mar 2007
Location: Cornwall
Posts: 368
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Must be a new Fiat virus.

Exactly the same happened to ours 3 days ago.
As you say, wild flickering from 20mph to off the scale and then back to normal as if nothing had happened

Currently have head in sand hoping the problem goes away!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiat_freak is offline Reply With Quote Quote 
Old 03-11-2008   #3
Join Date: Oct 2008
Posts: 26
Thanks: 3
Trader Rating: 0
Re: The Usual Speedo Problems - MK1 Punto

yup - it definitely seems to be fairly common.

anyway - brief update - got a new instrument panel this morning and it's still doing all the same stuff - except the speedo needle is very very rarely moving now. Looks like my reasoning about it being the panel due to the miles still ticking over is nonsense

Am going up to a local breakers this afternoon to replace the speedo sensor unit (and gear if neccessary) so will let you know how i got on.

as a slight aside - don't turn on your ignition if not all the connections are made to the instrument panel (probs best disconnect the battery actually). I now have the airbag warning light on due to trying to figure out which connector was for which sytem on the instruments. doh! ah well, should only be a tenner to get it reset.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spf is offline Reply With Quote Quote 
Old 03-11-2008   #4
Join Date: Mar 2007
Location: Cornwall
Posts: 368
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Thanks spf
Would appreciate an update as and when you sort it!
Got 'til August for next MoT so no pressure!!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiat_freak is offline Reply With Quote Quote 
Old 03-11-2008   #5
Join Date: Oct 2008
Posts: 26
Thanks: 3
Trader Rating: 0
Re: The Usual Speedo Problems - MK1 Punto

was the speedo sensor.

everything back to normal. I'd suggest a quick trip to the local scrappy/breaker and try a new sensor. they're dead easy to get on and off, especially if you only remove the electronic bit to try it first.

hope you get it sorted as easily as i did in the end fiat freak.

just have to decide if i like my new instrument panel better than my old one now
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spf is offline Reply With Quote Quote 
Old 04-11-2008   #6
Join Date: Mar 2007
Location: Cornwall
Posts: 368
Thanks: 7
Trader Rating: 0
United Kingdom 
Cool Re: The Usual Speedo Problems - MK1 Punto

Thanks for that spf
Daft question! Wtf is the speedo sensor? Gearbox?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiat_freak is offline Reply With Quote Quote 
Old 05-11-2008   #7
Join Date: Oct 2008
Posts: 26
Thanks: 3
Trader Rating: 0
Re: The Usual Speedo Problems - MK1 Punto

if you look at the back of the engine, roughly in the middle but slightly towards the passenger side, there should be a wire running to the back of the transmission - this connects to a plastic part (round top with tubular piece protruding into the engine) which has a 20mm nut connecting it to the transmission.

if you have a 1.2 8v its shown (and labeled) in the guides section - "where everything is on a 1.2fire engine" (would put the link in, but not allowed till I have 5 posts!)

You just need to undo the 20mm nut and lift off the speedo sensor. disconnect the wiring and rreverse the process with your replacement one. takes 2 mins!

only other thing that may be wrong there is that the actual speedo sensor unit connects to a plastic gear inside the transmission. to get this out, just below where you undid the 20mm speedo sensor nut is a small screw (about 8mm hex head) - loosen this off and lift out what is left in the hole where the speedo sensor was - there should be a metal sleeve and inside that a plastic gear. have a look at it and see if it's intact, especially where it connects to the speedo sensor - if it looks worn this may be your problem.

once you locate these it's really easy - I think the arrangement is basically the same on a 16v engine, but am open to correction on that.

the big question is - do you have ABS? If so, this all means nothing as the speedo works in a different way - by the sounds of your problem I'd guess not tho! seems far too similar to not be the same thing.

hope you get it sorted!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by spf; 05-11-2008 at 12:06.
spf is offline Reply With Quote Quote 
Old 04-12-2008   #8
Join Date: Mar 2007
Location: Cornwall
Posts: 368
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Very belated thanks for that
Only just seen the post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiat_freak is offline Reply With Quote Quote 
Old 17-12-2008   #9
Join Date: Mar 2007
Location: Cornwall
Posts: 368
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

h

Changed speedo sensor for a brand new one
Worked fine for 20 miles and now playing up exactly the same
Sometimes I hate cars!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fiat_freak is offline Reply With Quote Quote 
Old 20-01-2009   #10
Join Date: Oct 2008
Posts: 26
Thanks: 3
Trader Rating: 0
Re: The Usual Speedo Problems - MK1 Punto

Hi fiat freak, didn't see that you'd replied again...

had the same sort of problem when i put the new sensor in - i ended up taking it off again and just making sure that the plastic worm gear was well set / positioned, and then very carefully re-assembled the electronic sensor. seems to have sorted it (haven't been 'going' at 140mph for a few weeks now nehows!)

hope you get it sorted.

seŠn
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spf is offline Reply With Quote Quote 
Old 20-01-2009   #11
Join Date: Aug 2006
Posts: 3,213
Thanks: 267
Trader Rating: 0
MikeSalt has donated!
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Fiat freak, if it is not your speed sensor, then chances are it is the little circuit behind the dashboard. Quick way to determine this is if the fault corrects itself when you slap the top of the dashboard hard. If this does fix it, then chances are it is not the sensor, but the circuit in the instrument panel.

You do not need a whole new instrument cluster, or even a new speedometer. All you need is the little circuit board that sits behind the speedometer. I bought a speedometer including this circuit for a about £25 brand new, delivered, from Ebay. Remove and strip down you instrument cluster, remove the circuit board, unclip from the speedometer and the main board cabels then replace with the new circuit. 15 minute job if it all goes the right way.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by MikeSalt; 20-01-2009 at 11:54.
MikeSalt is offline Reply With Quote Quote 
Old 09-11-2010   #12
Join Date: Nov 2010
Location: coventry/warwick
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Hi everyone!

im new on here so i apologise if this is posted somewhere it shouldnt be

i have a 1994 elx 90 cabrio, the speedo is not working at all and the fuel light is on constantly... the rev counter and other dash lights etc are all working as they should... just not the speedo...?? if any one can help id really appreciate it, i know my way around a car being brought up with 5 brothers and a dad who are all mechanics, unfortunately theyre all at the other end of the country! and i reckon asking an actual fiat fanatic would help me out a bit more

cheers in advance! Trey
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

trey1984 is offline Reply With Quote Quote 
Old 09-11-2010   #13
I like to be different!
 
bredsticz's Avatar
Join Date: Jul 2009
Location: Manchester
Posts: 4,479
Thanks: 213
Trader Rating: 1
bredsticz has donated!
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Is it cable speedo on them or electric?
Also you have ABS?

Not too familiar with mk1's
__________________
Any MK2 punto parts needed? Let me know!
I have 2 punto's worth of parts for sale
bredsticz is offline Reply With Quote Quote 
Old 09-11-2010   #14
Join Date: Apr 2008
Posts: 16,588
Thanks: 911
Trader Rating: 0
Ziggy122 has donated!
Eggs Champion, Fruit Pairs Champion
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

Quote Originally Posted by bredsticz View Post
Is it cable speedo on them or electric?
Also you have ABS?

Not too familiar with mk1's
I'm pretty Sure its electronic
i thinks only a cable on Cuiq/Sei

Ziggy
__________________
!!WANTED!! 3dr Mk2 Punto Roof Bars !!WANTED!!

Meet Bumble-Bee


Ziggy122 is offline Reply With Quote Quote 
Old 10-11-2010   #15
I like to be different!
 
bredsticz's Avatar
Join Date: Jul 2009
Location: Manchester
Posts: 4,479
Thanks: 213
Trader Rating: 1
bredsticz has donated!
United Kingdom 
Re: The Usual Speedo Problems - MK1 Punto

If its electronic then the sensor is always 1st to go and common.
Im sure i said that to someone with a mk1 though and was told its cable
__________________
Any MK2 punto parts needed? Let me know!
I have 2 punto's worth of parts for sale
bredsticz is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Fiat Punto MK1 speedo problems fiatpunto123 Punto (Mk1) 2 16-01-2011 16:08
(G) Mk1 Punto Speedo!! Mk1PuntoRyan Punto (Mk1) 3 24-07-2007 18:38
(T) MOT checks/usual problems? VUK Uno 13 12-06-2006 15:36
Fiat Punto Mk1 Speedo/clock Set With Revcounter. dave Auction Watch 0 10-02-2005 01:41