Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 08-06-2018   #1
Join Date: Jun 2018
Posts: 4
Thanks: 0
Trader Rating: 0
South Africa 
Limp mode 5th gear under load @ 2500Rpm

I have had a lot of trouble since buying this vehicle(thinking that's why they sold it. fiat panda 1.2 active

Symptoms:
Car goes into Limp mode 5th gear under load @ 2500Rpm going up the hill. it then throws a p0105 error code
when slowly applying petrol, when it gets to 1900 the revs drop to 1200 and goes up and down between them
Car misfires constantly that causes a jerky experience

I Had it at 6 mechanics that did the following:
Replace MAP sensor.
Replace coils.
Cleaned Idle valve.
cleaned intake manifold.
Replaced all injectors.

I am really at my wits end here. Help would really be appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

juan2dupreez is offline Reply With Quote Quote 
Old 08-06-2018   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 19,737
Thanks: 708
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by juan2dupreez View Post
I have had a lot of trouble since buying this vehicle(thinking that's why they sold it. fiat panda 1.2 active

Symptoms:
Car goes into Limp mode 5th gear under load @ 2500Rpm going up the hill. it then throws a p0105 error code
when slowly applying petrol, when it gets to 1900 the revs drop to 1200 and goes up and down between them
Car misfires constantly that causes a jerky experience

I Had it at 6 mechanics that did the following:
Replace MAP sensor.
Replace coils.
Cleaned Idle valve.
cleaned intake manifold.
Replaced all injectors.

I am really at my wits end here. Help would really be appreciated.
Hi. What year..and what engine type?

Sounds like a poor connection.

Has it ever run well?

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 08-06-2018   #3
Join Date: Jun 2018
Posts: 4
Thanks: 0
Trader Rating: 0
South Africa 
Re: Limp mode 5th gear under load @ 2500Rpm

It is a 2007 1.2 8 valve.
Also replaced spark plugs and leads

it did run fine for the first 2 months before starting to act up.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

juan2dupreez is offline Reply With Quote Quote 
Old 08-06-2018   #4
No strings on me
 
Eklipze3k's Avatar
Join Date: Nov 2007
Location: York
Posts: 14,662
Thanks: 646
Trader Rating: 0
Eklipze3k has donated!
United Kingdom 
Re: Limp mode 5th gear under load @ 2500Rpm

After having the above work done, have you had the codes read again and is it still just P0105? What are you using to read the codes (hint: MultiECUScan is the best answer)?
Likes varesecrazy liked this post
__________________
Eklipze3k is offline Reply With Quote Quote 
Old 08-06-2018   #5
Join Date: Sep 2009
Posts: 13,842
Thanks: 656
Trader Rating: 0
United Kingdom 
Re: Limp mode 5th gear under load @ 2500Rpm

Download MutiECUScan and get an adapter from eBay. Then you read the codes for yourself. You should even be able to drive the car with it connected to see what shows up when it goes into limp mode.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DaveMcT is offline Reply With Quote Quote 
Old 08-06-2018   #6
Join Date: Apr 2011
Location: Near the M4
Posts: 19,737
Thanks: 708
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by juan2dupreez View Post
It is a 2007 1.2 8 valve.
Also replaced spark plugs and leads

it did run fine for the first 2 months before starting to act up.
I think thats the older 60hp configuration.

As a 1st thing.. I would change the main
Battery to engine EARTH cable.. they rot internally and can cause all kind of weird stuff.. cheap too.

WHERE IS CAR BASED?

IF UK somebody near you could possibly assist with better diagnostics.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 08-06-2018   #7
Join Date: May 2018
Location: Isle of Portland
Posts: 89
Thanks: 5
Trader Rating: 0
United Kingdom 
Re: Limp mode 5th gear under load @ 2500Rpm

P0150 code is a barometric sensor fault code (map sensor)but also indicates a barometric circuit failure so chances are there is a poor or dirty connection in a plug/socket or a failing wire.
Another issue I have come across is the two plugs that connect to the ECU not making contact at all pins, my simple fix was to run long tie wraps around the ECU strapping the plugs down tight, seems to have worked!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

09 johno is offline Reply With Quote Quote 
Old 09-06-2018   #8
Join Date: Oct 2016
Posts: 1,370
Thanks: 85
Trader Rating: 0
United Kingdom 
Re: Limp mode 5th gear under load @ 2500Rpm

disconnect the MAP does it run any better ? Yes it will throw the engine check light on but should run fine for testing.

I got a repacement MAP for mine frome the scrap yard. Punto Grande has the same part number on it. No doubt other Fiats also.



Third part MAP sensors are a lottery. Some work fine and last. Some seem to have a short life.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

koalar is offline Reply With Quote Quote 
Old 13-06-2018   #9
Join Date: Jun 2018
Posts: 4
Thanks: 0
Trader Rating: 0
South Africa 
Re: Limp mode 5th gear under load @ 2500Rpm

Hi guys,

Thanks so much for the replies. Was away on business. The car is in CPT South africa. Only displays P0105/

Car Miss fires badly and is not drive-able with the MAP unplugged.

I will replace the ground wire and strap the ecu plugs down today and revert back.

Thanks so much for the overwhelming great responses.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

juan2dupreez is offline Reply With Quote Quote 
Old 18-06-2018   #10
Join Date: Jun 2018
Posts: 4
Thanks: 0
Trader Rating: 0
South Africa 
Re: Limp mode 5th gear under load @ 2500Rpm

Problem fixed. It was the throttle sensor in the throttle body.
Likes koalar liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

juan2dupreez is offline Reply With Quote Quote 
Old 18-06-2018   #11
Join Date: Oct 2016
Posts: 1,370
Thanks: 85
Trader Rating: 0
United Kingdom 
Re: Limp mode 5th gear under load @ 2500Rpm

Thanks for the feedback.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

koalar is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Limp mode Simmo1109 Punto Evo 4 14-03-2017 16:25
(T) Limp mode balachluie Ducato 3 17-03-2015 11:14
(T) No turbo until 2500rpm and random limp mode with no warning light BravoCraig Bravo 7 10-11-2014 22:51
(T) LIMP mODE pLUS multihull Stilo 1 22-10-2013 18:28
(T) Limp mode again wegi Bravo 8 08-08-2011 08:14