Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools Search this Thread
Old 24-07-2021   #1
Join Date: Jul 2021
Posts: 6
Thanks: 1
Trader Rating: 0
United Kingdom 
Weak Spark on start - time for an Electronic Ignition?

Hi all,

A few weeks ago my 1988 Panda (1000CL) broke down after the ignition coil failed. I subsequently replaced the coil and the engine would start but would run rough (just as it felt as the ignition coil started to fail). With each start the engine would find it harder and harder to start, to the point now that it now won't start at all, including when wired up to another car's battery.

I've diagnosed this as being due to a weak spark when cranking the engine over. I've tested each spark with a light tester, and the light is much weaker than it should be - every now and then the light is bright (when the spark is strong - I don't know why it is infrequent like this?) and the ignition appears to catch and almost start the engine but it then returns to the weak spark and engine cranking over.

I've checked the obvious things (spark plugs, HT leads, distributor cap, etc...) and these are all in good nick. I should add that I haven't been able to look inside the distributor itself due to a stripped screw head on the cover, so this part has not been checked. So my question is:

Is there an easy fix for this, or is it time for me to install an electronic ignition? And if so, does anybody have any suggestions for a good value electronic ignition for the 1000cc engine?

Thanks all
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Avspotter; 24-07-2021 at 20:43.
Avspotter is offline Reply With Quote Quote 
Old 25-07-2021   #2
Join Date: Jul 2021
Posts: 6
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Classic Panda Weak Spark on start - time for an Electronic Ignition?

All fixed now - was due to contacts on the distributor having slipped so they had minimal separation. I'll leave this post up though for anyone else having the same issue.
Likes jackwhoo liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Avspotter is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Does not start weak spark Fires Uno 2 04-06-2014 23:18
(T) no spark in electronic ignition samantha Bravo / Brava 2 26-02-2006 14:51