Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 16-02-2017   #1
Join Date: Feb 2017
Posts: 43
Thanks: 0
Trader Rating: 0
United Kingdom 
Heater Blower not functioning properly

Hey everyone,

So my heater blower has been playing up a lot recently. Sometimes it wont come on, others times it works fine and everything in between. It often makes a lot of noise without actually pushing any air out.

So I read the forums and changed the heater resistor. This unfortunately made no difference so I changed the wire loom too again no change. So im suspecting the motor itself has gone wrong.

Before I replace the motor which isn't cheap (Around 80) is there anything else I should try / check?

The fuse also looks fine.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Meska77 is offline Reply With Quote Quote 
Old 17-02-2017   #2
Join Date: Aug 2016
Posts: 50
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Heater Blower not functioning properly

If the resistor swap didn't work, or the loom, you've changed the major components already. Motor is the next thing. Have you tried eBay for a used or refurb motor? eBay can be hit or miss, but I just order replacement head lamps and got near as new refurbs, damn happy. Good Luck
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

LeadMagnet is offline Reply With Quote Quote 
Old 17-02-2017   #3
Join Date: Feb 2017
Posts: 43
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Heater Blower not functioning properly

Ebay is where i've found the cheapest which is around 65! Still very pricey.

Ill try a new motor and report back here incase others have similar issues.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Meska77 is offline Reply With Quote Quote 
Old 21-02-2017   #4
Join Date: May 2009
Location: Southampton, England
Posts: 455
Thanks: 17
Trader Rating: 0
United Kingdom 
Re: Heater Blower not functioning properly

If the car has air con, its likely to have a pollen filter if that's old and blocked you won't get much air, however it wouldn't cause excessive noise. Perhaps worth checking/replacing/removing and see if you get more air. If the noise is like a bag of nails then its the motor failing or the impeller fouling. How many miles, when was the pollen filter last changed?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by johnhififan; 21-02-2017 at 15:36.
johnhififan is offline Reply With Quote Quote 
Old 23-02-2017   #5
Join Date: Feb 2017
Posts: 43
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Heater Blower not functioning properly

Hey everyone quick update. Changed the blower motor today and it's working perfectly again. Thanks for all the replies
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Meska77 is offline Reply With Quote Quote 
Old 28-12-2018   #6
Join Date: Dec 2018
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Heater Blower not functioning properly

Hi, was it a big job changing the blower?

My blower has stopped working, after a few days of working intermittently and it was noisy toward the end. The resister looks fine, no melted wires or discolouration so it looks like I need a blower replacement.

Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

FrankyFiat is offline Reply With Quote Quote 
Old 31-12-2018   #7
Join Date: Apr 2011
Location: Near the M4
Posts: 19,326
Thanks: 696
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by FrankyFiat View Post
Hi, was it a big job changing the blower?

My blower has stopped working, after a few days of working intermittently and it was noisy toward the end. The resister looks fine, no melted wires or discolouration so it looks like I need a blower replacement.

Thanks
Apparently not too bad.

Good info in Grande Punto section
FAQs
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 17-01-2019   #8
Join Date: Dec 2018
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
I've just replaced my blower. Got one from eBay for 58.95. Literally a 5min job to replace and I'm no expert.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

FrankyFiat is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Heater not working properly edbay Abarth Grande Punto 8 15-02-2018 20:49
(T) Heater blower trog Doblo 1 19-08-2016 12:27
Speedometer not functioning properly southcoastden Tech Talk 1 10-06-2014 15:02
(T) Heater Fan only working properly Adrian Howard Doblo 2 10-08-2013 12:41
(G) Blower not working properly on a Seicento SX 899cc 1999? minidriver Cinquecento / Seicento 3 13-10-2006 13:20