Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 4 Days Ago   #1
Join Date: Jan 2020
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Bravo 2008 1.9 mjet Airbag light no errors

Hi all, I hope someone could help me with my problem. I replaced battery, checked earthing grounds and fuses and done proxi alignment, but airbag light and message is still on. No errors to be find, only one stored B1002 low battery erased and never came back. I own a car 2 months and don't know it's history. Also no seat belt light or buzzer and no belt buzzer volume in menu. Is it faulty airbag ecu or do you have any other ideas?
Attached Thumbnails
Click image for larger version

Name:	lA9O0eU.jpg
Views:	8
Size:	758.5 KB
ID:	205706   Click image for larger version

Name:	GCOdkZk.jpg
Views:	7
Size:	916.8 KB
ID:	205707  

Click image for larger version

Name:	E4G26mm.jpg
Views:	7
Size:	779.0 KB
ID:	205708   Click image for larger version

Name:	Z4HnbHo.jpg
Views:	10
Size:	882.5 KB
ID:	205709  

Click image for larger version

Name:	s0j5rwg.jpg
Views:	9
Size:	704.0 KB
ID:	205710  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Omas is offline Reply With Quote Quote 
Old 3 Days Ago   #2
Join Date: Jan 2020
Posts: 2
Thanks: 0
Trader Rating: 0
USA 
Re: Bravo 2008 1.9 mjet Airbag light no errors

I have exact same issue. Mine came up on the highway, no code, just error on the dash.

The only thing I noticed is that while passenger seat belt light and beeping is on, driver is stuck in "fastened" and 0mAh. I am sure I was getting the beep before. Could it be related to that? Can you check values for your seat belts? All resistances of all airbags seem to be ok, no other issues.

Hold on, I looked at your screenshots, how come all airbags resistances are 0? It should not be the case...
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by hestati; 3 Days Ago at 23:27.
hestati is offline Reply With Quote Quote 
Old 3 Days Ago   #3
Join Date: Jan 2020
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
That's why I think there is a problem with airbag ecu. When using multiecuscan I can't even turn on no seat belt light from airbag module actuator.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Omas is offline Reply With Quote Quote 
Old 1 Day Ago   #4
Join Date: Jan 2020
Posts: 2
Thanks: 0
Trader Rating: 0
USA 
Most probably airbag ECU is fried. Strange that you can even connect to it. Have you tried proxy alignment? What does it say?

Also, check body and instrument panel modules, any errors there?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

hestati is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Urgent! Airbag light on without errors XicoZe 500 43 21-02-2019 10:08
Bravo Bravo 1.9 Mjet 2008 minime1488 Members Motors 1 03-06-2018 19:30
(G) Bravo 1.9 Mjet 2008 - Various issues minime1488 Bravo 3 01-06-2018 19:48
(T) Fiat Bravo 1.6 mjet 2008 cabin air flow stuck on windscreen. gazcoombe Bravo 7 20-01-2016 23:14