Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 15-09-2008   #1
Join Date: Aug 2008
Location: Peterborough
Posts: 1,317
Thanks: 84
Trader Rating: 0
neilshep has donated!
United Kingdom 
Unhappy multijet 120 1.9 starting problem

I've had my Bravo for 3 months now, and just topped 2000 miles. Its my first diesel car. The last few days it has had an intermittent starting problem. Up till now, I've waited for the glow plug light to go out, turned the key, and its started within about 2 or 3 compressions. Now about half the COLD starts, it turns over for for about 5 to 10 seconds before it fires up. It then runs perfectly.

When it messes about, the preheater light illuminates "as normal", and there is a click from the dash as it goes out. I'm thinking faulty relay or connection in the glow plug circuit. Any thoughts? Would this show up on a fault memory?

Its not a great problem at the moment, but when it gets colder.............
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

neilshep is offline Reply With Quote Quote 
Old 16-09-2008   #2
-~Moderator~-
 
a1ant's Avatar
Join Date: May 2006
Location: UK
Posts: 4,531
Thanks: 679
Trader Rating: 1
a1ant has donated!
United Kingdom 
Re: multijet 120 1.9 starting problem

Hi mate,

The cold start system does a self diagnosis, and if it detects a fault, then the glow plug light will flash for about 30 seconds after it goes out. Fiat examiner can check its operation in more detail however. How long is the glow plug light staying on for before it goes out?
Secondly, when you turn the ignition to MAR, do you hear the fuel pump prime? (whurring) Do you hear any gurgling at all??

Alan
__________________
If you see a problem post, please click the report button
a1ant is offline Reply With Quote Quote 
Old 16-09-2008   #3
Join Date: Aug 2008
Location: Peterborough
Posts: 1,317
Thanks: 84
Trader Rating: 0
neilshep has donated!
United Kingdom 
Re: multijet 120 1.9 starting problem

Quote Originally Posted by a1ant View Post
Hi mate,

The cold start system does a self diagnosis, and if it detects a fault, then the glow plug light will flash for about 30 seconds after it goes out. Fiat examiner can check its operation in more detail however. How long is the glow plug light staying on for before it goes out?
Secondly, when you turn the ignition to MAR, do you hear the fuel pump prime? (whurring) Do you hear any gurgling at all??

Alan
The glow plug light is only on for about a second, two at the most, and its always been like that. The light just goes out and stays out, no flashing. I'll have to listen for any whirring or gurgling in the morning.
__________________
His: CL Jazz Blue Bravo 1.9 Mjet 120 Gone but not forgotten
Now Kia Ceed Sportswagon GT-Line 1.0 TurboGDi
Hers: C4 1.4SX -still looking for the Robot button - Gone - Now Kia Ceed hatch 1.6GDi
neilshep is offline Reply With Quote Quote 
Old 17-09-2008   #4
Join Date: Aug 2008
Location: Peterborough
Posts: 1,317
Thanks: 84
Trader Rating: 0
neilshep has donated!
United Kingdom 
Re: multijet 120 1.9 starting problem

When I first turned on the ignition this morning, the heater fan and radio were on, so I turned these off, and turned of the ignition. I then turned the ignition on, and heard the fuel pump whirring at the back for a second or so, but no gurgling. By this time the glow plug light was out, so I turned the key to start, and it started perfectly. I'll have to see how it goes this evening now!
__________________
His: CL Jazz Blue Bravo 1.9 Mjet 120 Gone but not forgotten
Now Kia Ceed Sportswagon GT-Line 1.0 TurboGDi
Hers: C4 1.4SX -still looking for the Robot button - Gone - Now Kia Ceed hatch 1.6GDi
neilshep is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Fiat Ducato 2.3 120 Multijet 2008 MELAS Ducato 8 16-08-2010 18:59
(T) Bravo 120 multijet - remap? Tad-bravo Bravo 6 18-08-2008 19:05
(T) Multijet starting problem gibbo501 Punto (Mk2/2b) 1 08-08-2008 15:07
(G) Carrying A Motorctcle in a 120 multijet? lostrider Scudo 5 17-06-2008 17:26
(T) 1.6 Multijet 120 remap? Dan_MK Bravo 1 02-05-2008 15:32