Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 08-12-2006   #1
Join Date: Nov 2006
Posts: 66
Thanks: 2
Trader Rating: 0
United Kingdom 
Rear wiper and pipe attachment

My rear wiper works but i cant get any water spray. Today i took off the rear cover to check if the water pipe was connected. As mentioned by someone before the pipe was already disconnected. I've got a couple of pics below







The thing is i cant see where the pipe is supposed to be connected originally? Is it behind the motor and would i need to remove the wiper motor to reattach the pipe?

I've tried disconnecting the power connector as shown and looking for a pipe input but have failed to find it.

Also i was just checking to see if water comes out of the loose pipe when i press the rear wash/wipe stalk. It makes a whirring noise but there was no water at all coming from the pipe. I held it for a few seconds but still no water. Does that mean the pipe is blocked aswell as unattached to the wiper?

Any help appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by evo149; 08-12-2006 at 16:46.
evo149 is offline Reply With Quote Quote 
Old 08-12-2006   #2
Join Date: Nov 2006
Location: Dublin
Posts: 15
Thanks: 0
Trader Rating: 0
Ireland 
Re: Rear wiper and pipe attachment

The water pipe fits onto basically where the arm comes thru the glass, Best is to removed the motor and you will see it!

I think it is 3 allen key bolts and remember to remove the arm by clipping off the plastic bit and using a no 10 spanner to removed the bolt then the motor and gear bit will come off. Not that tricky just a few rubber washes to be weary off.

One of the connector bits will need to be replaced for the water to come thru, just look in your engine bay and follow the pipes from the water bottle.
Hope this helps!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bong is offline Reply With Quote Quote 
Old 08-12-2006   #3
Bravo 155 HGT
Join Date: Aug 2006
Location: Ayr, Scotland
Posts: 3,115
Thanks: 10
Blog Entries: 3
Trader Rating: 1
mountainmachine has donated!
Beach Bobbing Bob Champion, War on Iraq Champion
United Kingdom 
Re: Rear wiper and pipe attachment

Yup sounds like a blockage on a connector so replace and then glue the connector back into the wiper mechanism, i havent but most people do i have a longer pipe so doesnt get pulled out!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mountainmachine is offline Reply With Quote Quote 
Old 09-12-2006   #4
Join Date: Nov 2006
Posts: 66
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

Quote Originally Posted by bong

One of the connector bits will need to be replaced for the water to come thru, just look in your engine bay and follow the pipes from the water bottle.
Hope this helps!!!

ok i will try that, but its so cold today i couldnt feel my hands working on the motor . so i will try when its sunny again.

Also when you say the connector needs to be replaced, is that in the engine by the water tank or somewhere near the wiper motor?

Thanks for your response
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

evo149 is offline Reply With Quote Quote 
Old 09-12-2006   #5
Join Date: Nov 2006
Posts: 66
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

Quote Originally Posted by mountainmachine
Yup sounds like a blockage on a connector so replace and then glue the connector back into the wiper mechanism, i havent but most people do i have a longer pipe so doesnt get pulled out!


Hi is it a connector in the engine by the tank or by the wiper? roughly what does it look like?

If you check my pic where its showing the pipe hanging off, does it look like someone has added a rubber extension to the pipe, or is this original fitment?
thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

evo149 is offline Reply With Quote Quote 
Old 10-12-2006   #6
Bravo 155 HGT
Join Date: Aug 2006
Location: Ayr, Scotland
Posts: 3,115
Thanks: 10
Blog Entries: 3
Trader Rating: 1
mountainmachine has donated!
Beach Bobbing Bob Champion, War on Iraq Champion
United Kingdom 
Re: Rear wiper and pipe attachment

Ahh yea where the electrical tape is! I would take that off and see what its doing!, As for connectors, there is the wee plastic one on the end, it can get blocked, and others nearer the washer tank, blow through them see if you get resistance etc, it must be blocked somewhere if the pump is kicking in. even try disconecting right in the engine to see if it squirts out there.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mountainmachine is offline Reply With Quote Quote 
Old 11-12-2006   #7
Join Date: Dec 2006
Location: West Lothian
Posts: 14
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

There should be a plastic connector under the tape. This enables you to disconnect the pipe without disturbing the joint at the end of the pipe. The end joint gets pushed off it's seat by the pressure build up caused when the water hits the jets. That's why most people glue them on. There is a one-way valve on the pipe, in the engine compartment between the reservoir and the passenger bulkhead.It looks just like a plastic connector. It's supposed to stop the water draining back in to the tank. If it's faulty, it can take while for the water to reach the jets because the pipe has to fill up first. Usually, the rear washer pipe from the tank is a light colour and it changes to black after about 12 inches. The one way valve is usually where the pipe changes colour. To test the valve, disconnect the pipe before it and start your washer motor. This will tell you if water is reaching the valve. Next, stick the valve on the end of the pipe and start your washer motor again, if water gets throught he valve your ok, if not, you need a new one. Hope this helps.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by J-OK; 11-12-2006 at 13:55.
J-OK is offline Reply With Quote Quote 
Old 14-12-2006   #8
Join Date: Nov 2006
Posts: 66
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

Hi

Is the connector the black one shown in this pic? I was wondering if it would be possible to remove the pipe that goes to the rear wiper just to check that water is coming out of the reservoir as it should. But is it the left or right pipe on this pic for the rear wiper?





Also i can easily remove the electric connector at the top, but the pipes on the bottom end seem to be tight or glued on. So i dont know, i was thinking if i managed to take them off would i be able to get them back on?

How could i test if the connector is ok and water is going to the boot end of the pipe? If it was going to the back, water should squirt out of the loose pipe in the boot yes?

any advice welcome.
thanks



Quote Originally Posted by J-OK
There should be a plastic connector under the tape. This enables you to disconnect the pipe without disturbing the joint at the end of the pipe. The end joint gets pushed off it's seat by the pressure build up caused when the water hits the jets. That's why most people glue them on. There is a one-way valve on the pipe, in the engine compartment between the reservoir and the passenger bulkhead.It looks just like a plastic connector. It's supposed to stop the water draining back in to the tank. If it's faulty, it can take while for the water to reach the jets because the pipe has to fill up first. Usually, the rear washer pipe from the tank is a light colour and it changes to black after about 12 inches. The one way valve is usually where the pipe changes colour. To test the valve, disconnect the pipe before it and start your washer motor. This will tell you if water is reaching the valve. Next, stick the valve on the end of the pipe and start your washer motor again, if water gets throught he valve your ok, if not, you need a new one. Hope this helps.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

evo149 is offline Reply With Quote Quote 
Old 15-12-2006   #9
jug
blessed are the apostates
 
jug's Avatar
Join Date: Nov 2005
Location: Durham
Posts: 13,806
Thanks: 554
Trader Rating: 1
jug has donated!
United Kingdom 
Re: Rear wiper and pipe attachment

if you pull either pipe off water will come out without using the pump, gravity will do it for you. besides you dont need to test here if you can hear the pump working when you use the stalk switch.

remove the pipe at the point where the white pipe copnnects to the black pipe (behind fusebox at back right of engine bay). now you can see if water is getting that far (it usually does). disconnect the white pipe then try squirting water, it should come out at this point.

now try blowing down the black pipe with the black plastic bit still connected, it wont let you blow because the plastic thing connecting the white and black pipes is blocked (the non-return valve). fix/replace that, then reconnect the pipe in the boot, and it should work.
__________________
2.0 twinspark veloce
jug is offline Reply With Quote Quote 
Old 15-12-2006   #10
Join Date: Dec 2006
Location: West Lothian
Posts: 14
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

First of all, the connections on the pipe are quite tough to get off. I levered them off with a broad blade screwdriver. You will notice that the two pipes run into the wiring loom cover. The connector is sometimes under there. I opened up the cover and traced the grey pipe until I found the in-line one-way valve. When you see it, you'll know what it is, there will be a little arrow on it to show the flow direction. Disconnect at the grey pipe ( before the valve) and activate your washer motor switch, the wash motor should pump water through. If it doesn't, you've a problem between the wash motor and the one-way valve but that's unlikely. Now, remove the valve completely and connect it to the grey pipe only. Once again, activate your washer motor. If you are getting water though at that point, the problem must be further back in the system. If not the valve's a duffer and you will need to replace it. I got mines from a scrappy. Connect it all up again and then try to pump the water through to your tailgate connector which should still not be connected up. If water eventually reaches the rear connector then your OK up to there. Glue the rear connector into the jet connection (I used no more nails) and leave to set over night. In the morning try again. Remember it may take a while to fill up the pipe again. If you are still definitley not getting water through your jets, then the jet assembly must be the problem. I'm afraid that you'll have to strip off your wiper motor and check out the jet assembly. It also helps if you position your rear wiper off glass while you are trying to pump the water through. Otherwise, the blade will be trying to wipe a dry surface. This all sounds rather long winded but it will only take you about 10 minutes. Good luck
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

J-OK is offline Reply With Quote Quote 
Old 19-12-2006   #11
Join Date: Nov 2006
Posts: 66
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

Thanks for the response guys.

I tried to find the connector between the pipes today. But it seems to be tucked away quite well.

Regarding the fusebox, would i need to take the cover off shown here to see the pipe/connector? Or is it possible another way?




I'm kind of reluctant to start taking bits and pieces of the clip and connectors, in case i disturb something that shouldnt have been. So i'm just making sure. thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

evo149 is offline Reply With Quote Quote 
Old 19-12-2006   #12
jug
blessed are the apostates
 
jug's Avatar
Join Date: Nov 2005
Location: Durham
Posts: 13,806
Thanks: 554
Trader Rating: 1
jug has donated!
United Kingdom 
Re: Rear wiper and pipe attachment

first remove the fuse box cover (one screw on top),
then remove the rubber strip behind it that goes from one side of the engine bay to the other,
then remove the round push in clips that hold that thing on which sits under the rubber strip.
now pull it forward and you can see the pipe.
where the 2 pipes connect the area behind the fusebox
its easy dont be scared.
Attached Thumbnails
Click image for larger version

Name:	pipepic.JPG
Views:	5
Size:	47.2 KB
ID:	22209  
__________________
2.0 twinspark veloce
jug is offline Reply With Quote Quote 
Old 19-12-2006   #13
Join Date: Dec 2006
Location: West Lothian
Posts: 14
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

Oh dear! you seem to be having a time of it. I must say, I'm quite surprised that you haven't got it yet, it should only be about a foot from the washer pump. The pipe should be routed through the bulkhead and along under the door kickplate. If you wish, you could take the kickplate off, turn back the carpet and get access to the pipe. If you cut it through, you could then check if you are getting water to that point. To re-connect the pipe you'll need to get one of the little in-line connectors, like the one at the tailgate, and plug it all back together again. You should be able to get one from the scrappy. If you get water to that point, that should signify that the one-way valve that you can't find is ok. If not, then you'll have to track it down and check it out. Just be careful if you go this route. If you have a cd changer fitted in the rear of the car somewhere, the cable for it will probably run alongside the water pipe. Make sure you cut the right one!
__________________
j-ok
J-OK is offline Reply With Quote Quote 
Old 20-12-2006   #14
jug
blessed are the apostates
 
jug's Avatar
Join Date: Nov 2005
Location: Durham
Posts: 13,806
Thanks: 554
Trader Rating: 1
jug has donated!
United Kingdom 
Re: Rear wiper and pipe attachment

Quote Originally Posted by J-OK
Oh dear! you seem to be having a time of it. I must say, I'm quite surprised that you haven't got it yet, it should only be about a foot from the washer pump. The pipe should be routed through the bulkhead and along under the door kickplate.
the non return valve is behind the engine bay fusebox (as shown in the pic), about 4/5ft of tubing away from the pump. also the pipe is routed through the roof so you cant access it under the door kick plate.
__________________
2.0 twinspark veloce
jug is offline Reply With Quote Quote 
Old 20-12-2006   #15
Join Date: Nov 2006
Posts: 66
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Rear wiper and pipe attachment

Great instructions guys! really appreciate all the comments and advice given.

I was going to have a go at it again today. But it's so cold and foggy outside. Plus it was already getting dark by the time i had a chance. I think i might have to leave it for a while until a brighter day.. i will be back on this one
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

evo149 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Cinquecento GhostWKD's Turbo Cinq 56k warning GhostWKD Members Motors 251 20-07-2009 15:23
(T) Rear Wiper Wash neoseal Bravo / Brava 6 22-05-2006 18:00
(T) Seicento rear wiper... Is this thing fused!?! SpongeBobSquareCar Cinquecento / Seicento 7 27-12-2005 07:06
(T) Rear wiper motor 'clicking'! tony witney Bravo / Brava 1 18-09-2005 14:35
(T) rear wiper pipe cm246 Uno 3 12-04-2005 13:14