Technical Uconnect issues

Ez2517

New member
Joined
Jan 11, 2015
Messages
201
Location
Vienna
It arrived today :slayer:What also arrived was an answer from connects2, which says that the kit does not connect the original microphone to the aftermarket radio.
Does anyone know how the microphone is connected to the UConnect system ? Maybe it is still possible to connect it somehow to the Pioneer .... I don't want to glue the Pioneer microphone somewhere unless I absolutely have to ...


Brandy
 

Ez2517

New member
Joined
Jan 11, 2015
Messages
201
Location
Vienna
This takes more time than expected ... the infodapter kit missed a cable which they now send me, guess that will take another 2 weeks :bang: and I still have to solve the microphone and the USB connection ...
 

seano500L

New member
Joined
Apr 7, 2019
Messages
2
I have been a happy and proud owner of a 550L MPW for four years and the only complaint I had was the fact that the eco:drive application never worked (I could not manage to make it work on my mac). However in the last few weeks my Uconnect system just stopped working. First the sat nav will stay stuck in initializing mode and the same with the phone connection. Then suddenly the radio switch off after a couple of minutes. I have to say that in February the car was recalled to the dealer for safety fix that had to do with the entertainment system. But the issues started a couple of months after that so I am not sure it is related.

Has anyone found the same type of issues with Uconnect?

Thanks
My car has much the same problem. Last few months the radio/satnav turns off randomly after being turned on, and will then turn back on shortly after on most occasions.
The Fiat logo shows on the screen but it doesn't then progress to the normal information display.
Went to Fiat dealer last week and they advised they can't install a download fix as things stand and to disconnect the car battery overnight and fingers crossed, if it restarts and goes beyond the logo display then they can install the update.
Didn't go beyond the logo, so stuck. This car is just 5 years old - Fiat need to sort this. Will be going to social media, as clearly the garage can't be expected to sort it.
 

seano500L

New member
Joined
Apr 7, 2019
Messages
2
I have been a happy and proud owner of a 550L MPW for four years and the only complaint I had was the fact that the eco:drive application never worked (I could not manage to make it work on my mac). However in the last few weeks my Uconnect system just stopped working. First the sat nav will stay stuck in initializing mode and the same with the phone connection. Then suddenly the radio switch off after a couple of minutes. I have to say that in February the car was recalled to the dealer for safety fix that had to do with the entertainment system. But the issues started a couple of months after that so I am not sure it is related.

Has anyone found the same type of issues with Uconnect?

Thanks
I've got exactly the same problem with my 500L. I paid £500 extra to get the top of the range DAB & Satnav unit when buying the car new in October 2014. Tyres wear out, oil needs changing, but an integral technical feature like this is like a door or seating - you have every right to expect it to last the average life of the car, which has got to be more than just one year beyond the warranty.
I've had it checked out and the Fiat dealer is not able to repair it and has quoted just over £1,100 to replace it. I've contacted Fiat Customer Services and they have come back to me today to say that while the request to replace it for me at their cost was declined, they are offering me a goodwill gesture of discounting the cost of the part to £495 (with VAT and installation on top).
To me that's welcome but just not adequate. We also have a 500c, and although we really like both cars compared to the mundane brands that are around, this makes me seriously question whether I'd buy another Fiat.
 
Last edited:

Powellj3

New member
Joined
May 5, 2014
Messages
60
My UConnect also failed on my 2016 MPW within days of the expiry of the warranty. Also after me taking it to my Fiat Garage before expiry and being told there was nothing wrong. Finally ended up paying £220 for the new unit. The local dealer then were unable to Proxi Align the unit.
It's amazing how many of these units are failing but even more amazing that nobody in Fiat has ever heard of one failing!
I have still got my old VP2 unit and may look to getting it fixed and offer it for resale. The fix cost must be well under the second hand value.
 

alclot

New member
Joined
Jun 6, 2019
Messages
6
Hi mates,
I have my uconnect 5 with problem only logo on screen and no work.
Maybe can I update firmware to fix that right?
Problem is menu doesnt work to do update by buttons. Is there other way to do it?
Thanks a lot
 

Attachments

  • WhatsApp Image 2021-08-24 at 12.09.09.jpeg
    WhatsApp Image 2021-08-24 at 12.09.09.jpeg
    253.4 KB · Views: 11
  • WhatsApp Image 2021-08-24 at 12.09.21.jpeg
    WhatsApp Image 2021-08-24 at 12.09.21.jpeg
    319.3 KB · Views: 14
  • WhatsApp Image 2021-08-25 at 08.49.54.jpeg
    WhatsApp Image 2021-08-25 at 08.49.54.jpeg
    289.7 KB · Views: 11
Last edited:

freemind

New member
Joined
Sep 13, 2021
Messages
4
Hi,

I bought a Fiat 500L (3rd hand), of 2015.

This car is from Canada and I'm in Europe (Greece).

The problem is that the radio doesn't lock on the radio stations with even frequency.
For example can't lock on 89.0, 89.2, 89,4 etc

Also NAV doesn't have Europe maps.

Do you know what should I do?

Is there any European update that I could download or something else?
 
Top