Technical Radiator coolant temperature too high

Currently reading:
Technical Radiator coolant temperature too high

Ffoxy

Telford's Own...
Joined
Apr 26, 2007
Messages
13,617
Its warm in Telford today... 22degrees. Nothing like Greece or Italy in the Summer. :D
I got into my car, its been stood for 3 hours, a short 15 minute trip before that. I turned on the key, waited for the Glowplug light to go out and turned... Shuddered and stopped, got a Beeeeep and a warning "Radiator coolant temperature too high, stop the engine!" :eek:
Switched off, waited a while, tried again and the same thing happened. :eek: :eek:
A third attempt and all was well again. No problem driving. Coolant level perfect. :confused:

Anyone else had this? If so what did you do? If anything. Is this a FIAT spurious alert?
 
OP
OP
Ffoxy

Ffoxy

Telford's Own...
Joined
Apr 26, 2007
Messages
13,617
SORRY!

Car is a 56plate 1.9 GPS not re-mapped just boggo! :)
 

kip02

New member
Joined
Sep 19, 2006
Messages
97
Location
Stockton on Tees
I get this message sometimes. It always seems to be when the car is cooling down and then is started again not when it is cold.

I think the exact message is " Excessive radiator fluid temperature, stop and switch off engine" read it that many times tbh.

I've taken it to my dealers to check and they said no error messages were recorded when they hooked it up to the computer and they don't know what it is. But i can't take it to show them as it only seems to happen every now and again.

From my limited mechanical experiance (none;) ) could it be a dodgy temperature sensor that is not right?
 
Joined
Sep 12, 2004
Messages
39,858
Location
Preston
you will probably find it needs new air intake sensor on manifold...there is a post on this somewhere in this section.
 

Rich

Former FIAT Obsessive
Joined
Jul 2, 2002
Messages
3,543
Location
Torquay
The GP we have just bought had this on startup when we went to testdrive it - worrying times ahead! :p
 

tommy_8884

NFFC
Joined
Sep 1, 2007
Messages
784
Location
Stratford-Upon-Avon
My car showed this message a few weeks back, it was stone cold and it was -3 outside so i just took the key out and tried again! Started no trouble. Mine is also the 1.9. Mine didnt beep though, come to mention it it never has!
 
Top