Technical Panda Multijet 2005 - mileage has stopped recording

Currently reading:
Technical Panda Multijet 2005 - mileage has stopped recording


Jun 17, 2023
I have done 248547 or thereabouts as of 23 Dec ...... then i looked down and the mileage indicator has reset to ----- i.e. zero. All other indicators are ok when i toggle through.... i will have a problem at MOT if not fixed with next couple of months. Help please......... i was told to post on this forum....... one guy said at 400k km the mileage is reset...... but how do i get the mileage guage to restart/continue recording again? how do i get it restored for MOT purposes?
I don't think there is a legal option

The dash odometer get locked out

Not seen it happen on a Panda. But that's what use to happen on other fiat models

It's still recording the correct milage, it just can't display it

Same with some Corolla and Prius as well

Ignore the posts on doing a proxi or getting a new dash both have been tried and haven't work, unless someone come along and says it worked

It can be reprogrammed with the correct equipment but that would be illegal
Last edited:
You can still read it electronically via examiner and maybe MuiltiECUscan

I can't find anything doing a search through the mot manual, tried milage and odometer then gave up

I know around 2018 it was an advisory but not a fail