Technical JTD 115 Boost pressure lower than "Desired"

chemomche

New member
Joined
Aug 19, 2013
Messages
12
Hi, i got a 2003 stilo jtd. I felt that the power is less then before so i made a log of the ECU to check the boost and i saw that the actual boost is less that the Desired boost pressure. It catches up here and there but at the peaks it is 200mBars less.


Here is the log
boost.jpg


Is this normal? From the graphs i saw on the net, the boost is usually very close to desired and even more in some moments.
If this is not normal, what should be the cause?
 

sussexa

Donated
Joined
Oct 21, 2007
Messages
1,055
Location
north wales
the log is not showing but the usual suspects would be sticking open egr, boost leak from hoses , or vnt actuator not giving full spool position so issue with vanes, vnt vac pipes leaking or vnt solenoid issues.
200mbar doesn't sound real low can you read maf value as well as boost might help test things without disassembly.
a low boost low maf might suggest vane, vnt issue ,sticky egr
a low boost high maf might suggest a boost leak after turbo
think about blanking egr if not already done.
 
OP
OP
C

chemomche

New member
Joined
Aug 19, 2013
Messages
12
Forgot to mention it, the ERG is blocked. Blocked it last weekend, but there was no change which should mean that it was working properly before.

So i will do another log with maf then
 
OP
OP
C

chemomche

New member
Joined
Aug 19, 2013
Messages
12
I just remembered that i got another log with boost control/solenoid measurement in, unfortunately it do not have desired boost - only boost, rpm and boost control.

795540_EDBB2_C05_C3.jpg


I see that the limit is 75% which should be ok, but the solenoid is cutting the boost each time the revs go up, while the pressure is not so too much....
 

sussexa

Donated
Joined
Oct 21, 2007
Messages
1,055
Location
north wales
I still see no logs just sqare with cross in it.
just type in a few values from the logs at peak boost or maf or rpm whatever, just state a few like this example
revs=2650 boost =1986mbar maf= 986mg/I
and idol also
revs=850 boost=1001mbar maf=485mg/I
must be error on loading logs up(or try a screenshot and add as a picture)
 
OP
OP
C

chemomche

New member
Joined
Aug 19, 2013
Messages
12
Ok, may be i upload the pics wrong.
I just did a log on the drive to work.
At idle:
853rpm, maf - 483,4mg/l, boost 943mbar, desired boost 950mbar,

MAX values for the run:
2807rpm, maf - 3276mg/l, boost 2060mbar, desired boost 2120mbar

At some of the peaks
- 1650rpm, 764mg/l, 1282mbar, desired 1855mbar
- 1910rpm, 940mg/l, 1531mbar, desired 1734mbar


I hope this gives some view...
 

sussexa

Donated
Joined
Oct 21, 2007
Messages
1,055
Location
north wales
Has this occured suddenly since egr blank ?
If so check around blank you may have a boost leak.
If it was there before could still be a boost leak elsewhere.
The last 2 peak values you listed are fairly low revs and the turbo is only just beginning to spool, i think actual will always lag requested below 1800 revs or so.
It would be worth eyballing the turbo vnt actuator operation, either with someone starting car stopping and restarting as you watch or by pulling the vac pipe off the actuator while its idling.
Both should give same result with actuator travelling 10mm-13mm or so from min spool position to max spool position. Fairly quickly and smooth .
Could be a leaky vac hose resulting in actuator not pulling all the way to max spool pisition(actuator pulling arm all the way to the stop screw)
Search for some previous threads ive put vids to vnt actuator stuff.
Regarding log pics , personaly i save as png and upload ok as attachment on here.
Im not sure if typo but maf value of 3276mg/i looks wrong was it 1276mg/i
And also theres also a chance the map sensor is reading low or clogged.
Quick enough to remove it and give it a blast of carb cleaner till clean, refit and recheck.(back of inlet manifold 1 bolt holding in, theres a guide for cleaning im sure)
And lastly are you pretty high up? The idle pressure is pretty low 950mbar ,
If so you will see less boost anyway as air is thinner, turbo works harder to make boost at altitude.
If you are high up and theres anywhere more sea level close by worth cheching at lower altitude.
 
Last edited:

sussexa

Donated
Joined
Oct 21, 2007
Messages
1,055
Location
north wales
Just seen post above about vnt%
75% is max spool position usually idling and full throttle.
As you accelerate , below a certain fuel input the vnt% is read from an ecu map so boost can lag desired and ecu not bothered, then above a certain fuel input it switches to closed loop and uses actual boost as a feedback to adjust vnt%.
20% is minimum vnt(fully open trying to reduce boost)
So sometimes people feel a kick a it switches open loop to closed loop and increases vnt to match boost vs desired boost.
Example a sudden spike in vnt% for little input in speed or acelerator but fuel may be 1mm3 into closed loop.
It varies the switching point as revs and fuel rises also (so may not follow any pattern)
But if vnt% is too high at high revs it might also suggest a boost leak or vnt issue(theres no feedback on vnt %, so ecu asks for 75% but has no idea if its in 75% position)
Id expect vnt to drop into 30-40% vnt on hard acceleration 3-3500revs.
 
OP
OP
C

chemomche

New member
Joined
Aug 19, 2013
Messages
12
- after i blank the egr there was no change
- i will examine the vnt at first chance i get, may be in the weekend
- the maf max value is acurate, not a mistake - 3276mg/l
- i read some threads for the maf, so i wil ltry to unplug it and see if there is change
- i am at about 600m over sea level

And thanks for the fast respond:worship:
 
OP
OP
C

chemomche

New member
Joined
Aug 19, 2013
Messages
12
Last evening i unplugged the maf to see if it will make any difference. At the beginning i thought i felt the car ride better, but it was only buttdyno and after a couple of minutes i realized there is no difference. This morning plug the maf and again no difference, so this means that the maf is ok, right?
However, i am planing to give the maf and the map sensors a clean soon.
 
OP
OP
C

chemomche

New member
Joined
Aug 19, 2013
Messages
12
I made another log too - 3th gear, 1500 to 3500rpm at full throttle
Again the maf shows pretty low mg/l....can i have blocked intake?
 

Attachments

  • 3th gear.png
    3th gear.png
    34.1 KB · Views: 184
Last edited:
Top