Technical instrument panel warning lights problem

Currently reading:
Technical instrument panel warning lights problem

boilerman

New member
Joined
Oct 27, 2007
Messages
9
Location
CORNWALL
I have a problem that manifested itself about 4 weeks after having a turbo problem sorted out and a service recall front suspension mod done on my Stilo 1.9JTD 115 Dynamic 2003 model, though I dont expect its linked.

When about to start the engine, the system goes through its 'pre flight' checks and glowplug light goes off, then the key is turned to start the engine, lately ALL the panel warning lights have been comming on and staying on and the tacho, speedo, fuel and temp gauges freeze, the clock also resets to 00.00 and any stored info eg trip distance, consumpion figuires etc., in the computer are erased!!:eek:
This happens about 4 times out of 10 now and is becoming a real annoyance, the only way I have found to get rid if the lights is to disconnect the battery for 20 secs then reconnect, then I have to reset the clock, date etc., it has now caused the service warning to appear even though there's still 4000 miles and six months to go before service is due!
All service's bar 1 have been done by a fiat dealer, but after the one that wasn't done by fiat it was taken there to get the service clock reset, (at a cost of £50 :mad:).
Can anyone shed any light on what the problem may be please or do I have to tke it to the local agent to have it put on the diagnostic machine and get ripped off again? :bang:
 
OP
OP
B

boilerman

New member
Joined
Oct 27, 2007
Messages
9
Location
CORNWALL
thanks for the reply, but I cant seem to find the thread you are on about, can you point me in the right direction eg:- page number etc., please :confused:
 
Top