Technical Erratic/ Bouncing RPM at idle ( 900-3500!)

Currently reading:
Technical Erratic/ Bouncing RPM at idle ( 900-3500!)

varuns10

New member
Joined
Jun 19, 2009
Messages
10
Location
Mumbai
Hi guys,

My recently aquired palio S10 is behaving nuts to say the least.
The battery not charging light came up on my dash , it was concluded the alternator is blown.
Yesterday morning when I re-charged the battery and cranked the car (to take to alternator repair guy, as Fiat A.s.s said - " Replace the alternaror sir .. Rs.12500 / - including taxes !)

The RPM needle stared bouncing from 900- 3500 when idle, the engine kept on revving madly!

So i switched of and again cranked , drove it like mad max for 10kms , but na the same when i idled .

Could it be a Throttle body ?

Or its just that the alternator is not giving enough current so engine is revving to try and pump more current ?

Is it safe for the car engine to drive it for 35 kms ? (Alternator repair guy is 35 km from my place.)

I think i should fix the alternator first and then see if the prioblem persists.

suggest !:bang:
 

planet_rocker

New member
Joined
Nov 3, 2006
Messages
99
Location
Kolkata
Hey Varun,

the problem has not been solved yet? i thought you got it checked and repaired??

see if the rpm is dancing then IMO it is the Throttle body - it needs cleaning - ask the mechanic to open the air intake pipe near the throttle body and spray required amount of carb cleaner to clean the idle control valve inside - you cannot dismantle the TB of the 1.6. also rev the car while spraying the cleaner. once done reset the ecu by disconnecting the battery for > 30mins.

see if the problem occurs again.

are you using system G - if not try it with regular unleaded fuel.
 
OP
OP
varuns10

varuns10

New member
Joined
Jun 19, 2009
Messages
10
Location
Mumbai
@planet : The head mechanic of the Bosch Service centre where i nentend to repair my alternator has gone on leave for 15 days. I took my car , his juniors were not confident of 1.6 Palios, though they have done 1.2 Palios. ( I noticed they were trying to look for the alternator) so decided my car is not going to be their test piece.
While driving back the car this problem started.

To top it up an 3-wheeler bumped the rear end at signal , leaving a nice love bite !!

seems am having tough days with this beast !
:bang:

I hope its back on road befor Dussehera !!!

Thanks for you advice and time mate !
 

chrizano

New member
Joined
Dec 13, 2010
Messages
9
Hey varuns.
Im am experiencing the exact same problem. Had the car with the Fiat agents in our countery. They cleaned the throtle body and told me to cjange the battery (which was due) to see if the problem stil arises.

Currently the car is with them and hopefully I can share and give you some feed back on what they might have found.

Regards
 

PaulSmit

New member
Joined
Feb 18, 2009
Messages
30
Location
Pretoria
hi guys.

check the vacuum.

my car had the same problem and ever since i installed my vacuum gauge and replaced the vacuum pipe the problem is gone.

don't ask my what the problem was....thinking it might me a vacuum leak as the engine heats up the pipe expands and starts to leak
 
Top