General Electrical Problem: Panda stopped whilst driving

Currently reading:
General Electrical Problem: Panda stopped whilst driving

iportu

New member
Joined
Oct 25, 2007
Messages
3
Hi,

I bought a Panda Selecta 1993 a couple of months ago and it is a joy of a car. I was very please with it until today, whilst driving, suddenly, all the lights went off, the engine stopped and it cruised to a stop. Now when I try to start none of the lights switch on and none of the lights work except for the hazard lights and the inside/driver's light. I assume that it is a relay/fuse problem but I am not at all sure which one. I have checked all the fuses I could find and they all seem alright. Do any of you have any views or advice you could give me?

Thank you very much.
 

Alan.D

Ban the Mongol rally
Joined
Mar 27, 2004
Messages
13,622
Location
West Cumbria
There is a Main fuse on the bulkhead can't remember where so search the site. If it goes it would cause the problems that you describe.
 

Most Easterly Pandas

Speed Reader of the Year!
Joined
Aug 15, 2007
Messages
44,234
Location
Norwich, Norfolk
Hope its not catchie, not long ago brought a 1993 Selecta myself.

One thing it could be is the ECU, passenger foot well under cloth dash, just check the plug/loom is in securly. Just push it and wiggle it a bit, doubt it is the prob as these are very secure (as I found when I went to fit a tachometer to it).

The only other thing I can think of is the ignition lock / barrel. Supplies power to everything except comstantly live circuits like hazards and interior light/horn. Hopefully its not compleate barrel, could just be the plug which goes into this is loose, but you'll probably have to remove the steering shroud.

Keep us upto date with the diagnostics, best of luck.

Jon.
 
OP
OP
I

iportu

New member
Joined
Oct 25, 2007
Messages
3
Just a quick update:

Thank you very much for your comments. Tried looking for that main fuse. I thought I had found it - a black connector with red wiring, under the bonnet? When I looked at it I could separate the two bits but there was not obviously a fuse in it. Also if the ECU was the problem, would that explain the lack of hand brake light? I am now working on the ingition barrel/switch. The barrel however looks OK when you turn the key... I tried going to Halfords and getting the PANDA book to have a look t the wiring diagram but they have to order it in !?!? I now remember that just before stopping it peeped at me several time, I do not know whether this is anything significant? I will keep you posted if anything else comes up.
 
OP
OP
I

iportu

New member
Joined
Oct 25, 2007
Messages
3
Latest update - I took the front cover off to try and get to the ignition switch - I think I was supposed to do this from the bottom now but I am a complete newbie here. I then put it back again and ti started working again... I started to move wires and stuff around to see whether I can find what might have been loose but nothing... I cannot seem to be able to replicate the fault now. Do you have any views/opinions?

Thanks.
 
Joined
Oct 17, 2006
Messages
1,056
Location
Nottingham
Panda wiring can be a nightmare - especially if you are electrically challenged like me. As someone else said here, the earths are often the cause of random behaviour although this is not always so bad on the later models.
 
Top