Technical car wont start

Currently reading:
Technical car wont start

stezgt

New member
Joined
Jan 27, 2006
Messages
7
My brothers cinquecento wont start.When you turn the key the injector warning light comes on along with clicking relays near the ecu and humming sound from the dash.
I would be very grateful if anyone could help with this problem..
Thanks Steve,:)
 

rallycinq

Autotest Special
Joined
Mar 19, 2002
Messages
24,589
Location
Lake District....Moist
OK, put the headlamps on, and with somebody trying to start the engine, check whether the headlamps stay bright, or go dim.

If they go dim, then the battery is flat and needs recharged, or replaced.

If the lights stay bright, then there is something up with the starter circuit, possibly a wire off the starter.

Report back

Cheers

D
 
OP
OP
S

stezgt

New member
Joined
Jan 27, 2006
Messages
7
the battery is showing over 12v on the test meter and the car wont bump start.
cheers Steve
 

rallycinq

Autotest Special
Joined
Mar 19, 2002
Messages
24,589
Location
Lake District....Moist
mmm, thats a different problem then. I think its still worth doing the drop test with the lights just to rule out a duff battery, it might have enough power to swing the meter but not enough 'welly' to turn the starter motor.

Not turning the starter, and failing to bump start are almost two different problems, so at this late hour I'm a bit befuddled. I'll think about it overnight and see if I can comwe up with any answers.

Cheers

D
 
OP
OP
S

stezgt

New member
Joined
Jan 27, 2006
Messages
7
thanks for your replies,much appreciated!! Ill have another dig round tomorrow in the daylight and try the drop test.


cheers

Steve
 
OP
OP
S

stezgt

New member
Joined
Jan 27, 2006
Messages
7
ive tried a fully charged battery and still nothing is happening,just the clicking relays and the humming sound from the dash:confused:
can anyone help ?
cheers

Steve
 

chaos

Ah. Not good...
Joined
Jan 16, 2005
Messages
10,602
Could it possibly be fuelling related? On my 899,when you turn it over, you can hear the fuel pump whirring/humming. Could this be what you're hearing - which would be totally normal? Possibly a dodgy connection somewhere from the fuel pump to the relay?

TBH it could be a number of things :(
 

Jamieboy

Active member
Joined
Mar 30, 2005
Messages
227
Location
Caithness
chaos said:
On my 899,when you turn it over, you can hear the fuel pump whirring/humming.....

Yeah - I'll second that - on my 899 a 'buzz' when i turn the key to get the ignition lights. It's the fuel pump priming - is it the same as this only constant? Maybe a failing fuel pump relay? the coil inside this is capable of giving a hum or buzz.

I also used to have a Mini that made loud clicks due to a dodgy battery clamp. Same as you - battery reads good voltage, even other, low-drain devices work, but due to the lowered current carrying capacity of the clamp, it wont budge the starter.
 
Last edited:

project-cinqy

New member
Joined
May 15, 2005
Messages
646
Location
Coningsby, Lincolnshire
If the starter and bumping doesn't work but the ecu clicks, is the ecu warning light (little spray symbol on the dash) lighting up? If so then the ecu could be dead. The clicking could be it malfunctioning. Take the plug of the ecu and blow any dust out, and wd40 it to be sure then plug it in.

Also check all the earth connections, as a dodgy earth will seriously limit the amount of power the battery releases!

Jon+Em
 

chaos

Ah. Not good...
Joined
Jan 16, 2005
Messages
10,602
project-cinqy said:
If the starter and bumping doesn't work but the ecu clicks, is the ecu warning light (little spray symbol on the dash) lighting up? If so then the ecu could be dead. The clicking could be it malfunctioning. Take the plug of the ecu and blow any dust out, and wd40 it to be sure then plug it in.

Also check all the earth connections, as a dodgy earth will seriously limit the amount of power the battery releases!

Jon+Em

It says in the first post that the injector light lights up ;)
 
OP
OP
S

stezgt

New member
Joined
Jan 27, 2006
Messages
7
Thanks everybody for replying..the injector light flashes at the same rate as the relays click....
i will try the things youve mentioned tomorrow..
I just don't want my brother to be ripped off by a fiat dealer again,
Thanks again

Steve
 

Liam

hi friends :waves:
Joined
Mar 12, 2003
Messages
14,118
Location
Scotland
Sounds a bit like my Sporting, it threw a hissy fit one friday and refused to start but it was displaying CODE and I had the proper bloody key, after 15mins it started fine nd it never done it again.

Does the 899 have an Immobiliser? I can't remember.

Liam
 

Matthew28

New member
Joined
Jan 25, 2006
Messages
3
My cinq 900, has just died in a similar fashion - it is sitting in the fiat garage at the moment with them scratching their heads.

However!!

Before it dies completely I was able to start the car using the emergency start up in the owners manual (inputing the immobiliser code via the accelerator pedal - see the owners manual) This worked until I found a broken earth lead in the engine, which possibly frazelled something else.

To get the car started with the emergency procedure you need the key code on a credit card hopefully supplied with the red key.

By the way - anyone know if the McCrich works on a 900? This might solve my problem.

Also, does your (or did it ever) 900 ever have the yellow code light light up on the dash board?

Hope this helps - (if you don't have the owners manual, let me know and I'll copy the relevant pages.
 
OP
OP
S

stezgt

New member
Joined
Jan 27, 2006
Messages
7
I think my brothers cinq is pre key code,he only has 2 black keys.
cheers Steve......
 
Top