Technical Brava 100 16V, idle problem

Currently reading:
Technical Brava 100 16V, idle problem


Jan 26, 2019
Lately I have a problem with the engine idle rpm.

It is not something that constantly presents it, but it presents it when it warms up.
Engine rpm goes up and down to 3000 rpm, but even though they are up, the engine does not seem to have the same power.
For example, when I accelerate with the accelerator pedal I have an acceleration and the car develops a certain speed.
If while the engine increased rpm (eg 3000 rpm) I select a gear in the gearbox and release the clutch, without pressing the accelerator, the rpm fall close to idle and I have no power to accelerate or slide the car, just like as if the engine rpm are virtual .
I have removed and cleaned the throttle body but saw no improvement.
The stepper motor that regulates the engine idling moves smoothly without any problems and does not get stuck at any point.

Below I show you in a video the problem
At the points of the video where the rpm go above 3000 are because I press the accelerator pedal.
Last edited:
I will just try to give u some hints because a friend of mine had the same problem.Not in a fiat but anyway.Check angle throttle bank,crank sensor,idle valve
First of all, thank you for your answers

I connected the car with the help of a friend who has the appropriate equipment to my laptop and it showed a crank sensor fault, I delete it and it did not show it again.
I do not know where this sensor is located at this time :)

What is and where is the angle throttle bank? :confused:

Neverth , vacuum leak from where? where is the MAP sensor ? can i check it?

Many, many years ago , when my Brava was young :) the same damage occurred but not in such a big change of rpm, when the car has 1700km, then I had changed the whole throttle body.

I held the old throttle, and turning the key on without starting the engine I connected the stepper motor connector of the old one, and the motor apparently moved normally.
I probably do not know if the movement was correct, but it was the same in both throttle bodies.

Unfortunately in my model Fiat decided to use a throttle that does not replace the stepper motor or the throttle position potentiometer.

As you can see, I do not know many of the cars as an aircraft electronic engineer.

MariosGr, are you from Greece? I live at Eleysina.
MAP is in the back of the plastic intake towards firewall, looking from front above the text on the manifold. I'd try cleaning it first before changing it.

Vacuum leak, intake/rubber parts/brake boost lines? I've had to put self vulcanizing tape after the throttle body on my Marea as the rubber has cracked on the bellow.

Crank sensor is on the crankshaft accessory end, pretty much lowest sensor on the engine, it is going to be seized in the aluminum holder, but the sensor should not cause that kind of issues. Most common on the crank sensor issues are no-start when hot or just generally not starting and then after half an hour it starts without issues.

After cleaning/checks, disconnect battery for half an hour, reconnect, start and let it idle 10min for the ECU to relearn parameters.
One possibility is incorrectly adjusted throttle cable keeping the throttle open or the cable being bad? Have you tried manually closing the throttle from the cable assembly on the throttle body?
For the last three days the engine is working properly again.
Ιτ seems to be trying to drive me crazy.

Anyway I will clean the map sensor
I will check the throttle cable, although the problem exists without the cable being in place.
I will also do a reset by removing the battery.
I will also clean with spray contact as many connections and connectors I can.

But I can not explain why it works normally now, what I know for sure is that it has to do with temperature because it does not show up in the first kilometers but after 20 minutes of use.

If I clean and install my old throttle, will I have to reprogram it to work properly?
Last edited:
After 19th of September the problem was solved on its own.
I do not know why, what was the cause but the engine runs normally most of the time.
It has occurred a few times for short periods of time.
Anyway, I hope that at some point in the future the idle problem will stop appearing or becoming permanent so that I can locate it and it will be solved.
Here we are again ....

The problem came up again, I changed the spark plugs and spark plugs, I saw a slight improvement, but now the engine is shaking like running on three cylinders, it sounds like a motorcycle, it has lost power, and when I press the accelerator it pretends to blink, pressing the accelerator pretends to go out and then accelerates.

I'm thinking of taking out the various sensors one by one and cleaning them and the contacts from their connectors
Last edited:
I finally found the fault, the problem was in the coil and specifically in the No. 1 cylinder.
Although I had removed it and measured it ohmmetrically it looked ok. However, when it was warming up, it stopped the No. 1 cylinder and made sparks from the plastic in the adjacent pipe
I changed it with a NGK ignition coil and everything is ok

You can see the sparks in the video