Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 23-06-2009   #1
Join Date: Jun 2009
Location: Essex
Posts: 358
Thanks: 46
Trader Rating: 0
United Kingdom 
Fault Codes

Hi, got check engine light on, plugged into an OBDII code reader and recieved the following errors.

U1706
P0500 - Vehicle Speed Sensor Malfunction.
U1600
P0115 - Engine Cooling Temperature Sensor, Circuit Malfunction

But I cannot Identify the other 2 faults, going to try swapping those 2 sensors which I have identified to see if this resolves the problem.

Anybody know what the U errors are?

also, bad connection under passenger seat with the airbag system, dont know if that would cause some errors in the can bus network? Suspected bad connection because apparently when the wires are moved around a bit the airbag light goes out.

havent had a chance to have a good look at that yet.

Thanks In advance.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

RB2009 is offline Reply With Quote Quote 
Old 23-06-2009   #2
Join Date: Dec 2006
Location: Southampton, Hampshire
Posts: 3,966
Thanks: 290
Trader Rating: 0
s130 has donated!
United Kingdom 
Re: Fault Codes

U are manufacturer specific. U1600 is a communications error on the immobiliser cicruit. On our Barchetta we occasionaly get this error when the car fails to start, especially when warm and momentarilt stopped and a re-start is attempted.

I've just ignored them and reset them as/when I "plug in".
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

s130 is offline Reply With Quote Quote 
Old 23-06-2009   #3
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Fault Codes

P1xxx are manufacture specific codes.

RB2009 it helps if you tell us the car?
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 28-06-2009   #4
Join Date: Jun 2009
Location: Essex
Posts: 358
Thanks: 46
Trader Rating: 0
United Kingdom 
Re: Fault Codes

Hi, sorry, the car is a 2003 fiat punto sport 1.4.

I have changed the coolant temperature sensor, and the coolant temperature sensor error code has gone now.

also fixed some bad connections under the passenger seat causing the airbag light to appear intermitantly, and repaired the connections behind the passenger airbag disable switch, as when the passenger airbag was switched on, it was triggering the message "airbag fault"
Since I fixed these, the airbag light does not illuminate now, or display airbag fault so im assuming that should be ok now as long as it has not stored any errors.

Error code U1600 has also disappeared.

But I am still recieving error code, U1706 and vehicle speed sensor error.
I have purchased a replacement speed sensor but cannot locate it on the gearbox.. I have located where I think it should be on the differential, but theres like a plug/cap with no electrical connections, then behind it there is a cable hanging down but the plug doesnt fit the new speed sensor. It is the correct speed sensor though as there is only 1 listed for this car.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

RB2009 is offline Reply With Quote Quote 
Old 28-06-2009   #5
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Fault Codes

Airbag light will come back on.

If car has ABS it wont have speed sensor on gearbox.
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 28-06-2009   #6
Join Date: Jun 2009
Location: Essex
Posts: 358
Thanks: 46
Trader Rating: 0
United Kingdom 
Re: Fault Codes

Hi. airbag light hasnt come on yet, its been out for a few days so far... will have to monitor it.. if it does come back on then I guess its a trip to the dealer to reset it, although the cause of the airbag light coming on should now be fixed.

If there is no speed sensor as it is built into the ABS, any idea what is causing the speed sensor fault code? ABS system seems fine, because the ABS light is not illuminating so there cant be any faults with that.

Will have a look at D4 connector in engine bay tomorrow, this might be related to the problems?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

RB2009 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Fault codes, if you know the meaning of any codes please post them here bigdong Scudo 36 13-09-2016 13:22
(G) Fault codes jmac Stilo 12 06-07-2015 20:58
(T) Fault Codes minimad99 Stilo 7 12-11-2010 19:58
(T) fault codes fueltank Stilo 3 05-05-2009 21:15
(T) FAult codes blufin Doblo 2 25-04-2007 09:21