Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 05-07-2015   #1
Join Date: Jun 2009
Posts: 57
Thanks: 2
Trader Rating: 0
Macedonia 
Stilo JTD Issues

Hi everyone
I'm am very very sorry for the long post.
I own a 03 plate 1.9 JTD 8V 5 door stilo (and I love it ) However it has been giving me some issues lately

Problem Nr. 1

I'm so sorry if this is a double post ... i have tried to find an answer by using the Search function and i found a post describing the same problem I have but it was never answered.
Here is the original post:

"I've noticed when i was looking under the clutch pedal that there is a space between the clutch pump rod head (Metal ball) and the plastic element on the back side of the clutch pedal. This Space causes probably a non effective (not 100%) pressing of the master cylinder.
Do you think that it is normal to have such a 1/3 space, non effectively pressing the master cylinder rod ?"
My question is: Are these pumps same for all stilos, or are they different ? How can there be space between the metal rod and the place in the pedal ? Are there rods of different sizes ?
(because I have a spare one that I can replace)
Gears don't crunch, I shift fine , it's just that awkward feeling when I press the pedal, there's empty space then the pedal reaches the rod ???
As I learned, the tip of the rod (the metal ball) should enter the plastic that's located in the pedal, however I don't think I can manage to put the rod in there, it seems too short ?!?!?
Any idea on how to fix this would be much appreciated.

Problem Nr.2

When I bought the stilo the EGR was blocked. As time passed the hot fumes have melted a spot on the blocking plate and I was getting no power at low revs. I took out the old plate and because it was getting dark I decided to make another plate the next day. I started the car to park it in the garage, and the engine was "crazy" without that plate. It was working as a Tractor, and huge white smoke that had a terrible odor was coming out of the tail pipe. I mean there was a huge amount of white smoke because I was reving and trying to move the car, there was no power at all. I then immediately turned the car off, took a steel plate, blanked the EGR and took the car for a drive. It was running fine with the blocked EGR.
My question: What was that smoke ?!?
I'm an amateur when it comes to cars but I searched the net and I found out that maybe?!?! IMHO there is a leak of coolant from the EGR cooling mechanism of some sort ? Could that be it ? Can I fix that ?

Problem Nr.3
The MAF sensor I think is out. I disconnected then connected the plug again on the MAF, there is no difference on the way the car drives, with the MAF connected or disconnected. I took out the MAF and it was a bit oily. I will get a CRC MAF Cleaner and try to clean it. Probably I will have to buy a new one.

Problem Nr.4
Whenever the turbo starts to spin, if I have my window down, I can hear it. like a hissing sound of some sort, not loud, but I can hear it. Is that normal ?

Problem Nr.5
When I connect Ecu reader or whatever they are called, it cannot establish a connection at all with the Ecu of my car ?!?

All in all, the car hasn't got enough power as it supposed to and a high consumption. I think all of these problems are contributing to that.
Any help would be very much appreciated ...
I am truly sorry if you have read all this much ..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by stilo123; 05-07-2015 at 23:28.
stilo123 is offline Reply With Quote Quote 
Old 10-07-2015   #2
Join Date: Jun 2009
Posts: 57
Thanks: 2
Trader Rating: 0
Macedonia 
Re: Stilo JTD Issues

Anyone ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stilo123 is offline Reply With Quote Quote 
Old 14-07-2015   #3
Join Date: Jun 2009
Posts: 57
Thanks: 2
Trader Rating: 0
Macedonia 
Re: Stilo JTD Issues

UPDATE
1. I have changed the air filter and fuel filter. The air filter was very dirty. It made a positive change on the way the car drives.
2. The alternator clutch pulley was rotating in both directions.. that needed changing also. I managed to change the pulley without taking the alternator out.

I will post updates as I fix things ... "maybe my troubles would be of benefit to someone in need".

Now I think I have a problem with the Dual Mass Flywheel ... will see how that goes ...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by stilo123; 14-07-2015 at 22:31.
stilo123 is offline Reply With Quote Quote 
Old 15-07-2015   #4
Join Date: Jun 2009
Posts: 57
Thanks: 2
Trader Rating: 0
Macedonia 
Re: Stilo JTD Issues

Here's the update for the DMF problem I think I have ...

https://www.fiatforum.com/stilo/4269...g-car-off.html
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stilo123 is offline Reply With Quote Quote 
Old 15-07-2015   #5
Join Date: Jun 2009
Posts: 57
Thanks: 2
Trader Rating: 0
Macedonia 
Re: Stilo JTD Issues

UPDATE to Problem nr.1 with the master cylinder pump.
I have replaced the master cylinder pump, behind the clutch pedal. The problem is the same. I have managed to put the the head of the metal rod (the ball) inside the white plastic in the clutch pedal, but the upper 1/3 of the way down is still like "empty" , no resistance at all. When the pedal reaches somewhere in the middle then the clutch engages. I've bleed the air out, still the same. I'm guessing there something wrong with the clutch.
I will update.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stilo123 is offline Reply With Quote Quote 
Old 15-07-2015   #6
Join Date: Jun 2009
Posts: 57
Thanks: 2
Trader Rating: 0
Macedonia 
Re: Stilo JTD Issues

I love my Stilo but it's one hell of a love

I had the famous Airbag problem light on turn off engine. Checked under seats, they were soldered. Checked in the trunk behind the tail lights, they were ok. I've cut the connectors and soldered them together ... Airbag failure is still there. I'll check the one in the lower glove box ...solder that too... if that doesn't solve the problem ...I'll keep looking for those "lovely" orange connectors ..."and I'll take them down one by one, until there's none left standing".
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stilo123 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Stilo JTD Technical issues Marney08 Stilo 3 15-04-2015 14:20
(G) Stilo JTD issues willow1 Stilo 13 03-06-2013 20:02
(T) Stilo 54 1.9 JTD Multi Starting issues seagull83 Stilo 1 30-04-2013 20:43
(T) Stilo JTD cooling issues fifeplumber57 Stilo 42 18-01-2011 01:00
(G) Stilo as next car? JTD issues? Fast Finger Stilo 3 25-08-2005 18:02