Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 08-03-2012   #1
Join Date: Mar 2012
Posts: 1
Thanks: 0
Trader Rating: 0
Denmark 
Exclamation -HELP- Stilo 1.9 JTD 115 HP -HELP!-

Hey fellow Fiat drivers.

I have a few probloms with my Stilo 1.9 JTD

One week ago driving on cruse control (70 MPH)
The "ENGINE FAULT" and "PREHEAT FAULT" came on.
And the car lost alot of performance. (would say about 60 HP)


Fault Codes.
P0404 - P0236 - P0638 - P0101

Everything i fixed, except P0101.

When i did a new read at the dealer the same faults show.

Any ideas,?

PS:
When i was working on the car. i disconected the battery.
When i conected it again the instrument was not turning on.
nothing works. only the airbag light.

WHAT?

Pleas help...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bwiwy is offline Reply With Quote Quote 
Old 08-03-2012   #2
Join Date: Sep 2008
Location: Wolverhampton
Posts: 6,091
Thanks: 289
Trader Rating: 7
Shadeyman has donated!
United Kingdom 
Re: -HELP- Stilo 1.9 JTD 115 HP -HELP!-

Welcome to the forum.

A low or faulty battery can cause a lot of strange errors, make sure the battery is fully charged.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Shadeyman is offline Reply With Quote Quote 
Old 08-03-2012   #3
Join Date: Nov 2006
Location: Coventry
Posts: 2,773
Thanks: 133
Trader Rating: 0
United Kingdom 
Re: -HELP- Stilo 1.9 JTD 115 HP -HELP!-

P0101 Mass or Volume Air Flow Circuit Range/Performance Problem
that ol' chestnut

unplug it go for a drive
__________________
Rich
'02 Stilo, 1.6, Dynamic, Black, 3 door, Full Leather, -30mm Apex Springs w/ Monroe Reflex Shocks.
'99 Coupe, 2.0 20v VIS, Portofino Blue, 2 door, Full Leather, Mani-Back Longlife Custom S/S Exhaust.
richydraper is offline Reply With Quote Quote 
Old 04-12-2017   #4
Join Date: Jun 2017
Posts: 1
Thanks: 0
Trader Rating: 0
Portugal 
Re: -HELP- Stilo 1.9 JTD 115 HP -HELP!-

Quote Originally Posted by Bwiwy View Post
Hey fellow Fiat drivers.

I have a few probloms with my Stilo 1.9 JTD

One week ago driving on cruse control (70 MPH)
The "ENGINE FAULT" and "PREHEAT FAULT" came on.
And the car lost alot of performance. (would say about 60 HP)


Fault Codes.
P0404 - P0236 - P0638 - P0101

Everything i fixed, except P0101.

When i did a new read at the dealer the same faults show.

Any ideas,?

PS:
When i was working on the car. i disconected the battery.
When i conected it again the instrument was not turning on.
nothing works. only the airbag light.

WHAT?

Pleas help...
How do you fix the other error codes (P0404 - P0236 - P0638)?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

malapeiro is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Stilo 1.9 JTD 115 Crossy20 Stilo 30 09-11-2009 10:01
(G) Stilo jtd 115 decat???? Stilo170 Stilo 15 14-04-2008 17:04