Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 06-10-2010   #1
Join Date: Oct 2010
Location: Belfast
Posts: 13
Thanks: 0
Trader Rating: 0
Ireland 
Exclamation Multifunction Display Question

Just got an 04 Stilo 5dr 1.2 Active. The Multifuctional display only shows the time, temp and total mileage.
The display has a black strip along the top of it which going by the manual is where the fuctions list and date are meant to be displayed, Is this normal?

Also the mode button sort of works but the two arrow buttons dont, any ideas?

Also the trip button isn't working which i suspect is linked to the other issue mentioned.

Many thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PolHam is offline Reply With Quote Quote 
Old 08-10-2010   #2
Join Date: Oct 2010
Location: Belfast
Posts: 13
Thanks: 0
Trader Rating: 0
Ireland 
Re: Multifunction Display Question

Having suspected something wasn't 100% i used some info posted on the forum to take out the display and found that someone had placed black tape over the menu info on the display to hide an airbag failure warning however there is no airbag light accompanying it. Is the warning message without the light normal?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PolHam is offline Reply With Quote Quote 
Old 08-10-2010   #3
Join Date: Sep 2008
Location: Wolverhampton
Posts: 6,091
Thanks: 289
Trader Rating: 7
Shadeyman has donated!
United Kingdom 
Re: Multifunction Display Question

Quote Originally Posted by PolHam View Post
Having suspected something wasn't 100% i used some info posted on the forum to take out the display and found that someone had placed black tape over the menu info on the display to hide an airbag failure warning however there is no airbag light accompanying it. Is the warning message without the light normal?
My guess is they took the bulb out. If they took time to cover the display they probabely took the time to remove the bulb from the warning light.
Thanks PolHam thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Shadeyman is offline Reply With Quote Quote 
Old 08-10-2010   #4
Light Seeker
 
vladof's Avatar
Join Date: Jul 2008
Location: Bucharest
Posts: 873
Thanks: 66
Trader Rating: 0
vladof has donated!
Romania 
Re: Multifunction Display Question

What some people would do... incredible.

Do you still hear 3 beeps when you start the engine or has the buzzer been taken out too?
__________________

______________________________________________

Stilo 1.8 Dynamic, 5 door, 2002, Navy Blue
Stilo 1.8 Dynamic, 5 door, 2002, Nero Moire VR
vladof is offline Reply With Quote Quote 
Old 08-10-2010   #5
Join Date: Sep 2008
Posts: 2,180
Thanks: 131
Trader Rating: 0
mzhussein has donated!
United Kingdom 
Re: Multifunction Display Question

what a prick.....thats just not safe :/

whip out the cluster and examine it.

when you press the mode etc butons do you get any beeps..??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mzhussein is offline Reply With Quote Quote 
Old 08-10-2010   #6
Join Date: Oct 2010
Location: Belfast
Posts: 13
Thanks: 0
Trader Rating: 0
Ireland 
Post Re: Multifunction Display Question

Quote Originally Posted by vladof View Post
What some people would do... incredible.

Do you still hear 3 beeps when you start the engine or has the buzzer been taken out too?
Still hear the 3 beeps so the buzzer is still there I know that. It wasn't until I reconnected everything that I remembered about the bulb possibly being missing.

Is the airbag failure a common problem on the stilo and if so is it costly to get repaired?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PolHam is offline Reply With Quote Quote 
Old 08-10-2010   #7
Join Date: Sep 2008
Posts: 2,180
Thanks: 131
Trader Rating: 0
mzhussein has donated!
United Kingdom 
Re: Multifunction Display Question

its reasonably common, and usually quite easy to fix, usually attributed ot dirty connections, but could also be an OCS mat....a quick search will provide a good overview.
Thanks PolHam thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mzhussein is offline Reply With Quote Quote 
Old 09-10-2010   #8
Whataboutye?
 
Minus8's Avatar
Join Date: Oct 2010
Location: Belfast
Posts: 429
Thanks: 28
Trader Rating: 0
Minus8 has donated!
United Kingdom 
Re: Multifunction Display Question

Noticed your from my neck of the woods, where did you buy the car from out of curiosity? Wouldn't happened to have been Jack Reids would it ? Noticed they had a 5 door Stilo recently and it sounds like something they would do
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Minus8 is offline Reply With Quote Quote 
Old 09-10-2010   #9
Join Date: Oct 2010
Location: Belfast
Posts: 13
Thanks: 0
Trader Rating: 0
Ireland 
Angry Re: Multifunction Display Question

Quote Originally Posted by Minus8 View Post
Noticed your from my neck of the woods, where did you buy the car from out of curiosity? Wouldn't happened to have been Jack Reids would it ? Noticed they had a 5 door Stilo recently and it sounds like something they would do
I bought it off a private seller in belfast who obviously thought I wouldn't investigate the beeps and the tape. Going to try and see if it's the connectors under the seat as a starting point but this is my first car and I have to say I am no longer surprised by the lengths some people will go to, to hide something like that instead of being upfront and honest.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PolHam is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Multifunction display!!! Stilo owl Stilo 0 16-11-2009 23:22
(T) Multifunction display died lyubohar Bravo 4 04-04-2009 09:50
(G) Multifunction Display Anthony Renshaw Panda 7 09-10-2008 01:12
(G) flashing multifunction display cotasoc Panda 9 15-04-2007 12:52
(T) Blank Multifunction display!!! flat-top Stilo 6 16-07-2006 00:52