Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 01-11-2009   #1
Join Date: Oct 2009
Location: Derby
Posts: 27
Thanks: 1
Trader Rating: 0
United Kingdom 
Exclamation Random Warnings then engine dies

Hi There

I have recently brought a 2002 Stilo Abarth. It was filthy when i got it from the garage so thought i would give it a clean. So spent the day cleaning it. Now when i come to start the car i get a load of random warnings on the dash like ABS, ASR, Immobiliser, Engine Control Unit, then the engine cuts out. If it manages to stay running it drives absolutely fine but the engine management light stays on. Any ideas as to what the problem could be???

Cheers

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jamesderby is offline Reply With Quote Quote 
Old 01-11-2009   #2
Join Date: Jul 2005
Location: London
Posts: 953
Thanks: 77
Trader Rating: 0
12[X] has donated!
United Kingdom 
Re: Random Warnings then engine dies

water...in the battery fuse box... is likelly
Thanks jamesderby thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

12[X] is offline Reply With Quote Quote 
Old 01-11-2009   #3
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Random Warnings then engine dies

You cleaned the engine bay or the passenger side wheel arch with a power washer maybe?
Thanks jamesderby thanked for this post
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 01-11-2009 at 18:28.
Deckchair5 is offline Reply With Quote Quote 
Old 01-11-2009   #4
Join Date: Oct 2009
Location: Derby
Posts: 27
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Random Warnings then engine dies

Well looks like i'll be spending a few hours drying and greasing when i get back from my hols...

...water in there would make sense as the battery/fusebox cover is missing!!

Cheers Guys
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jamesderby is offline Reply With Quote Quote 
Old 01-11-2009   #5
Join Date: Mar 2008
Location: Outtta Space
Posts: 757
Thanks: 66
Trader Rating: 2
danhans115 has donated!
Andorra 
Re: Random Warnings then engine dies

My battery/fusebox cover is beyond repair and I have had the same thing, after using a jetwash. There will be two multiway connectors under the fuse box so make sure they are dry (I had this with mine, the connector is called D4). Did them with a hairdryer. Its quite easy for water to kick up from the wheelarch into this area.

Also, it might be worth disconnecting both plugs from the ecu and plugging them back in firmly.
Thanks jamesderby thanked for this post
__________________
If it aint broke, break it and fix it anyway

Former Abarth Owner
danhans115 is offline Reply With Quote Quote 
Old 12-11-2009   #6
Join Date: Oct 2009
Location: Derby
Posts: 27
Thanks: 1
Trader Rating: 0
United Kingdom 
Smile Got my car back :) but still got one tiny problem

Hi,

Got the car back from the garage today and is now fixed. No more warning lights. Apparently it was a faulty ignition switch causing all the probs.

I only have 3 little issues with it now...

1. When i turn off the car and take the key out there is a 2tone bleeping noise. Is this anything to worry about?

2. The indicators do not flash when the car is locked and the little red light only flashes if i press the lock button twice.

3. the boot light does not work. Checked the bulb and thats ok. The power socket still works tho.

Any help would be appreciated. Hopefully i will be able to enjoy the car now. It was in the garage the day after i brought it!!

Cheers

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jamesderby is offline Reply With Quote Quote 
Old 12-11-2009   #7
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Got my car back :) but still got one tiny problem

What was wrong with it? Nice to know the solution but handy to know what all the probs were

To have hazards flash with locking needs dealer setting. Do a search for plenty of info

Boot light not working can be a few l things but check for power at the bulb socket and if there is none then it can be the boot open switch (integral with the boot lock) or often it's the diode in the wiring loom near the boot light that has given up
Thanks jamesderby thanked for this post
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX
Deckchair5 is offline Reply With Quote Quote 
Old 12-11-2009   #8
Join Date: Jun 2004
Location: Ooop North
Posts: 4,782
Thanks: 57
Trader Rating: 0
United Kingdom 
Re: Got my car back :) but still got one tiny problem

all stilos mad a noise and a clicking about 5 seconds after turning off
Thanks jamesderby thanked for this post
__________________
2008 Fiat Bravo T-Jet 150 Sport
2014 Fiat 500 S


Fabbrica Italiana Automobili Torino
Big Black Stilo is offline Reply With Quote Quote 
Old 12-11-2009   #9
NobodyBlamesTheHappyGuy!
 
Morty Mort's Avatar
Join Date: Jun 2003
Location: 69 North
Posts: 2,831
Thanks: 133
Trader Rating: 2
Morty Mort has donated!
Norway 
Re: Got my car back :) but still got one tiny problem

Quote Originally Posted by jamesderby View Post
3. the boot light does not work. Checked the bulb and thats ok. The power socket still works tho.
The fault is most likely within the lock mechanism itself. Don't worry about it, the light will never return.

Fastest fix is a new lock. I have a little flashlight in the boot for this purpose.
Thanks jamesderby thanked for this post
__________________
jet blue. eibach pro system. omp bar. gsr in. supersprint out. hella eyes. phoenix gold watts.

member of the 5-door massive attack.
Morty Mort is offline Reply With Quote Quote 
Old 12-11-2009   #10
Join Date: Oct 2009
Location: Derby
Posts: 27
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Got my car back :) but still got one tiny problem

Quote Originally Posted by Deckchair5 View Post
What was wrong with it? Nice to know the solution but handy to know what all the probs were

To have hazards flash with locking needs dealer setting. Do a search for plenty of info

Boot light not working can be a few l things but check for power at the bulb socket and if there is none then it can be the boot open switch (integral with the boot lock) or often it's the diode in the wiring loom near the boot light that has given up
This was my original post with the details of the problem. As said was originally thought to be water but looks like it was just a coincidense. Hopefully!!

https://www.fiatforum.com/stilo/2148...gine-dies.html

Thanks for the help guys.

Was looking forward to buying some new wheels for it now they'll have to wait until next month

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by jamesderby; 12-11-2009 at 21:16. Reason: forgot link
jamesderby is offline Reply With Quote Quote 
Old 13-11-2009   #11
It's about GO! not SHOW!
 
Argonought's Avatar
Join Date: Sep 2005
Location: POOLE, Dorset
Posts: 7,335
Thanks: 340
Blog Entries: 1
Trader Rating: 0
Argonought has donated!
United Kingdom 
Re: Random Warnings then engine dies

Always continue threads if about the same topic.

Have now merged for you.
Thanks jamesderby thanked for this post
__________________
------------------------------------------------------
Stilo Dynamic 5 door JTD {150} 02 model in Metallic Grigio Steel with Skyroof & 16" Alloys Mods: New standard springs all round; Tyres: FALKEN ZIEX ZE912; Oil: Mobil 1 TD 0W-40 fully synthetic
Argonought is offline Reply With Quote Quote 
Old 30-11-2009   #12
Join Date: Oct 2009
Location: Derby
Posts: 27
Thanks: 1
Trader Rating: 0
United Kingdom 
Question Help! Again :$

Hi All,

I really am beginning to think i've brought a lemon. After having the ignition switch replaced and a new exhaust, i was greeted by my 02 Abarth running on 4 cylinders and missfiring this morning. Took it on a 200 mile trip yesterday was absolutely fine. Started it this morning and was as rough as anything. No warning at all.

Am i right in assuming this could well be a coil pack issue?? the engine management light comes on but goes straight off again then back on and so on.

Not bad for saying i've only had the car a month . If it is the coil pack how easy are they to get hold of? Are they the same fpr all petrol engines (even the 5pot).

Cheers Guys

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jamesderby is offline Reply With Quote Quote 
Old 30-11-2009   #13
Join Date: Mar 2008
Location: Outtta Space
Posts: 757
Thanks: 66
Trader Rating: 2
danhans115 has donated!
Andorra 
Re: Help! Again :$

Do you have access to a code reader? Read the ECU if you can

Might be worth checking the spark plugs before plumping for a coil. The ECU should log an intermittent misfire etc.

Dan
Thanks jamesderby thanked for this post
__________________
If it aint broke, break it and fix it anyway

Former Abarth Owner
danhans115 is offline Reply With Quote Quote 
Old 30-11-2009   #14
Join Date: Oct 2009
Location: Derby
Posts: 27
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Help! Again :$

Thanks for that Dan,

Havent got a code reader but might have to invest in one as this seems to be a regular thing

Thnks

James
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jamesderby is offline Reply With Quote Quote 
Old 30-11-2009   #15
Join Date: Mar 2008
Location: Outtta Space
Posts: 757
Thanks: 66
Trader Rating: 2
danhans115 has donated!
Andorra 
Re: Random Warnings then engine dies

If youve got a laptop an ELM interface is a good buy, saves a lot of headaches. If you get one make sure its 1.3a version, or 1.3 at least.

No laptop? something like a uiftech u581 off ebay are quite good.

http://cgi.ebay.co.uk/Car-Code-Reader-Scanner-OBD2-EOBD-CAN-U581-2010-DTC_W0QQitemZ110463152818QQcmdZViewItemQQptZUK_Dia gnostic_Tools_Equipment?hash=item19b81df2b2

or if you do have one

http://cgi.ebay.co.uk/ELM-327-CAR-DIAGNOSTIC-CODE-READER-SCANNER-OBD2-TOOL_W0QQitemZ300371758218QQcmdZViewItemQQptZUK_Di agnostic_Tools_Equipment?hash=item45ef8d4c8a

I have a few different cables for different things. Spend about 60/70 in total. Wouldnt like to say how much money they have saved me in garage visits.

Dan
__________________
If it aint broke, break it and fix it anyway

Former Abarth Owner
danhans115 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Engine always dies, when i want to stop!!! admiral00 Uno 6 03-05-2009 03:32
(T) fiat dies at random popesutek 124 Spider (Classic) 4 13-12-2008 23:23
(G) Engine dies on hills Boyblue Ulysse 8 30-07-2007 23:35
(T) Engine Dies NZUNO Uno 2 19-07-2006 20:29
(T) Engine dies after 20 minutes starbuster Uno 8 28-07-2005 12:07