Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 11-03-2013   #1
Join Date: Mar 2013
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Unhappy Engine Management Limp Home!

Hi All, I hope someone can help with a diagnosis; all info greatly received!

Qubo 1.3 Multijet - 3 Years old 67k Miles.

Symptoms:

At 2.5 -3k RPM in any gear, asking for acceleration engine management light comes on and limp home mode activated. Stop the car and restart results in normal performance regained until it's asked to accelerate above the RPM level above. Engine Management light goes out if the iginition is cycled 4 times to clear the fault.

My action so far without success :

Had the car error codes read: reporting Turbo / Supercharger, not very helpful. Took off the MAP sensor and cleaned, read the output voltage and all looks OK from what I can tell. EGR Value removed and sure enough needed to be freed and cleaned, not sure if it's working though. Although I can hear the turbo 'whistling' (does this mean EGR OK?) and acceleration is good right up to the point of limp mode being activated, I've no idea what to turn to next, all input welcome...... Car starts well, runs well up to this magic 2.5-3k RPM!

Other things I've heard that could cause the problem but I've no idea if there is any value in these include:

1. Fuel filter needs replacing (It is due to be done but bloody expensive).
2. Catalytic converter is showing signs of blockage, would either of these suggestions give the symptoms I'm seeing?

Other things worth knowing:

Petrol was put into the tank a few months ago, about 6 litres, immediately diluted with a full tank of diesel, 45 litres therefore approximately 39 litres of diesel; the car ran fine, petrol diluted out with more fresh diesel over a weeks running and all seemed fine. The problem above wasn't seen for some 2 months after this event but I thought I'd better mention it in case it is relevant.

Thanks.
Likes philnicandamy, Qube O liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

QuboOwner is offline Reply With Quote Quote 
Old 11-03-2013   #2
My Fiorino's a Qubo..
 
Red Van Man's Avatar
Join Date: Feb 2013
Location: Yorkshire
Posts: 507
Thanks: 29
Blog Entries: 2
Trader Rating: 0
Red Van Man has donated!
United Kingdom 
Re: Engine Management Limp Home!

Quote Originally Posted by QuboOwner View Post
Hi All, I hope someone can help with a diagnosis; all info greatly received!

Qubo 1.3 Multijet - 3 Years old 67k Miles.

Other things I've heard that could cause the problem but I've no idea if there is any value in these include:

1. Fuel filter needs replacing (It is due to be done but bloody expensive).

Thanks.
Is the fuel filter an exchange on a mileage basis service item?

I read somewhere on a forum that the chances of needing to change it was next to unlikely for it being clogged up with anything - I can't remember if this was an in-tank filter they were discussing which, if it's the case that there's a filter in the tank would suggest that a filter on the engine is filtering filtered fuel?!!

Have a look here - nice price?

Sorry it's not very helpful to your problem but it might remove one angle for checking. I was just reading up on the Qubo semi-auto box driving method earlier and to say it looks complex is an understatement. One may have to take an exam....

R-V-M
Likes philnicandamy, Qube O liked this post
__________________
2017 Qubo Hillbilly Azure 1.3 MJ 80PS Dualogic
Red Van Man is offline Reply With Quote Quote 
Old 11-03-2013   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 20,588
Thanks: 731
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Engine Management Limp Home!

I would be tempted to post this in the Panda section AND other sections with MUCH more traffic in the 1.3 multijet issues,

none of your issues sound unique,
Charlie
Likes philnicandamy, Qube O liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) 04 Stilo keeps going into limp home mode P0220 olly0404 Stilo 29 21-05-2016 00:00
(T) Engine management lamp on on running in 'limp home' mode Cote DAzur Croma 14 11-08-2012 16:54
(T) Limp home! gbattye Multipla 4 01-02-2011 00:03
(G) limp home mode sporting chap Punto (Mk2/2b) 2 15-02-2010 10:40
(T) Limp home mode gtturbs Punto (Mk2/2b) 1 11-11-2008 20:11