Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 29-03-2010   #1
Join Date: Apr 2008
Posts: 119
Thanks: 1
Trader Rating: 0
United Kingdom 
Starter motor problem?

Have had a problem for a while. In the mornings, starter motor has been turning over VERY slowly but car does just about start. Also, makes a noise (like when you turn the ignition when the engine is already running).

Anyway, once started its ok then for the rest of the day. So I assumed it was the batttery.

Yesterday though it wouldnt start about 10 mins after I'd just driven 30 miles. Checked the battery voltage and it was 12.75 (which is fine, yeh?)

Did eventually start. Checked this morning and battery was 12.6 (this is ok, yeh?). Still the same - started just about.

Does this sound like a starter motor problem?

How much for starter motor? Easy to fit myself?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

psychocandy is offline Reply With Quote Quote 
Old 29-03-2010   #2
Moderator
 
Davren's Avatar
Join Date: Jul 2008
Location: London, UK.
Posts: 13,675
Thanks: 1459
Trader Rating: 5
Davren has donated!
United Kingdom 
Re: Starter motor problem?

Check for poor connection of the battery to engine earth lead.

There's a guide how to do it in the Stilo Guides section but the principle is the same for the Punto and all cars.

https://www.fiatforum.com/stilo-guid...ery-earth.html
__________________
Stilo Parts For Sale: Connect Nav+ Map Discs - Wiper Motor (NEW) - JTD/JTDM Front Brake Discs (NEW)

For details, click here: http://www.fiatforum.com/classifieds...0&ppuser=48514
Davren is offline Reply With Quote Quote 
Old 30-03-2010   #3
Join Date: Apr 2008
Posts: 119
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Starter motor problem?

Quote Originally Posted by Davren View Post
Check for poor connection of the battery to engine earth lead.

There's a guide how to do it in the Stilo Guides section but the principle is the same for the Punto and all cars.

https://www.fiatforum.com/stilo-guid...ery-earth.html
Thanks. I'll try that. Battery is at 12.6v so its ok. Also checked when running and its 14v+ so thats ok too.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

psychocandy is offline Reply With Quote Quote 
Old 30-03-2010   #4
Join Date: Aug 2006
Posts: 3,213
Thanks: 267
Trader Rating: 0
MikeSalt has donated!
United Kingdom 
Re: Starter motor problem?

Check the battery voltage under load. With the engine turned off, turn on every single electrical item you can think of, and then measure the voltage. If it is significantly lower, then the battery has had it. I have a feeling that 12.6v on and unloaded battery is pretty low anyway, should be more like 13.0v for a healthy battery.

The good news is that you charging system seems to be working just fine with a running voltage of 14v.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

MikeSalt is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Starter motor problem solo3583 Idea 19 23-06-2013 23:20
(T) starter motor problem? Frosty 44 Multipla 6 01-11-2009 18:36
(G) starter motor problem pinkdolphin113 Punto (Mk2/2b) 5 02-04-2009 00:41
(T) Starter motor problem sutton Punto (Mk2/2b) 3 14-12-2008 13:10
(T) Starter motor problem shaun Punto (Mk2/2b) 7 09-03-2008 03:56