Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools Search this Thread
Old 4 Days Ago   #1
Join Date: May 2020
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Working on CO_VP2

Hello Fiat lovers,
Firstly thanks for allowing me to register.


Not 100% sure where to post this so the Mods can move or remove this as required.


I have been asked to look at a Fiat250 VP2 DAB NAV head unit.
Seems stuck on a Peugeot Splash screen and does little else.
It has come from a Fiat, but not 100% sure what model.

I have had a good read around and seen some firmware files and other info but not found any info on fixing this type of issue.

I have had a probe around and found a couple of debug outputs.
One for SPI bus and another more general but not tried to talk back to the radio yet. See attached files for Radio boots.

So I am wondering if there is any info on a console connection out there.
Or perhaps someone has some other tips to shake some life into this radio.
Perhaps even a NAND dump so I can try and reflash that way if it comes to it.


I have made a USB cable and tried to connect a thumb drive with flash files but nothing prompted on the display and it would seem that the power out of the socket is not active at this point, it could be my wiring or just that the radio has not got to that stage of booting yet, who knows such things.!


Obviously I do not have the vehicle with me so hard to check things in its native environment but I figure it should come on enough if only to tell me I need a code or something. I do have access to the car but it is miles away so not an easy option at this stage.


I will continue to probe around and see what I can discover.


So just some basic questions.
Can the radio normally be powered on the bench?
Does anyone know the correct pinouts of the USB socket?
Is the radio stuck on the boot logo a recognised and fixable issue?


Attached is two files of a single boot until the radio turned off.
Attached Files
File Type: pdf RadioBoot.pdf (1.49 MB, 1 views)
File Type: pdf RadioBoot_SPI.pdf (422.5 KB, 0 views)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Hiddenvision is offline Reply With Quote Quote 
Old 4 Days Ago   #2
No strings on me
 
Eklipze3k's Avatar
Join Date: Nov 2007
Location: Huddersfield
Posts: 15,063
Thanks: 670
Trader Rating: 0
Eklipze3k has donated!
United Kingdom 
Re: Working on CO_VP2

Welcome to the forum

It would help to know what vehicle it came from, but if I had to guess (given the PSA connection) it's likely to be a Ducato/Boxer/Relay.
Depending on what generation, it may need a CANBUS connection to fully boot, so perhaps that's where the issue lies? I'm not an in-car entertainment specialist by any stretch, just basing this off of what I've read on here over the last 12 years
Likes Hiddenvision, varesecrazy liked this post
__________________
Eklipze3k is offline Reply With Quote Quote 
Old 4 Days Ago   #3
Join Date: May 2020
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Working on CO_VP2

Hey Ek,
You are right it was a 66 plate Boxer.
I just noticed the reg number written on the lid so looked it up.


Well I could simulate the can bus, but I think it never worked in the van either so not sure it is that, unless the bus in the van has gone wonky too.


As normal I never get the full story from customers but I think it may need a visit to the vehicle so I can get a clearer picture I guess.


I did a repair on an older continental unit from a VW a while back and that powered up fine and I was able to update and control the unit without a car but times may have changed.

Someone on the forum must have worked on one of these on the bench, No?


Cheers for the reply either way, it gives another angle to look for.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Hiddenvision is offline Reply With Quote Quote 
Old 4 Days Ago   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 22,999
Thanks: 810
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Working on CO_VP2

@rolopolo seems to feature in some basic search attempts by me.

Not sure if they can help with your problem though..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 4 Days Ago   #5
Join Date: Feb 2004
Location: Faringdon, Oxfordshire UK
Posts: 6,648
Thanks: 523
Trader Rating: 1
portland_bill has donated!
United Kingdom 
Re: Working on CO_VP2

Even though the Ducato is one of a joint venture with PSA, I would still expect a Fiat radio to show a Fiat intro screen.

Here's a thought.
It came from a Peugeot. But why for sale? Original vehicle written off, or unit broken, but for sale anyway.
Fiat owner bought it as an upgrade, for either the DAB or the Nav. Being Peugeot originated, it might not accept the Fiat canbus, even with the correct code.

As you say, owner will not tell full story, but still expect you to fix. I would have expected it to fire up on the bench though, so I'm still guessing it is broken, before this owner bought it.
Likes varesecrazy liked this post
__________________
13 years motor trade, 16 years motor industry. 16 years Driving Instructor & 9 years Fleet Trainer
Panda Alessi (2015 Skoda Fabia)
portland_bill is offline Reply With Quote Quote 
Old 3 Days Ago   #6
Join Date: May 2020
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Working on CO_VP2

Hi Bill,
No the radio is original fit, not used or 2nd hand.
I suspect that one of the mechanics has tried to do an update with incorrect information and screwed it, but that is just a guess. Normally things are faulty as a result of jet washing or other madness but no water in this unit, but that does not rule out other things IN the vehicle having gotten a soaking. Although they do not do it as often as they used to.

It is an annoying unit when in bits so it is all back together now and I shall take a trip to try it in the vehicle and see what happens.

At the same time I can do a bit of snooping on the can bus and capture some of the messages so I can, if required, try and fool it a little if it gets back on the bench. I can also check the USB wiring and see if I have the data pair reversed. Doubt I will ever see another unit but nice to discover things just in case.

Is there anyone in North London with the right software to plug in and do anything while the radio is in the vehicle?

Hv.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Hiddenvision is offline Reply With Quote Quote 
Old 3 Days Ago   #7
Join Date: Apr 2011
Location: Near the M4
Posts: 22,999
Thanks: 810
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Hiddenvision View Post
Hi Bill,
No the radio is original fit, not used or 2nd hand.
I suspect that one of the mechanics has tried to do an update with incorrect information and screwed it, but that is just a guess.
Is there anyone in North London with the right software to plug in and do anything while the radio is in the vehicle?
Hv.

Do you mean to reboot the CANBUS

or the units ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 3 Days Ago   #8
Join Date: Oct 2017
Location: West Yorkshire
Posts: 2,304
Thanks: 107
Trader Rating: 0
chris3234 has donated!
United Kingdom 
Re: Working on CO_VP2

https://www.fiatforum.com/500l/45599...ml#post4532246

https://forum.clubalfa.it/threads/uc....113860/page-3



Theres people talking about software update for the units on here
Perhaps ask if they know about any sort of recovery system for the units
Likes Hiddenvision liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

chris3234 is offline Reply With Quote Quote 
Old 2 Days Ago   #9
Join Date: May 2020
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Working on CO_VP2

Quote Originally Posted by varesecrazy View Post
Do you mean to reboot the CANBUS

or the units ?


Hi Varesecrazy,
Well I guess either.
I have loads of OBD software but never anything for Italian makes.


However I now understand that it is not a Fiat Boxer but a Peugeot Boxer.
Shows how much I need to understand what I am working on.
So the Boot logo is correct I guess given the make of the car.

On discussing with the customer I find the van is quite new for them and they do not know if the unit was ever working so accurate history is hard to find. They buy and sell vehicles so do not always check everything. I still suspect that it was a firmware update fail so perhaps when it is back in the vehicle I can just try and insert USB stick and see what happens.

Hv.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Hiddenvision is offline Reply With Quote Quote 
Old 2 Days Ago   #10
Join Date: May 2020
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Working on CO_VP2

Hi Chris,
Cheers for those links,
Thank (insert religious idol) for google translate.

But I read all of the 734 posts (74 pages) and did not find anyone with the same issue. But did see one that said the radio recovered from blank screen just by having the update stick in the slot.

So I guess I need to find out exactly where the Van is and take a trip to view it in person. Don't like doing mobile work as I always forget to take something but seems like it is the last option on the list.




Hv.


Quote Originally Posted by chris3234 View Post
https://www.fiatforum.com/500l/45599...ml#post4532246

https://forum.clubalfa.it/threads/uc....113860/page-3



Theres people talking about software update for the units on here
Perhaps ask if they know about any sort of recovery system for the units
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Hiddenvision is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for working options to get AUX working with my OEM blue&me donioli Blue and Me 1 04-04-2018 16:19
(T) Air conditioning isnt working, lights on dashboard are not working either... summer2013 Grande Punto 22 19-06-2017 16:24
(T) Wipers stopped working, Clicking fuse? & temp gage and rev counter not working? JordanJ Grande Punto 1 12-02-2011 08:25
Citroen Relay - Oil Pressure Light not working! + Fans not working! aroughcircle Non-FIAT 0 05-08-2007 12:45