Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 20-09-2009   #1
Join Date: Jul 2009
Posts: 10
Thanks: 0
Trader Rating: 0
No sound from car speakers -

Hey, basically all of a sudden my speakers completely cut out, it's in a 55sx punto with 2 front and 2 back speakers.

All I get now when i turn the radio on is a pop from the back left speaker then silnece. Radio is working fine, all controlsetc are working.

I understand it may be because a wire is shorting between the radio and the speaker, is this likely?

Also would that stop all the speaklers working ?

Any help would be greatly appreciated as I'm trying to avoid spending any money on repairs etc.

Thanks, Paul.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

thompsop07 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound Through Speakers (Stilo 1.2) redmond38 I.C.E 3 19-05-2009 17:47
engine sound coming out of speakers jonboy739 I.C.E 12 13-12-2008 17:36
Mono sound through both left and right speakers? jiggy I.C.E 5 25-02-2008 10:20
Expensive new speakers sound like s**te DotSPF I.C.E 5 17-08-2004 23:56
New speakers sound awful Trebor I.C.E 5 23-03-2004 17:49