Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools Search this Thread
Old 04-08-2016   #1
Join Date: Dec 2012
Posts: 24
Thanks: 0
Trader Rating: 0
United Kingdom 
Unhappy Help - wont start

Morning All,

So this morning my 58 plate Grande Punto wont start. (60k on clock)

History...
We have had an issue with the passenger side rear indicator cluster about 4weeks ago and replaced that no problem, for about a year or 2 had the problem that the fact it says the boot is open even when it isn't.

Went in for Full Service and MOT 2 and half weeks ago with local garage, no reported faults.

So on Monday morning i went to start the car and seemed a bit 'different' it did start but didnt sound as healthy, when turning from ignition to start all lights went off on dash, radio went off, needles dropped to zero and the made the sound that it locked(??).

It started though and then did the same again on Tuesday & Wednesday, this morning went to start the car and it did the above but didnt start at all, nothing, not even a attempt just a strange noise (like a click, click, click) i applied the accelerator and it flashed up for prob 0.2secs something about Radiator??

Help - im not too technical if you couldnt guess
__________________
Fiat Owner:
Fiat Punto 2001 -> Fiat Punto GP 2008 (58) -> ???

500 Abarth Competizione = DREAM

Last edited by Bale03; 04-08-2016 at 09:32. Reason: error
Bale03 is offline Reply With Quote Quote 
Old 04-08-2016   #2
Join Date: Jan 2013
Posts: 624
Thanks: 46
Trader Rating: 0
DGPunto has donated!
United Kingdom 
Re: Help - wont start

Sounds Battery related to me. The click can be the starter trying to engage with a flattish battery.


A few checks:
1. Check battery earths at both the battery and car ends
2. If you turn headlights on are they bright?
3. Check the battery is being charged - easiest to check voltage when the car is running (you might have to jump it from another car). You should see somewhere around 14v when running
4. Check battery voltage when the car is turned off - should be a little over 12v
5. Have you tried charging the battery?


If you're getting boot open when it isn't could the boot light be on draining the battery?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DGPunto is offline Reply With Quote Quote 
Old 05-08-2016   #3
Join Date: Apr 2015
Posts: 316
Thanks: 21
Trader Rating: 0
United Kingdom 
Re: Help - wont start

Sounds like an absolute classic earth strap fault. If you have some jump leads, put ONE of them from the battery negative terminal to the engine block (the top engine mount at the cam belt end is a good place). make sure contact is good and on to clean metal at each end.

Try and start it.

If that doesn't work, take a SECOND jump lead (leaving the first connected,) and run that one from the battery negative terminal to the BODYSHELL. Again, it will have to go to something that is clean metal and electrically connected to the bodyshell.

Try again to start it.

Report back and let us know what happens.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Avocet is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Uno Hard to start in the morning or after 5hrs or more (1st cranking but wont start) allan26 Members Motors 3 04-08-2015 10:41
(T) car cuts out and wont start ! and other car wont start also ! petrol and diesel waggy190 Multipla 7 06-12-2010 17:36
(T) Stilio 1.9JTD 02 Wont Start, Unless "engine start" is Used CraigLL Stilo 21 24-06-2010 21:41
car wont start without easy start spray??? machine125 FIAT Boo Archives 13 01-11-2007 21:49
(G) Wont start chris_mr2 Scudo 2 06-10-2007 20:04