Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools Search this Thread
Old 12-02-2011   #1
Join Date: Feb 2011
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Unhappy Wipers stopped working, Clicking fuse? & temp gage and rev counter not working?

Got in my car today after it been sat for about 4 weeks. The battery was flat but after a couple of cranks it got going. However went to go and use the wipers and they wont work. They seems to be a clicking noise coming from the fuse box. The rear wiper is working fine. Also the temperature gage and rev counter seem to have gone all strange. They do work sometimes, but they don't really move off the bottom. Is it just a fuse or what? Btw its a 2007 Grande Punto 1.2 Active 3d
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by JordanJ; 12-02-2011 at 00:29.
JordanJ is offline Reply With Quote Quote 
Old 12-02-2011   #2
Join Date: Aug 2007
Location: Scotland
Posts: 2,454
Thanks: 125
Trader Rating: 2
colin79666 has donated!
United Kingdom 
Re: Wipers stopped working, Clicking fuse? & temp gage and rev counter not working?

Give the battery a good charge then try again. Most likely it was just that there wasn't enough juice left to power the electrics.
__________________
colin79666 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Horn stopped working - fuse? Gav Punto (Mk2/2b) 19 27-08-2016 12:49
(G) sporting rev counter stopped working clock34 Cinquecento / Seicento 4 07-06-2010 19:26
(T) Sei Wipers stopped working Littala Cinquecento / Seicento 1 23-09-2007 09:41
(G) Wipers stopped working b.c Scudo 2 24-02-2007 16:16
(T) Front wipers stopped working danowat Cinquecento / Seicento 5 10-12-2005 17:41