Register Login
The UK's No.1 Chrysler Owners Forum
Comment
 
Guide Tools
<!-- google_ad_section_start -->Fast blinking indicator & indicator bulb not working<!-- google_ad_section_end -->
Fast blinking indicator & indicator bulb not working
No indicator bulb, fast blinking, blinking brake lights
Published by tjscotton
11-04-2015
Difficulty Level: 1

User Rated:Unrated

Show Printable Version  Email this Page 
The problem

So you may have washed your car or a heavy down pour has happened or nothing at all and you've got into the car, only to reach a turn and when you signal; the canbus bulb error comes up and your indicator goes into overdrive. Hopefully you haven't replaced the bulb just yet as its not necessarily the bulb - it could be a number of things, this guide will be looking at the multi-plug connector into the tail-light.

What you need;

- Philips head screw driver
- Something plastic and thin to lodge out the tail light
- Electrical contact cleaner / WD40
- Some fine grit sandpaper, I used 600
- A dry clean rag
- A beverage

For steps that involve checking to see if the bulb is working, you don't have to turn the hazards on every time - you can use the key fob to lock and unlock the car its a lot quicker.

Please note: This is a very simple job, this guide is aimed at people who wouldn't usually carry out car maintenance and hopefully keeps them away from Halfrauds at all costs! Feel free to comment further maintenance steps as I only go as far as cleaning the connections on the multi-plug.

Thanks varesecrazy thanked for this post
Likes Mscaldwell, mrmrblakey liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Contents
<< <    Next Page: Diagnosis (Page 1 of 4)    >  >>
Old 12-04-2015   #1
Join Date: Aug 2014
Posts: 105
Thanks: 4
Trader Rating: 0
mrmrblakey has donated!
United Kingdom 
Re: Fast blinking indicator & indicator bulb not working

I like it when a tutorial is put together as it should be, well done! It makes it so much more pleasing to read and all it takes is a little effort.
Good job and easy to follow tutorial!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mrmrblakey is offline Reply With Quote Quote 
Old 13-04-2015   #2
Join Date: Oct 2014
Location: North London / Derby
Posts: 250
Thanks: 13
Trader Rating: 0
United Kingdom 
Re: Fast blinking indicator & indicator bulb not working

thanks man i really appreciate it!
__________________
im on instagram (sometimes) @tjscotton

if your contemplating new wheels/colour change etc let me know and i'll be happy to do you a photoshop so you can see what it looks like
tjscotton is offline Reply With Quote Quote 
Old 03-09-2015   #3
Join Date: Aug 2013
Posts: 1
Thanks: 0
Trader Rating: 0
France 
Re: Fast blinking indicator & indicator bulb not working

Thank you. It helped a lot!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

cybobox is offline Reply With Quote Quote 
Old 09-09-2015   #4
Join Date: Jan 2008
Location: Hungary
Posts: 41
Thanks: 3
Trader Rating: 0
Hungary 
Re: Fast blinking indicator & indicator bulb not working

Hello,

same problem was here and for me the corrosion you mentioned was caused by the leakage of the rear washer flexible (it should be but it's rigid somehow) tube.

It's well worth taking the time to check...
__________________
Grande Punto 1.4 8V 77HP

Last edited by szasz; 09-09-2015 at 07:13.
szasz is offline Reply With Quote Quote 
Old 04-08-2016   #5
Join Date: Feb 2013
Location: Copenhagen
Posts: 13
Thanks: 0
Trader Rating: 0
Denmark 
Re: Fast blinking indicator & indicator bulb not working

Hi people.

I experience the problems you talk about, with the fastblinking indicator, and also the breaklight on my left rearside not working(Danish car)

I then desided to change the lights to test as recomended, and then all is working. on both sides of the car. When I then change back problem with fast blinking and breaklight occur again.

Is the trick then to use some sandpaper to get the connection working again?
I think it is strange that when I put the right lights in the left side, there are no problems.

Anyone, with an ide what to do? Do I need to go to an Autoelectritian, to have him look at it?

Thanks for a great forum!

Regards
The Starfish
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

The Starfish is offline Reply With Quote Quote 
Comment
Currently Active Users Viewing This Guide: 1 (0 members and 1 guests)
 
Guide Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Guide Guide Starter Category Comments Last Post
(T) Help Fast indicator maramark Punto (Mk2/2b) 1 08-11-2014 15:49
(T) Left indicator flashing fast when brakes pressed?? steverich Multipla 6 14-02-2012 17:56
(T) Fast Indicator Flashing johnny bravo Punto (Mk2/2b) 22 09-03-2009 21:21
Gearbox Indicator blinking... terry FIAT Boo Archives 1 08-04-2001 22:56