Register Login
iNETFX Domain Registration - COM/NET/ORG £6.50 a year!
 
 
Thread Tools
Old 11-01-2005   #1
Cynic-al
Guest
RE loss of power

Firstly, finally got my broadband connection working after resolving an error i made with the phone system wiring

Secondly, i while ago i posted re a loss of engine power, i had the car in at the garage, it was showing a faulty knock sensor, which i had fitted today, lets hope it solves the problem.

For those of you like me who do not know what a knock sensor is, it's a device that retards the timing if the engine is pinking, the theory goes that my sensor would randomly send a full signal causing a mass loss of power.

178 all in, there goes the christmas bonus
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #2
Anonymous
Guest
Re: RE loss of power

Your problem sounded similar to what i have...

I am hoping it will be something as cheap as a knock sensor, as a set of plug leads cost around 240 on a HGT!

Any idea on where it is located and if it can be tested?

Daz
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #3
Tom
Guest
Re: RE loss of power

Daz, if it works your engine runs fine, if its not working your engine don't work fine.

That simple really.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #4
cynic-al
Guest
Re: RE loss of power

there were two error codes when they read the car both relating to the knock sensor, cost me 25 to have it read though
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #5
Tom
Guest
Re: RE loss of power

But without knowing that you'd have spent over 25 swapping bits.

Nice to see a diag works once in a while.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #6
cynic-al
Guest
Re: RE loss of power

i agree, i'd be chasing that fault for ever, especially as i didn't know what the sensor was. lol
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #7
Tom
Guest
Re: RE loss of power

I would have hoped that the light would come on though... oh well.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 11-01-2005   #8
Anonymous
Guest
Re: RE loss of power

Does this sound like what you had Al?

My car runs fine when the light is off...

Any conditions...from cold, running hot, under load etc, etc...

Sometimes when i hit a bump, the light comes on, other times its at random.

As soon as the light comes on, i get a power loss

When i get the power loss its like the car is in 1 gear higher, i get a delay in throttle response (approx. 2 secs), then i get some of the power back.

The light doesnt go off on its own. But if i switch the engine off and restart it, its fine...

I know its not the right thing to do, but i have now got that fed up, as i am driving i just flick the key off and on, this takes less than a second and the car is then fine for a while.

If i do an ECU reset the light stays off for about a week.

Also it happens more when i have less fuel in the tank (not sure why?).

I have been waiting since the end of November for Fiat to get thier diag. machine back as its away being repaired and havent really got the time to take it to the next nearest Fiat garage which is 20-25 miles away...

Just hope its something cheapish/simple as i don't want to fork out circa 800 for a new ECU

Daz
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #9
Tom
Guest
Re: RE loss of power

Sounds more like a loose wire!

The knock sensor is normally easy to find, its usually bolted onto or into the block about halfway down. Although with the HGT having a front exit exhaust it may be under everything.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #10
Anonymous
Guest
Re: RE loss of power

Yep, my first though was a loose wire.

I have checked every wire i can get at, with no luck...still a high possibility though.

The first time i reset the ECU, the light didn't come on for 2 days (which is rare), after the 2 days i basically hit every pothole bump i could find to try and get it to come back on...which it didn't...great! problem solved i thought?...Nope, lol. A few days later it was back.

I can maybe understand why with the ECU reset would effect it, but cannot get my head around why the amount of fuel in the tank would effect it???

Full tank of fuel...it rarely comes on (once every other day)
Half a tank...once a day.
Less than 1/4...approx. every 30 mins of driving.

I have tried some dry fuel stuff, which seemed to help alot. I was thinking there was some water/condensation build up when my car was stood idle for a few months). Thus explaining why it was happening when the fuel was lower (as the water obviously would float on top of the fuel)...

Could be way off track, but worth a try IMO...

Daz
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #11
Tom
Guest
Re: RE loss of power

Hmm.. fuel vapour purge valve? Dodgey fuel pump?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #12
cynic-al
Guest
Re: RE loss of power

my car had no lights on the dash with the fault, it was like the car was in a higher gear all the time though, it didn't like passing 4000rpm, then the next day it would be ok. didnt notice any relation to the amount of fuel though.

i took it to a smaler garage to get it looked, didn't bother with fiat.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #13
Anonymous
Guest
Re: RE loss of power

Does your light work then Al?

Maybe it was coming on, but maybe your bulb is shot???

Mine doesnt like passing 4000rpm either and its very slow to get there, but only when the light is on...

Mine is also fine the next day as the engine has been switched off.

It does sound very similar symptons, but that could be just the ECU going into some sort of safe mode???

Daz
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #14
Tom
Guest
Re: RE loss of power

My guess would be when it starts its relearning process it ignores the knock sensor.

There are 2 sensors on the front of the 5 pot engine, both behind the manifold helpfully but looks like the connectors stick out the sides.

The fuel level thing still makes me think it may be another thing.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-01-2005   #15
cynic-al
Guest
Re: RE loss of power

most garages will put it on the machine for you, just tell them you want the error codes reading and you don't want them to replace the parts.

I think my bulb works, will look in the morning, but i think it comes on when i first put the key in, just remind me what should come up,

Battery, oil, handbrake if it's on, orange key and orange exhaust?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

 
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump