Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 28-02-2011   #1
Join Date: Feb 2011
Posts: 4
Thanks: 0
Trader Rating: 0
France 
ignition off but fan on - always

A friend has a 2002 1.2 Doblo.A/C
The low speed fan stays on, without keys, flattening the battery. A local mech said he'd sorted it by changing the temp sensor and fan resistor. All was good for 3 days when the battery still flattened. The car went to fiat who said they couldn't find a problem.
The car then came to me. I found that the temp sensor hasn't been changed( still factory jube clip with QA mark on it)However the temp gauge works fine, so I don't think this is the problem. The resistor may or may not have been changed(There was a screw missing but I beleive this only slows the motor down, so this shouldn't be the problem) When I disconnected the battery I heard a click and traced it to the low speed relay (no key in) When I checked the connections with the relay removed the signal feed to the relay is powered all the time. Thus, I've taken F6 out which does the low speed and checked that the normal fan still comes on so the engine won't overheat. This has cured the flat battery but I'd like to know what feeds the relay. I have read that it is something to do with the A/C. I'd like to cure the problem properly and refit the fuse. Any suggestions gratefully accepted.
Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

moizeau is offline Reply With Quote Quote 
Old 16-03-2011   #2
Join Date: Feb 2011
Posts: 4
Thanks: 0
Trader Rating: 0
France 
Re: ignition off but fan on - always

Anyone please
Any suggestion

Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

moizeau is offline Reply With Quote Quote 
Old 16-03-2011   #3
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: ignition off but fan on - always

you say the relay is constantly on, it is switched by the ECU.
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 18-03-2011   #4
Join Date: Feb 2011
Posts: 4
Thanks: 0
Trader Rating: 0
France 
Re: ignition off but fan on - always

Thanks for the response
That's the problem. I don't know what switches the relay. Is the ECU or the A/C?
There are know new fault codes after I cleared them and everything else works great!
Cheers again
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

moizeau is offline Reply With Quote Quote 
Old 18-03-2011   #5
Join Date: Feb 2011
Posts: 4
Thanks: 0
Trader Rating: 0
France 
Re: ignition off but fan on - always

What tells the ECU to switch the relay? There must be another sensor somewhere?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

moizeau is offline Reply With Quote Quote 
Old 18-03-2011   #6
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: ignition off but fan on - always

it will be the ECU but what is making the ECU trigger the fan is the question? If the coolant sensor is ok (as you say) then the ECU could be faulty or the wiring between ECU and relay shorted to earth. Quickest way to tell is when the fan is staying on and key is out of ignition disconnect the ECU, if fan stays on its wiring if not it's ECU/coolant sensor.
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) help.. radiator fan switches on and runs with ignition off! kettyaprilia Stilo 13 23-03-2015 13:09
(T) Fan working without keys in ignition volxstu Stilo 6 04-07-2010 00:47
(T) Rad fan punto mk2 need ignition on or not? psychocandy Punto (Mk2/2b) 0 09-09-2008 15:59
(G) Radiator fan on for few minutes after ignition turned off peter212693 Punto (Mk2/2b) 14 18-04-2008 00:20
(T) Cinq fan running when ignition off fingers99 Cinquecento / Seicento 9 23-09-2006 16:45